libxml2-python-32: dropped
This commit is contained in:
parent
10e1059571
commit
2a11c076ff
@ -1,9 +0,0 @@
|
||||
drwxr-xr-x root/root usr/
|
||||
drwxr-xr-x root/root usr/lib32/
|
||||
drwxr-xr-x root/root usr/lib32/python2.7/
|
||||
drwxr-xr-x root/root usr/lib32/python2.7/site-packages/
|
||||
-rw-r--r-- root/root usr/lib32/python2.7/site-packages/drv_libxml2.py
|
||||
-rw-r--r-- root/root usr/lib32/python2.7/site-packages/drv_libxml2.pyc
|
||||
-rw-r--r-- root/root usr/lib32/python2.7/site-packages/libxml2.py
|
||||
-rw-r--r-- root/root usr/lib32/python2.7/site-packages/libxml2.pyc
|
||||
-rwxr-xr-x root/root usr/lib32/python2.7/site-packages/libxml2mod.so
|
@ -1,6 +0,0 @@
|
||||
untrusted comment: verify with /etc/ports/compat-32.pub
|
||||
RWSwxGo/zH7eXY521nkP9Q7QsjwkA/0rAz6OYH0BhQfnPwkzKxxfXDC0HXDhfx7mKajJ6BRXQGPj67dVYlMjQJlf4jOVdNfctwc=
|
||||
SHA256 (Pkgfile) = e49ab8accc07a8531be0fd97cc9b07d6e57e6f3496fd4752637d0b05005d70e6
|
||||
SHA256 (.footprint) = ba4ac6881fb9d13fddfe9153c0cd81278640c1b352e383c72a791bc1a2e26a2e
|
||||
SHA256 (libxml2-2.9.10.tar.gz) = aafee193ffb8fe0c82d4afef6ef91972cbaf5feea100edc2f262750611b4be1f
|
||||
SHA256 (libxml2-python-config.patch) = 86c3ebf2f5af78bdddcf885fb18bb21e0c4277a9321802270eda7deff1d347b4
|
@ -1,35 +0,0 @@
|
||||
# Description: Python bindings for the XML library version 2
|
||||
# URL: http://xmlsoft.org/
|
||||
# Maintainer: CRUX compat-32 Team, compat-32-ports at crux dot nu
|
||||
# Depends on: libxml2-32 libxml2-python python-32
|
||||
|
||||
name=libxml2-python-32
|
||||
version=2.9.10
|
||||
release=1
|
||||
source=(http://xmlsoft.org/sources/libxml2-$version.tar.gz
|
||||
libxml2-python-config.patch)
|
||||
|
||||
build() {
|
||||
cd libxml2-$version
|
||||
|
||||
patch -p1 -i $SRC/libxml2-python-config.patch
|
||||
|
||||
# --libdir=/usr/lib32 is unpredictable version 2.9.1 and 2.9.2
|
||||
./configure --prefix=/usr --libdir=/usr/lib32
|
||||
cd python
|
||||
|
||||
make
|
||||
make DESTDIR=$PKG install
|
||||
|
||||
# --libdir is not to be trusted some sort of race at configure
|
||||
# library will either end up in lib or lib32 depending on mood
|
||||
# if [ -e $PKG/usr/lib ]; then
|
||||
# mv $PKG/usr/lib $PKG/usr/lib32
|
||||
# fi
|
||||
|
||||
rm $PKG/usr/lib32/python2.7/site-packages/libxml2mod.{a,la}
|
||||
rm -r $PKG/usr/share/doc
|
||||
rmdir $PKG/usr/share
|
||||
|
||||
python -mcompileall $PKG/usr/lib32/python2.7/
|
||||
}
|
@ -1,12 +0,0 @@
|
||||
diff -Nru libxml2-2.9.2.orig/python/Makefile.in libxml2-2.9.2/python/Makefile.in
|
||||
--- libxml2-2.9.2.orig/python/Makefile.in 2014-10-17 12:04:08.614853413 +0200
|
||||
+++ libxml2-2.9.2/python/Makefile.in 2014-10-17 12:04:25.037581668 +0200
|
||||
@@ -495,7 +495,7 @@
|
||||
@WITH_PYTHON_TRUE@python_LTLIBRARIES = libxml2mod.la
|
||||
@WITH_PYTHON_TRUE@libxml2mod_la_SOURCES = libxml.c libxml_wrap.h libxml2-py.h libxml2-py.c types.c
|
||||
@WITH_PYTHON_TRUE@libxml2mod_la_LDFLAGS = $(CYGWIN_EXTRA_LDFLAGS) $(WIN32_EXTRA_LDFLAGS) -module -avoid-version \
|
||||
-@WITH_PYTHON_TRUE@ $(top_builddir)/libxml2.la $(CYGWIN_EXTRA_PYTHON_LIBADD) $(WIN32_EXTRA_PYTHON_LIBADD) $(PYTHON_LIBS)
|
||||
+@WITH_PYTHON_TRUE@ $(libdir)/libxml2.la $(CYGWIN_EXTRA_PYTHON_LIBADD) $(WIN32_EXTRA_PYTHON_LIBADD) $(PYTHON_LIBS)
|
||||
|
||||
@WITH_PYTHON_TRUE@BUILT_SOURCES = libxml2-export.c libxml2-py.h libxml2-py.c
|
||||
@WITH_PYTHON_TRUE@dist_python_DATA = \
|
Loading…
x
Reference in New Issue
Block a user