libdbusmenu-gtk2-32: updated source, added patches
This commit is contained in:
parent
aca4b3699d
commit
2e79611b90
@ -5,7 +5,5 @@ drwxr-xr-x root/root usr/lib32/
|
|||||||
lrwxrwxrwx root/root usr/lib32/libdbusmenu-gtk.so -> libdbusmenu-gtk.so.4.0.12
|
lrwxrwxrwx root/root usr/lib32/libdbusmenu-gtk.so -> libdbusmenu-gtk.so.4.0.12
|
||||||
lrwxrwxrwx root/root usr/lib32/libdbusmenu-gtk.so.4 -> libdbusmenu-gtk.so.4.0.12
|
lrwxrwxrwx root/root usr/lib32/libdbusmenu-gtk.so.4 -> libdbusmenu-gtk.so.4.0.12
|
||||||
-rwxr-xr-x root/root usr/lib32/libdbusmenu-gtk.so.4.0.12
|
-rwxr-xr-x root/root usr/lib32/libdbusmenu-gtk.so.4.0.12
|
||||||
drwxr-xr-x root/root usr/lib32/libdbusmenu-gtk2-32/
|
|
||||||
-rwxr-xr-x root/root usr/lib32/libdbusmenu-gtk2-32/dbusmenu-bench
|
|
||||||
drwxr-xr-x root/root usr/lib32/pkgconfig/
|
drwxr-xr-x root/root usr/lib32/pkgconfig/
|
||||||
-rw-r--r-- root/root usr/lib32/pkgconfig/dbusmenu-gtk-0.4.pc
|
-rw-r--r-- root/root usr/lib32/pkgconfig/dbusmenu-gtk-0.4.pc
|
||||||
|
@ -1,6 +1,8 @@
|
|||||||
untrusted comment: verify with /etc/ports/compat-32.pub
|
untrusted comment: verify with /etc/ports/compat-32.pub
|
||||||
RWSwxGo/zH7eXVH1msgOj6KUjB6G0cHQr7vttfpIt2oFc24jtl6o0zLVTIDRU0UVw3avGMnNMRwsDc2P/kSdpGmjGnLoGZiQeQs=
|
RWSwxGo/zH7eXVIrjb2gzvgS2AUHmapuQ9iiUPWq6+P3ggitaPDWsZMpPuiH5xmEpN6rXMWotuUuqDsdJwGVya73kC+4CHY+iQo=
|
||||||
SHA256 (Pkgfile) = 42d3d7cdece610507bd24ef77c0cc34791a55eadf31db6b0830ab179afde1809
|
SHA256 (Pkgfile) = 666236ab15fd9e47cbeb504fcae5478c803198c80e72271ec3a9f4d17642feea
|
||||||
SHA256 (.footprint) = e07a60f85539724566166f2f51bb0a7a25fa3ca71c1e45155bc8592f19f17ab3
|
SHA256 (.footprint) = 98b89cd7d4212567a76a3dab3b477aa84b48e68cbf1cc8e9d8fc2d880b3560b5
|
||||||
SHA256 (libdbusmenu_18.10.20180917~bzr490+repack1.orig.tar.xz) = f670bc86ea5ae1488b2405f371ceb870ce353127578f9b0aed2862cbbc42053b
|
SHA256 (libdbusmenu_18.10.20180917~bzr492+repack1.orig.tar.xz) = 41298b926573419f21864205317461750b833c596af6ab0bd206e13336f8cee3
|
||||||
SHA256 (0001_no-deprecated-gnome-common-macros.patch) = a65626ad3dd26a81037332d881736587929c7f8935cd34d2fc3e7f4a988d5a72
|
SHA256 (0001_no-deprecated-gnome-common-macros.patch) = a65626ad3dd26a81037332d881736587929c7f8935cd34d2fc3e7f4a988d5a72
|
||||||
|
SHA256 (0003_port-tools-dbusmenu-bench-to-py3.patch) = 5596fa1d311e80e780af9d2453e1b81f2b9604bb9894333c51a1361f41778919
|
||||||
|
SHA256 (0004_prevent-test-json-from-failing.patch) = 42f61f6b2a9c3e355a21f3fc8f9583963704e8c299b0f12c07499e41ce99c992
|
||||||
|
@ -0,0 +1,92 @@
|
|||||||
|
Description: Port tools/dbusmenu-bench from Py2 to Py3.
|
||||||
|
Author: Mike Gabriel <mike.gabriel@das-netzwerkteam.de>
|
||||||
|
|
||||||
|
--- a/tools/dbusmenu-bench
|
||||||
|
+++ b/tools/dbusmenu-bench
|
||||||
|
@@ -1,4 +1,4 @@
|
||||||
|
-#!/usr/bin/env python
|
||||||
|
+#!/usr/bin/env python3
|
||||||
|
# encoding: utf-8
|
||||||
|
"""
|
||||||
|
A library to communicate a menu object set accross DBus and
|
||||||
|
@@ -60,8 +60,8 @@
|
||||||
|
|
||||||
|
|
||||||
|
def dump_properties(properties, prepend=""):
|
||||||
|
- for key, value in properties.items():
|
||||||
|
- print "%s- %s: %s" % (prepend, key, value)
|
||||||
|
+ for key, value in list(properties.items()):
|
||||||
|
+ print("%s- %s: %s" % (prepend, key, value))
|
||||||
|
|
||||||
|
|
||||||
|
def run_test_sequence(menu, dump=False):
|
||||||
|
@@ -74,9 +74,9 @@
|
||||||
|
revision, layout = menu.GetLayout(dbus.Int32(0))
|
||||||
|
times["GetLayout"] = chrono.elapsed()
|
||||||
|
if dump:
|
||||||
|
- print "revision:", revision
|
||||||
|
- print "layout:"
|
||||||
|
- print layout
|
||||||
|
+ print("revision:", revision)
|
||||||
|
+ print("layout:")
|
||||||
|
+ print(layout)
|
||||||
|
|
||||||
|
# Get ids
|
||||||
|
tree = ET.fromstring(layout)
|
||||||
|
@@ -89,27 +89,27 @@
|
||||||
|
children = menu.GetChildren(dbus.Int32(root_id), property_names)
|
||||||
|
times["GetChildren"] = chrono.elapsed()
|
||||||
|
if dump:
|
||||||
|
- print "children:"
|
||||||
|
+ print("children:")
|
||||||
|
for child in children:
|
||||||
|
id, properties = child
|
||||||
|
- print "- %d:" % id
|
||||||
|
+ print("- %d:" % id)
|
||||||
|
dump_properties(properties, prepend=" ")
|
||||||
|
|
||||||
|
chrono.restart()
|
||||||
|
properties = menu.GetProperties(dbus.Int32(child_id), property_names)
|
||||||
|
times["GetProperties"] = chrono.elapsed()
|
||||||
|
if dump:
|
||||||
|
- print "properties:"
|
||||||
|
+ print("properties:")
|
||||||
|
dump_properties(properties)
|
||||||
|
|
||||||
|
return times
|
||||||
|
|
||||||
|
def create_timing_dict():
|
||||||
|
- return dict(zip(PROBES, itertools.repeat(0)))
|
||||||
|
+ return dict(list(zip(PROBES, itertools.repeat(0))))
|
||||||
|
|
||||||
|
def print_probe(prefix, name, value, timestamp):
|
||||||
|
value = int(value * 1000000)
|
||||||
|
- print "%(prefix)s.%(name)s:%(value)d@%(timestamp)d" % locals()
|
||||||
|
+ print("%(prefix)s.%(name)s:%(value)d@%(timestamp)d" % locals())
|
||||||
|
|
||||||
|
def main():
|
||||||
|
parser = OptionParser(usage = "%prog [options]")
|
||||||
|
@@ -134,7 +134,7 @@
|
||||||
|
max_timings = create_timing_dict()
|
||||||
|
for x in range(options.count):
|
||||||
|
timings = run_test_sequence(menu)
|
||||||
|
- for name, timing in timings.items():
|
||||||
|
+ for name, timing in list(timings.items()):
|
||||||
|
cumulated_timings[name] += timing
|
||||||
|
if min_timings[name] == 0 or min_timings[name] > timing:
|
||||||
|
min_timings[name] = timing
|
||||||
|
@@ -142,11 +142,11 @@
|
||||||
|
max_timings[name] = timing
|
||||||
|
|
||||||
|
timestamp = int(time.time())
|
||||||
|
- for name, timing in cumulated_timings.items():
|
||||||
|
+ for name, timing in list(cumulated_timings.items()):
|
||||||
|
print_probe("average", name, timing / options.count, timestamp)
|
||||||
|
- for name, timing in min_timings.items():
|
||||||
|
+ for name, timing in list(min_timings.items()):
|
||||||
|
print_probe("min", name, timing, timestamp)
|
||||||
|
- for name, timing in max_timings.items():
|
||||||
|
+ for name, timing in list(max_timings.items()):
|
||||||
|
print_probe("max", name, timing, timestamp)
|
||||||
|
|
||||||
|
return 0
|
@ -0,0 +1,14 @@
|
|||||||
|
Origin: https://bazaar.launchpad.net/~dbusmenu-team/libdbusmenu/trunk.16.10/revision/497/tests/Makefile.am#tests/Makefile.am
|
||||||
|
|
||||||
|
=== modified file 'tests/Makefile.am'
|
||||||
|
--- a/tests/Makefile.am 2019-09-13 16:53:05 +0000
|
||||||
|
+++ b/tests/Makefile.am 2022-09-28 21:56:18 +0000
|
||||||
|
@@ -219,6 +219,7 @@
|
||||||
|
@echo export G_MESSAGES_DEBUG=all >> $@
|
||||||
|
@echo $(XVFB_RUN) >> $@
|
||||||
|
@echo $(DBUS_RUNNER) --task ./test-json-client --wait-for org.dbusmenu.test --task-name Client --parameter $(top_builddir)/tools/dbusmenu-dumper --parameter test-json-01.output.json --task ./test-json-server --task-name Server --parameter $(srcdir)/test-json-01.json >> $@
|
||||||
|
+ @echo sed -i \"/Using cross-namespace EXTERNAL authentication \(this will deadlock if server is GDBus \< 2.73.3\)/d\" test-json-01.output.json >> $@
|
||||||
|
@echo diff $(srcdir)/test-json-01.json test-json-01.output.json \> /dev/null >> $@
|
||||||
|
@chmod +x $@
|
||||||
|
|
||||||
|
|
@ -5,20 +5,27 @@
|
|||||||
|
|
||||||
name=libdbusmenu-gtk2-32
|
name=libdbusmenu-gtk2-32
|
||||||
version=18.10
|
version=18.10
|
||||||
release=1
|
release=2
|
||||||
source=(http://cdn-fastly.deb.debian.org/debian/pool/main/libd/libdbusmenu/libdbusmenu_18.10.20180917~bzr490+repack1.orig.tar.xz
|
source=(http://cdn-fastly.deb.debian.org/debian/pool/main/libd/libdbusmenu/libdbusmenu_18.10.20180917~bzr492+repack1.orig.tar.xz
|
||||||
0001_no-deprecated-gnome-common-macros.patch)
|
0001_no-deprecated-gnome-common-macros.patch
|
||||||
|
0003_port-tools-dbusmenu-bench-to-py3.patch
|
||||||
|
0004_prevent-test-json-from-failing.patch)
|
||||||
|
|
||||||
build() {
|
build() {
|
||||||
|
cd libdbusmenu-18.10.20180917~bzr492
|
||||||
|
|
||||||
export PKG_CONFIG_LIBDIR='/usr/lib32/pkgconfig:/usr/share/pkgconfig'
|
export PKG_CONFIG_LIBDIR='/usr/lib32/pkgconfig:/usr/share/pkgconfig'
|
||||||
export HAVE_VALGRIND_TRUE='#'
|
export HAVE_VALGRIND_TRUE='#'
|
||||||
export HAVE_VALGRIND_FALSE=''
|
export HAVE_VALGRIND_FALSE=''
|
||||||
|
|
||||||
cd libdbusmenu-18.10.20180917~bzr490
|
|
||||||
patch -Np1 -i $SRC/0001_no-deprecated-gnome-common-macros.patch
|
patch -Np1 -i $SRC/0001_no-deprecated-gnome-common-macros.patch
|
||||||
|
patch -Np1 -i $SRC/0003_port-tools-dbusmenu-bench-to-py3.patch
|
||||||
|
patch -Np1 -i $SRC/0004_prevent-test-json-from-failing.patch
|
||||||
|
|
||||||
sed -e 's/-Werror -Wno-error=deprecated-declarations//g' -i libdbusmenu-{glib,gtk}/Makefile.am
|
sed -e 's/-Werror -Wno-error=deprecated-declarations//g' -i libdbusmenu-{glib,gtk}/Makefile.am
|
||||||
sed -e 's/gtkdocize || exit 1//g' -i autogen.sh
|
sed -e 's/gtkdocize || exit 1//g' -i autogen.sh
|
||||||
sed -e 's/--enable-gtk-doc//g' -i autogen.sh
|
sed -e 's/--enable-gtk-doc//g' -i autogen.sh
|
||||||
|
|
||||||
./autogen.sh --prefix=/usr \
|
./autogen.sh --prefix=/usr \
|
||||||
--sysconfdir=/etc \
|
--sysconfdir=/etc \
|
||||||
--libdir=/usr/lib32 \
|
--libdir=/usr/lib32 \
|
||||||
@ -27,10 +34,8 @@ build() {
|
|||||||
--disable-{dumper,tests,vala,nls} \
|
--disable-{dumper,tests,vala,nls} \
|
||||||
--with-gtk=2
|
--with-gtk=2
|
||||||
make -j1
|
make -j1
|
||||||
make DESTDIR=$PKG -j1 install
|
make DESTDIR=$PKG -C libdbusmenu-gtk install
|
||||||
make DESTDIR=$PKG -C libdbusmenu-glib -j1 uninstall
|
|
||||||
|
|
||||||
# mv $PKG/usr/lib/girepository-1.0 $PKG/usr/lib32
|
|
||||||
rm -fr $PKG/usr/{lib,include,share}
|
rm -fr $PKG/usr/{lib,include,share}
|
||||||
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
|
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
|
||||||
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
||||||
|
Loading…
x
Reference in New Issue
Block a user