[notify] libappindicator-sharp-32: might need manual downgrade! updated source
This commit is contained in:
parent
ff2fcf9c38
commit
6f05ea3ab5
@ -1,14 +1,10 @@
|
||||
untrusted comment: verify with /etc/ports/compat-32.pub
|
||||
RWSwxGo/zH7eXTa/ZVltRcVi1fU7pBGwJ3jPyGhEYMTSehtckff6+ZuCKpvg1ftHPaup8WNM5RaZSal49Gbg+pxmQsf5XF7Y9As=
|
||||
SHA256 (Pkgfile) = 71b71d90cb38339e30ef8578314bb5b6672b55be256e11fd2a1ae5b15e0a9c6e
|
||||
RWSwxGo/zH7eXeSnAJiN8VcIlVguDasp0Izx+0qVWajxZ0xgI4jfDvBhunwx81irikST49Wru9zDrV7X8Jle5ndsJPebxXWGfwQ=
|
||||
SHA256 (Pkgfile) = fb02933fa79e84ab78550bc4ea52d1123af9d9f06bdd0ce41b9c5eb02dee9c99
|
||||
SHA256 (.footprint) = 1738e72615e69d301cf39f11b475cca30834689cc6b67c45178a8c4ab51a277e
|
||||
SHA256 (libappindicator-16.10.tar.gz) = f33e0e06096fa8f8ca560ffcd84b8eb64830fa7308b30964c77bd5f45d0c497e
|
||||
SHA256 (libappindicator_12.10.1+20.10.20200706.1.orig.tar.gz) = 94e7096a49c400628ecddcafe313d63bf917d95a90ab994930909de724604e0a
|
||||
SHA256 (0001-Glib.Timeout-fix.patch) = bc7e3d5db0b9b324dc072f807519547fdc2c96514eb17aa07a71117a787d9b80
|
||||
SHA256 (0002-Fix-mono-nunit-pkgconfig-name.patch) = d60af265af61cf429158267b391c377adb8ee8a24f0cef72c3f10f202cec6c6f
|
||||
SHA256 (0003-Fix-Mono-assemblies-directory.patch) = d923cab3e2704758ce4d41c356e2822234f291f202fce6c3db12daec46f1e8ac
|
||||
SHA256 (badfunction.patch) = f4959649db01aada1fe303e2a3de1eac0b303955d69129f84a492771d600c808
|
||||
SHA256 (conditional-py-bindings.patch) = 40dc073f3825ff53ae16e3e37411bde2b70a9d9b89f8e8c85885e779b32d7260
|
||||
SHA256 (disable-mono.patch) = 3ec51b8923a65d8d71374977206239dd511a1775a60e3d72ca9f2b3b8f136ab8
|
||||
SHA256 (gtk3.patch) = 39fc14496fa491c933f224c6a977a23343d0daeebd93911f3538c29f1bf69407
|
||||
SHA256 (improved-plasma-support.patch) = c199e075fef864eb9a24845986f5486ee3a4cc30f9209b417eaa005cf5dc98a4
|
||||
SHA256 (vala-inherit.patch) = 77635b7b5bc0686577a191e0ac78dcfba79f5e5695b6b72cae7c412e59bc736d
|
||||
|
@ -4,22 +4,16 @@
|
||||
# Depends on: libappindicator-gtk2-32 libappindicator-sharp
|
||||
|
||||
name=libappindicator-sharp-32
|
||||
version=16.10
|
||||
version=12.10
|
||||
release=1
|
||||
source=(http://unrealize.co.uk/source/libappindicator-16.10.tar.gz
|
||||
source=(http://archive.ubuntu.com/ubuntu/pool/universe/liba/libappindicator/libappindicator_12.10.1+20.10.20200706.1.orig.tar.gz
|
||||
0001-Glib.Timeout-fix.patch
|
||||
0002-Fix-mono-nunit-pkgconfig-name.patch
|
||||
0003-Fix-Mono-assemblies-directory.patch
|
||||
badfunction.patch
|
||||
conditional-py-bindings.patch
|
||||
disable-mono.patch
|
||||
gtk3.patch
|
||||
improved-plasma-support.patch
|
||||
vala-inherit.patch)
|
||||
improved-plasma-support.patch)
|
||||
|
||||
build() {
|
||||
cd libappindicator-$version
|
||||
|
||||
# The next 3 patches shamelessly pinched from Arch
|
||||
patch -p1 -i $SRC/0001-Glib.Timeout-fix.patch
|
||||
patch -p1 -i $SRC/0002-Fix-mono-nunit-pkgconfig-name.patch
|
||||
@ -28,15 +22,12 @@ build() {
|
||||
# This one is also from Arch(ish), but had to be recreated best it could
|
||||
patch -p1 -i $SRC/improved-plasma-support.patch
|
||||
|
||||
# Patch pinched from Gentoo
|
||||
patch -p1 -i $SRC/conditional-py-bindings.patch
|
||||
|
||||
# Removed a function which had no declaration
|
||||
patch -p1 -i $SRC/badfunction.patch
|
||||
|
||||
sed -i -e 's/ -Werror//' src/Makefile.am
|
||||
export PKG_CONFIG_LIBDIR='/usr/lib32/pkgconfig:/usr/lib/pkgconfig:/usr/share/pkgconfig'
|
||||
export CSC='/usr/bin/mcs'
|
||||
export PKG_CONFIG_LIBDIR='/usr/lib32/pkgconfig:/usr/lib/pkgconfig:/usr/share/pkgconfig'
|
||||
NOCONFIGURE=1 ./autogen.sh
|
||||
|
||||
CXXFLAGS="$CXXFLAGS -std=c++11" \
|
||||
@ -53,6 +44,4 @@ build() {
|
||||
make
|
||||
make DESTDIR=$PKG -C bindings/mono -j1 install
|
||||
mv $PKG/usr/lib/mono $PKG/usr/lib32/mono
|
||||
|
||||
# rm -r $PKG/usr/{lib,include,share}
|
||||
}
|
||||
|
@ -1,72 +0,0 @@
|
||||
--- a/bindings/Makefile.am 2015-07-10 10:04:18.091199191 +0200
|
||||
+++ b/bindings/Makefile.am 2015-07-10 10:19:47.047974439 +0200
|
||||
@@ -3,8 +3,10 @@
|
||||
vala
|
||||
else
|
||||
SUBDIRS = \
|
||||
- python \
|
||||
vala
|
||||
+if HAS_PYTHON
|
||||
+SUBDIRS += python
|
||||
+endif
|
||||
endif
|
||||
|
||||
if HAS_MONO
|
||||
--- a/configure.ac 2015-07-16 13:28:41.007502838 +0200
|
||||
+++ b/configure.ac_new 2015-07-16 13:53:18.118602877 +0200
|
||||
@@ -188,25 +188,37 @@
|
||||
PYGTK_REQUIRED=2.14.0
|
||||
PYGOBJECT_REQUIRED=0.22
|
||||
|
||||
-AM_PATH_PYTHON(2.3.5)
|
||||
-AM_CHECK_PYTHON_HEADERS(,[AC_MSG_ERROR(could not find Python headers)])
|
||||
+AC_ARG_ENABLE([python],
|
||||
+ AC_HELP_STRING([--enable-python], [Enable python for GTK2 build]),,
|
||||
+ [enable_python=yes])
|
||||
|
||||
-PKG_CHECK_MODULES(APPINDICATOR_PYTHON,
|
||||
+if test x"$with_gtk" = x"3" ; then
|
||||
+ enable_python=no
|
||||
+fi
|
||||
+
|
||||
+AM_CONDITIONAL(HAS_PYTHON, test x"${enable_python}" != x"no")
|
||||
+
|
||||
+if test x"$enable_python" != x"no" ; then
|
||||
+ AM_PATH_PYTHON(2.3.5)
|
||||
+ AM_CHECK_PYTHON_HEADERS(,[AC_MSG_ERROR(could not find Python headers)])
|
||||
+
|
||||
+ PKG_CHECK_MODULES(APPINDICATOR_PYTHON,
|
||||
[
|
||||
pygtk-2.0 >= $PYGTK_REQUIRED
|
||||
gtk+-2.0 >= $GTK_REQUIRED_VERSION
|
||||
pygobject-2.0 >= $PYGOBJECT_REQUIRED
|
||||
])
|
||||
|
||||
-AC_MSG_CHECKING(for pygtk defs)
|
||||
-PYGTK_DEFSDIR=`$PKG_CONFIG --variable=defsdir pygtk-2.0`
|
||||
-AC_SUBST(PYGTK_DEFSDIR)
|
||||
-AC_MSG_RESULT($PYGTK_DEFSDIR)
|
||||
-
|
||||
-AC_MSG_CHECKING(for pygtk codegen)
|
||||
-PYGTK_CODEGEN="$PYTHON `$PKG_CONFIG --variable=codegendir pygtk-2.0`/codegen.py"
|
||||
-AC_SUBST(PYGTK_CODEGEN)
|
||||
-AC_MSG_RESULT($PYGTK_CODEGEN)
|
||||
+ AC_MSG_CHECKING(for pygtk defs)
|
||||
+ PYGTK_DEFSDIR=`$PKG_CONFIG --variable=defsdir pygtk-2.0`
|
||||
+ AC_SUBST(PYGTK_DEFSDIR)
|
||||
+ AC_MSG_RESULT($PYGTK_DEFSDIR)
|
||||
+
|
||||
+ AC_MSG_CHECKING(for pygtk codegen)
|
||||
+ PYGTK_CODEGEN="$PYTHON `$PKG_CONFIG --variable=codegendir pygtk-2.0`/codegen.py"
|
||||
+ AC_SUBST(PYGTK_CODEGEN)
|
||||
+ AC_MSG_RESULT($PYGTK_CODEGEN)
|
||||
+fi
|
||||
|
||||
#########################
|
||||
# Check if build tests
|
||||
@@ -278,4 +290,5 @@
|
||||
Tests: $enable_tests
|
||||
Mono tests: $have_nunit
|
||||
gcov: $use_gcov
|
||||
+ Python: $enable_python
|
||||
])
|
@ -1,21 +0,0 @@
|
||||
diff -Naur a/configure.ac b/configure.ac
|
||||
--- a/configure.ac 2017-10-23 14:05:48.291548000 +0000
|
||||
+++ b/configure.ac 2017-10-23 15:37:41.434800880 +0000
|
||||
@@ -104,7 +104,7 @@
|
||||
# Check for Mono support
|
||||
###########################
|
||||
|
||||
-MONO_REQUIRED_VERSION=1.0
|
||||
+MONO_REQUIRED_VERSION=9999
|
||||
PKG_CHECK_MODULES(MONO_DEPENDENCY, mono >= $MONO_REQUIRED_VERSION, has_mono=true, has_mono=false)
|
||||
AM_CONDITIONAL(HAS_MONO, [test "x$has_mono" = "xtrue"])
|
||||
|
||||
@@ -143,7 +143,7 @@
|
||||
AC_SUBST(GENERATED_SOURCES)
|
||||
|
||||
GLIB_SHARP_REQ_VERSION=2.12.1
|
||||
-GTK_SHARP_REQ_VERSION=2.12
|
||||
+GTK_SHARP_REQ_VERSION=9999
|
||||
PKG_CHECK_MODULES(GTK_SHARP, gtk-sharp-2.0 >= $GTK_SHARP_REQ_VERSION, has_gtksharp=true, has_gtksharp=false)
|
||||
|
||||
PKG_CHECK_MODULES(GAPI, gapi-2.0 >= $GLIB_SHARP_REQ_VERSION, has_gapi=true, has_gapi=false)
|
@ -1,9 +0,0 @@
|
||||
diff -Naur a/autogen.sh b/autogen.sh
|
||||
--- a/autogen.sh 2017-10-23 08:03:29.000000000 +0100
|
||||
+++ b/autogen.sh 2017-10-23 10:26:05.918283577 +0100
|
||||
@@ -10,4 +10,4 @@
|
||||
gtkdocize || exit 1
|
||||
USE_GNOME2_MACROS=1 \
|
||||
USE_COMMON_DOC_BUILD=yes \
|
||||
-gnome-autogen.sh --enable-gtk-doc $@
|
||||
+gnome-autogen.sh --enable-gtk-doc --with-gtk=3 $@
|
@ -1,14 +0,0 @@
|
||||
# http://bazaar.launchpad.net/~indicator-applet-developers/libappindicator/trunk.12.10/revision/244
|
||||
=== modified file 'bindings/vala/appindicator-0.1-custom.vala'
|
||||
--- a/bindings/vala/appindicator-0.1-custom.vala 2011-09-23 15:46:27 +0000
|
||||
+++ b/bindings/vala/appindicator-0.1-custom.vala 2012-10-10 23:33:35 +0000
|
||||
@@ -23,7 +23,7 @@
|
||||
*/
|
||||
|
||||
namespace AppIndicator {
|
||||
- [CCode (type_check_function = "IS_APP_INDICATOR")]
|
||||
+ [CCode (type_check_function = "IS_APP_INDICATOR", type_id = "app_indicator_get_type ()")]
|
||||
public class Indicator : GLib.Object {
|
||||
}
|
||||
}
|
||||
|
Loading…
x
Reference in New Issue
Block a user