libcap-32: 2.25 -> 2.26
This commit is contained in:
parent
75329f1ed7
commit
ae0d47e35a
@ -2,7 +2,7 @@ drwxr-xr-x root/root usr/
|
||||
drwxr-xr-x root/root usr/lib32/
|
||||
-rw-r--r-- root/root usr/lib32/libcap.a
|
||||
lrwxrwxrwx root/root usr/lib32/libcap.so -> libcap.so.2
|
||||
lrwxrwxrwx root/root usr/lib32/libcap.so.2 -> libcap.so.2.25
|
||||
-rw-r--r-- root/root usr/lib32/libcap.so.2.25
|
||||
lrwxrwxrwx root/root usr/lib32/libcap.so.2 -> libcap.so.2.26
|
||||
-rw-r--r-- root/root usr/lib32/libcap.so.2.26
|
||||
drwxr-xr-x root/root usr/lib32/pkgconfig/
|
||||
-rw-r--r-- root/root usr/lib32/pkgconfig/libcap.pc
|
||||
|
@ -1,6 +1,5 @@
|
||||
untrusted comment: verify with /etc/ports/compat-32.pub
|
||||
RWSwxGo/zH7eXcJ75eaPuvzqwm1D2/WZT8697vL7kTC8iA4H+wfZpSRllXkPHsK+LXUF5H3OKUYx61qfcNHM4xtCAYfmuwWM9Ao=
|
||||
SHA256 (Pkgfile) = aa4486386b4eb6fce7bee27c4b6162659aaba7877441ef8b5bb0a77df6268eda
|
||||
SHA256 (.footprint) = f73f509f131affbad702db18fb632758ca5407628da843f10027a79e8786ca67
|
||||
SHA256 (libcap-2.25.tar.xz) = 693c8ac51e983ee678205571ef272439d83afe62dd8e424ea14ad9790bc35162
|
||||
SHA256 (libcap-2.25-gperf.patch) = b435d629f4dcd53ba0b230ae6bc42708a155826b5ea350387e70594ee6a04b04
|
||||
RWSwxGo/zH7eXX6uta7qr1+ukqnday995Z2lAOH9NzOsDALNbBCxkRCddX7lspiwLl6aq3jEN59cBagPMXJ8Uu0kgj7Fltk28Q8=
|
||||
SHA256 (Pkgfile) = 5087e47a00099542e5ee268775cad9cfc513882750eddc1a527e3935145d8333
|
||||
SHA256 (.footprint) = beb68daa15f3d5ad1feca863d152da69dde93214cea66273ca24baba09f65d24
|
||||
SHA256 (libcap-2.26.tar.xz) = b630b7c484271b3ba867680d6a14b10a86cfa67247a14631b14c06731d5a458b
|
||||
|
@ -4,15 +4,13 @@
|
||||
# Depends on: attr-32
|
||||
|
||||
name=libcap-32
|
||||
version=2.25
|
||||
release=2
|
||||
source=(https://www.kernel.org/pub/linux/libs/security/linux-privs/libcap2/${name%-*}-$version.tar.xz
|
||||
${name%-*}-$version-gperf.patch)
|
||||
version=2.26
|
||||
release=1
|
||||
source=(https://www.kernel.org/pub/linux/libs/security/linux-privs/libcap2/${name%-*}-$version.tar.xz)
|
||||
|
||||
build() {
|
||||
cd ${name%-*}-$version
|
||||
|
||||
patch -p1 -i $SRC/${name%-*}-$version-gperf.patch
|
||||
sed -i "/^CFLAGS/s/-O2/$CFLAGS/" Make.Rules
|
||||
|
||||
make -C libcap
|
||||
|
@ -1,31 +0,0 @@
|
||||
From 13992f56d80c0ee20e08f99b8e8ff37d63e65f9d Mon Sep 17 00:00:00 2001
|
||||
From: Mike Gilbert <floppym@gentoo.org>
|
||||
Date: Mon, 16 Jan 2017 12:09:35 -0500
|
||||
Subject: [PATCH] Fix build with gperf-3.1
|
||||
|
||||
gperf-3.1 lookup functions take a size_t instead of unsigned int.
|
||||
|
||||
To resolve this:
|
||||
|
||||
1. Pass --includes to gperf so that size_t is defined.
|
||||
2. Remove __cap_lookup_name declaration.
|
||||
---
|
||||
libcap/Makefile | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/libcap/Makefile b/libcap/Makefile
|
||||
index d189777..634a042 100644
|
||||
--- a/libcap/Makefile
|
||||
+++ b/libcap/Makefile
|
||||
@@ -41,7 +41,7 @@ cap_names.h: _makenames
|
||||
./_makenames > cap_names.h
|
||||
|
||||
$(GPERF_OUTPUT): cap_names.list.h
|
||||
- perl -e 'print "struct __cap_token_s { const char *name; int index; };\n%{\nconst struct __cap_token_s *__cap_lookup_name(const char *, unsigned int);\n%}\n%%\n"; while ($$l = <>) { $$l =~ s/[\{\"]//g; $$l =~ s/\}.*// ; print $$l; }' < $< | gperf --ignore-case --language=ANSI-C --readonly --null-strings --global-table --hash-function-name=__cap_hash_name --lookup-function-name="__cap_lookup_name" -c -t -m20 $(INDENT) > $@
|
||||
+ perl -e 'print "struct __cap_token_s { const char *name; int index; };\n%%\n"; while ($$l = <>) { $$l =~ s/[\{\"]//g; $$l =~ s/\}.*// ; print $$l; }' < $< | gperf --ignore-case --language=ANSI-C --includes --readonly --null-strings --global-table --hash-function-name=__cap_hash_name --lookup-function-name="__cap_lookup_name" -c -t -m20 $(INDENT) > $@
|
||||
|
||||
cap_names.list.h: Makefile $(KERNEL_HEADERS)/linux/capability.h
|
||||
@echo "=> making $@ from $(KERNEL_HEADERS)/linux/capability.h"
|
||||
--
|
||||
2.11.0
|
||||
|
Loading…
x
Reference in New Issue
Block a user