[notify] libpsl-32: removed python-32

This commit is contained in:
Danny Rawlins 2019-12-15 22:47:20 +11:00
parent 38413b2d97
commit b65686f29d
4 changed files with 79 additions and 7 deletions

View File

@ -1,5 +1,7 @@
untrusted comment: verify with /etc/ports/compat-32.pub
RWSwxGo/zH7eXWCW/dzamF+nBQa9RT9OhIUTkUIhiuccIRAC09HNHbouS0klPJsqI2J8YU9PlMX2Khw6n2QC04KY5LC25mo7ygU=
SHA256 (Pkgfile) = c563c6deca7dd3d47645676becf988169953560c28df663378c35d14f4ed7f7a
RWSwxGo/zH7eXfJ9TEpTQRD/tAVwXXLsrx4pL2vveIaiJ6iXEs+iBtusxENgUxtsmghL+vfcxlPa5+RmBJmDC5wY/xUvUE/E1Q8=
SHA256 (Pkgfile) = 3c8d29e2751105930e4766c7738062f67844055b34209e046f3b123aa0562262
SHA256 (.footprint) = 066f65ea41f70ed863b5d2f86e8a733f81771e66aef91a29d93839fbc40213a6
SHA256 (libpsl-0.21.0.tar.gz) = 41bd1c75a375b85c337b59783f5deb93dbb443fb0a52d257f403df7bd653ee12
SHA256 (libpsl-gtk-doc-1.30-fix.patch) = 289663403b4bd511ef7361ad4ac7e5654edfbd83ee80fbd0f35b0977a7c926ca
SHA256 (libpsl-0.21.0-build-fix.patch) = a50c2c510a6543e79767af75b909bf7abc15e6b057b0253a036da66b27a590f1

View File

@ -1,21 +1,33 @@
# Description: Public Suffix List library.
# URL: https://github.com/rockdaboot/libpsl
# Maintainer: CRUX compat-32 Team, compat-32-ports at crux dot nu
# Depends on: libpsl libunistring-32 python-32
# Depends on: libpsl libunistring-32
name=libpsl-32
version=0.21.0
release=1
source=(https://github.com/rockdaboot/${name%-*}/releases/download/${name%-*}-$version/${name%-*}-$version.tar.gz)
release=2
source=(https://github.com/rockdaboot/${name%-*}/releases/download/${name%-*}-$version/${name%-*}-$version.tar.gz
libpsl-gtk-doc-1.30-fix.patch
libpsl-0.21.0-build-fix.patch)
build() {
cd ${name%-*}-$version
patch -p1 -i $SRC/libpsl-gtk-doc-1.30-fix.patch
patch -p1 -i $SRC/libpsl-0.21.0-build-fix.patch
rm -frv list
autoreconf -fiv
sed -e 's|^#!/usr/bin/env python$|#!/usr/bin/env python3|' \
-i src/psl-make-dafsa
./configure \
--prefix=/usr \
--libdir=/usr/lib32
--libdir=/usr/lib32 \
--with-psl-file=/usr/share/publicsuffix/effective_tld_names.dat \
--with-psl-testfile=/usr/share/publicsuffix/test_psl.txt
make
LC_CTYPE=en_US.UTF-8 make
make DESTDIR=$PKG install
rm -r $PKG/usr/{bin,include,share}

View File

@ -0,0 +1,33 @@
From 9347024221f4a9d63f9dcafcda13362a7c8d92fe Mon Sep 17 00:00:00 2001
From: Po-Chuan Hsieh <sunpoet@sunpoet.net>
Date: Wed, 17 Apr 2019 13:25:48 +0000
Subject: [PATCH] Fix build when configured with --with-psl-file
The error message is as follows:
Making all in tests
make: don't know how to make ../list/public_suffix_list.dat. Stop
make: stopped in /usr/ports/works/usr/ports/dns/libpsl/work/libpsl-libpsl-0.21.0/tests
*** Error code 1
Stop.
---
tests/Makefile.am | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 480b236..9c37ce3 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -33,9 +33,9 @@ TESTS = $(PSL_TESTS)
# dafsa.psl and dafsa_ascii.psl must be created before any test is executed
# check-local target works in parallel to the tests, so the test suite will likely fail
BUILT_SOURCES = psl.dafsa psl_ascii.dafsa
-psl.dafsa: $(top_srcdir)/list/public_suffix_list.dat
+psl.dafsa: $(PSL_FILE)
$(top_srcdir)/src/psl-make-dafsa --output-format=binary "$(PSL_FILE)" psl.dafsa
-psl_ascii.dafsa: $(top_srcdir)/list/public_suffix_list.dat
+psl_ascii.dafsa: $(PSL_FILE)
$(top_srcdir)/src/psl-make-dafsa --output-format=binary --encoding=ascii "$(PSL_FILE)" psl_ascii.dafsa
clean-local:

View File

@ -0,0 +1,25 @@
From 87d1add318b5e5d09977f7f374e923577b6ff3be Mon Sep 17 00:00:00 2001
From: Alexander Kanavin <alex.kanavin@gmail.com>
Date: Sat, 1 Jun 2019 13:09:41 +0200
Subject: [PATCH] gtk-doc: do not include tree_index.sgml
gtk-doc 1.30 no longer generates the file if the object tree is empty.
---
docs/libpsl/libpsl-docs.sgml | 4 ----
1 file changed, 4 deletions(-)
diff --git a/docs/libpsl/libpsl-docs.sgml b/docs/libpsl/libpsl-docs.sgml
index 335d241..88c7ba8 100644
--- a/docs/libpsl/libpsl-docs.sgml
+++ b/docs/libpsl/libpsl-docs.sgml
@@ -22,10 +22,6 @@
</para>
<xi:include href="xml/libpsl.xml"/>
</chapter>
- <chapter id="object-tree">
- <title>Object Hierarchy</title>
- <xi:include href="xml/tree_index.sgml"/>
- </chapter>
<index id="api-index-full">
<title>API Index</title>
<xi:include href="xml/api-index-full.xml"><xi:fallback /></xi:include>