libxml2-python-32: 2.9.1 -> 2.9.2

This commit is contained in:
Danny Rawlins 2014-10-18 22:59:29 +11:00
parent 76720a6483
commit e893ffdbe5
3 changed files with 22 additions and 29 deletions

View File

@ -1,2 +1,2 @@
9c0cfef285d5c4a5c80d00904ddab380 libxml2-2.9.1.tar.gz
3addaad95e18fcfe2e465377a39a097e libxml2-python-config.patch
9e6a9aca9d155737868b3dc5fd82f788 libxml2-2.9.2.tar.gz
80fdb13ebd1e5d320783dc94d8b9c6d7 libxml2-python-config.patch

View File

@ -1,35 +1,28 @@
# Description: Python bindings for the XML library version 2
# URL: http://xmlsoft.org/
# URL: http://xmlsoft.org/
# Maintainer: CRUX compat-32 Team, compat-32-ports at crux dot nu
# Depends on: python-32 libxml2-32 libxml2-python
# Depends on: python-32 libxml2-32 libxml2-python
name=libxml2-python-32
version=2.9.1
release=2
version=2.9.2
release=1
source=(ftp://xmlsoft.org/libxml2/libxml2-$version.tar.gz
libxml2-python-config.patch)
libxml2-python-config.patch)
build () {
cd libxml2-$version
build() {
cd libxml2-$version
patch -p1 -i $SRC/libxml2-python-config.patch
patch -p1 -i $SRC/libxml2-python-config.patch
# --libdir=/usr/lib32 is unpredictable version 2.9.1
./configure --prefix=/usr --libdir=/usr/lib32
cd python
./configure --prefix=/usr --libdir=/usr/lib32
cd python
make
make DESTDIR=$PKG install
make
make DESTDIR=$PKG install
# --libdir is not to be trusted some sort of race at configure
# library will either end up in lib or lib32 depending on mood
if [ -e $PKG/usr/lib ]; then
mv $PKG/usr/lib $PKG/usr/lib32
fi
rm $PKG/usr/lib32/python2.7/site-packages/libxml2mod.{a,la}
rm -r $PKG/usr/share/doc
rmdir $PKG/usr/share
rm $PKG/usr/lib32/python2.7/site-packages/libxml2mod.{a,la}
rm -r $PKG/usr/share/doc
rmdir $PKG/usr/share
python -mcompileall $PKG/usr/lib32/python2.7/
python -mcompileall $PKG/usr/lib32/python2.7/
}

View File

@ -1,7 +1,7 @@
diff -Nru libxml2-2.9.1.orig/python/Makefile.in libxml2-2.9.1/python/Makefile.in
--- libxml2-2.9.1.orig/python/Makefile.in 2013-04-19 09:58:10.989142606 +0200
+++ libxml2-2.9.1/python/Makefile.in 2013-04-19 10:02:26.390025067 +0200
@@ -435,7 +435,7 @@
diff -Nru libxml2-2.9.2.orig/python/Makefile.in libxml2-2.9.2/python/Makefile.in
--- libxml2-2.9.2.orig/python/Makefile.in 2014-10-17 12:04:08.614853413 +0200
+++ libxml2-2.9.2/python/Makefile.in 2014-10-17 12:04:25.037581668 +0200
@@ -495,7 +495,7 @@
@WITH_PYTHON_TRUE@python_LTLIBRARIES = libxml2mod.la
@WITH_PYTHON_TRUE@libxml2mod_la_SOURCES = libxml.c libxml_wrap.h libxml2-py.h libxml2-py.c types.c
@WITH_PYTHON_TRUE@libxml2mod_la_LDFLAGS = $(CYGWIN_EXTRA_LDFLAGS) $(WIN32_EXTRA_LDFLAGS) -module -avoid-version \