compat-32/gstreamer-32/gstreamer-1.14.5-make43.patch
2020-06-16 20:54:26 +10:00

85 lines
3.1 KiB
Diff

--- a/common/glib-gen.mak
+++ b/common/glib-gen.mak
@@ -1,11 +1,13 @@
# these are the variables your Makefile.am should set
# the example is based on the colorbalance interface
+H := \#
+
#glib_enum_headers=$(colorbalance_headers)
#glib_enum_define=GST_COLOR_BALANCE
#glib_enum_prefix=gst_color_balance
-enum_headers=$(foreach h,$(glib_enum_headers),\n\#include \"$(h)\")
+enum_headers=$(foreach h,$(glib_enum_headers),\n$(H)include \"$(h)\")
# these are all the rules generating the relevant files
%-marshal.h: %-marshal.list
--- a/common/gst-glib-gen.mak
+++ b/common/gst-glib-gen.mak
@@ -1,14 +1,16 @@
# these are the variables your Makefile.am should set
# the example is based on the colorbalance interface
+H := \#
+
#glib_enum_headers=$(colorbalance_headers)
#glib_enum_define=GST_COLOR_BALANCE
#glib_gen_prefix=gst_color_balance
#glib_gen_basename=colorbalance
#glib_gen_decl_banner=GST_EXPORT
-#glib_gen_decl_include=\#include <gst/foo/foo-prelude.h>
+#glib_gen_decl_include=$(H)include <gst/foo/foo-prelude.h>
-enum_headers=$(foreach h,$(glib_enum_headers),\n\#include \"$(h)\")
+enum_headers=$(foreach h,$(glib_enum_headers),\n$(H)include \"$(h)\")
# these are all the rules generating the relevant files
$(glib_gen_basename)-marshal.h: $(glib_gen_basename)-marshal.list
--- a/libs/gst/controller/Makefile.in
+++ b/libs/gst/controller/Makefile.in
@@ -17,13 +17,6 @@
# these are the variables your Makefile.am should set
# the example is based on the colorbalance interface
-#glib_enum_headers=$(colorbalance_headers)
-#glib_enum_define=GST_COLOR_BALANCE
-#glib_gen_prefix=gst_color_balance
-#glib_gen_basename=colorbalance
-#glib_gen_decl_banner=GST_EXPORT
-#glib_gen_decl_include=\#include <gst/foo/foo-prelude.h>
-
VPATH = @srcdir@
@@ -550,11 +543,12 @@
gstinterpolationcontrolsource.h \
gstlfocontrolsource.h
+H := \#
glib_enum_define = GST_CONTROLLER
glib_gen_prefix = gst
glib_gen_basename = controller
glib_gen_decl_banner = GST_CONTROLLER_API
-glib_gen_decl_include = \#include <gst/controller/controller-prelude.h>
+glib_gen_decl_include = $(H)include <gst/controller/controller-prelude.h>
built_sources = controller-enumtypes.c
built_headers = controller-enumtypes.h
BUILT_SOURCES = $(built_sources) $(built_headers)
@@ -587,7 +581,14 @@
libgstcontroller_@GST_API_VERSION@_la_LIBADD = $(GST_OBJ_LIBS) $(LIBM)
libgstcontroller_@GST_API_VERSION@_la_LDFLAGS = $(GST_LIB_LDFLAGS) $(GST_ALL_LDFLAGS) $(GST_LT_LDFLAGS)
CLEANFILES = *.gcno *.gcda *.gcov $(BUILT_SOURCES) $(am__append_1)
-enum_headers = $(foreach h,$(glib_enum_headers),\n\#include \"$(h)\")
+
+#glib_enum_headers=$(colorbalance_headers)
+#glib_enum_define=GST_COLOR_BALANCE
+#glib_gen_prefix=gst_color_balance
+#glib_gen_basename=colorbalance
+#glib_gen_decl_banner=GST_EXPORT
+#glib_gen_decl_include=$(H)include <gst/foo/foo-prelude.h>
+enum_headers = $(foreach h,$(glib_enum_headers),\n$(H)include \"$(h)\")
@HAVE_INTROSPECTION_TRUE@BUILT_GIRSOURCES = GstController-@GST_API_VERSION@.gir
@HAVE_INTROSPECTION_TRUE@gir_headers = $(patsubst %,$(srcdir)/%, \
@HAVE_INTROSPECTION_TRUE@ $(libgstcontroller_@GST_API_VERSION@_include_HEADERS)) \