22 lines
948 B
Diff
22 lines
948 B
Diff
diff -Naur Vulkan-ValidationLayers-sdk-1.3.243.0.old/layers/CMakeLists.txt Vulkan-ValidationLayers-sdk-1.3.243.0/layers/CMakeLists.txt
|
|
--- Vulkan-ValidationLayers-sdk-1.3.243.0.old/layers/CMakeLists.txt 2023-04-30 09:04:45.858225073 +0200
|
|
+++ Vulkan-ValidationLayers-sdk-1.3.243.0/layers/CMakeLists.txt 2023-04-30 09:05:37.842045460 +0200
|
|
@@ -14,7 +14,7 @@
|
|
# See the License for the specific language governing permissions and
|
|
# limitations under the License.
|
|
# ~~~
|
|
-add_library(VkLayer_utils STATIC)
|
|
+add_library(VkLayer_utils SHARED)
|
|
target_sources(VkLayer_utils PRIVATE
|
|
generated/vk_format_utils.h
|
|
generated/vk_format_utils.cpp
|
|
@@ -138,7 +138,7 @@
|
|
message(NOTICE "VulkanVL_generated_source target requires python 3")
|
|
endif()
|
|
|
|
-add_library(VkLayer_khronos_validation MODULE)
|
|
+add_library(VkLayer_khronos_validation SHARED)
|
|
|
|
target_sources(VkLayer_khronos_validation PRIVATE
|
|
best_practices/best_practices_error_enums.h
|