compat-32/gst-plugins-base-32/qt5-option.patch

56 lines
2.1 KiB
Diff

From 6643e941beb5a5cc00e220e841d2cb90fa2d8330 Mon Sep 17 00:00:00 2001
From: Nicolas Dufresne <nicolas.dufresne@collabora.com>
Date: Tue, 15 Sep 2020 14:15:36 -0400
Subject: [PATCH] meson: Add a qt5 feature
This allow opting out items of the builds the depends on QT5 library.
Auto-detection of QT5 in cross-build requires host tools to match with the
sysroot, and detection of mis-match is not fully reliable.
Part-of: <https://gitlab.freedesktop.org/gstreamer/gst-plugins-base/-/merge_requests/817>
---
meson_options.txt | 1 +
tests/examples/gl/qt/meson.build | 4 ++++
tests/examples/overlay/meson.build | 4 ++++
3 files changed, 9 insertions(+)
diff --git a/meson_options.txt b/meson_options.txt
index bb3cb3c4e..7010b9162 100644
--- a/meson_options.txt
+++ b/meson_options.txt
@@ -79,6 +79,7 @@ option('glib-asserts', type : 'feature', value : 'enabled', yield : true,
description: 'Enable GLib assertion (auto = enabled for development, disabled for stable releases)')
option('glib-checks', type : 'feature', value : 'enabled', yield : true,
description: 'Enable GLib checks such as API guards (auto = enabled for development, disabled for stable releases)')
+option('qt5', type : 'feature', value : 'auto', yield : true, description : 'Qt5 QML examples')
# Common options
option('package-name', type : 'string', yield : true,
diff --git a/tests/examples/gl/qt/meson.build b/tests/examples/gl/qt/meson.build
index ed0a0b0bb..66f3d93e7 100644
--- a/tests/examples/gl/qt/meson.build
+++ b/tests/examples/gl/qt/meson.build
@@ -1,3 +1,7 @@
+if get_option('qt5').disabled()
+ subdir_done()
+endif
+
qt5_mod = import('qt5')
qt5gui_dep = dependency('qt5', modules : ['Core', 'Gui', 'Widgets'], required : false)
diff --git a/tests/examples/overlay/meson.build b/tests/examples/overlay/meson.build
index b343f6598..926e9f3d7 100644
--- a/tests/examples/overlay/meson.build
+++ b/tests/examples/overlay/meson.build
@@ -1,3 +1,7 @@
+if get_option('qt5').disabled()
+ subdir_done()
+endif
+
if x11_dep.found()
if gtk_x11_dep.found()
executable('gtk-videooverlay', 'gtk-videooverlay.c',
--
GitLab