gst-plugins-bad: delete unused patches, enable openh264 codec if present

This commit is contained in:
John McQuah 2023-01-22 21:25:39 -05:00
parent 56097a09cb
commit 03182778f6
5 changed files with 29 additions and 1283 deletions

View File

@ -1,5 +1,5 @@
untrusted comment: verify with /etc/ports/contrib.pub
RWSagIOpLGJF32dzIZsPKrT8BKkOJIC7Qk6/oB9hMVFTJZ9MLYluX8MqzvYXEsaFN34+v285kx8XdVvMHHX2eHthdGH/WTf69AA=
SHA256 (Pkgfile) = 2fd1212410a45186271cebb5b8ea63792a942e8c5c62efe61a3c8691b0b6eeec
RWSagIOpLGJF3xoNARSjW4yjT6GDaC67ptYlnIbK3OtD1o7//8pqwvCGGDiC0JKnRonionFT0MNU5QQME0+YTB6tm2lrXIhyzgo=
SHA256 (Pkgfile) = daa9a4b1b1c6fbfa0f8adb5afe34c6ecbf34e386fd122ecc5c9ab61b74f5c000
SHA256 (.footprint) = 08f9580f05f8ccd6aa77b300b0fa18628154f8b38033f4ff9458a687c9391d79
SHA256 (gst-plugins-bad-1.20.5.tar.xz) = f431214b0754d7037adcde93c3195106196588973e5b32dcb24938805f866363

File diff suppressed because it is too large Load Diff

View File

@ -2,6 +2,7 @@
# URL: https://gstreamer.freedesktop.org/modules/gst-plugins-bad.html
# Maintainer: Danny Rawlins, crux at romster dot me
# Depends on: bluez brotli bzip2 chromaprint curl dav1d eudev expat faac faad2 fdk-aac ffmpeg flac glib gst-plugins-base gstreamer ladspa lame lcms2 libass libdrm libffi libglvnd libgmp libgudev libjpeg-turbo libmodplug libnghttp2 libnice libogg libpcre libpng libsndfile libsrtp libtheora libva libvdpau libvorbis libvpx libwebp lilv mjpegtools neon openal openjpeg2 opus orc rtmpdump shaderc soundtouch util-linux vulkan-loader x264 x265 xz zlib zstd
# Optional: openh264
name=gst-plugins-bad
version=1.20.5
@ -9,30 +10,32 @@ release=1
source=(https://gstreamer.freedesktop.org/src/$name/$name-$version.tar.xz)
build() {
meson build $name-$version \
--prefix /usr \
--libexecdir lib \
--buildtype plain \
--wrap-mode nodownload \
-D b_pie=true \
-D doc=disabled \
-D nls=disabled \
-D directfb=disabled \
-D flite=disabled \
-D gsm=disabled \
-D iqa=disabled \
-D magicleap=disabled \
-D msdk=disabled \
-D openh264=disabled \
-D openmpt=disabled \
-D openni2=disabled \
-D opensles=disabled \
-D tinyalsa=disabled \
-D voaacenc=disabled \
-D voamrwbenc=disabled \
-D wasapi2=disabled \
-D wasapi=disabled \
-D gobject-cast-checks=disabled \
PKGMK_GSTBAD="--prefix=/usr
--libexecdir=lib
--buildtype=plain
--wrap-mode=nodownload
-D b_pie=true
-D doc=disabled
-D nls=disabled
-D directfb=disabled
-D flite=disabled
-D gsm=disabled
-D iqa=disabled
-D magicleap=disabled
-D msdk=disabled
-D openmpt=disabled
-D openni2=disabled
-D opensles=disabled
-D tinyalsa=disabled
-D voaacenc=disabled
-D voamrwbenc=disabled
-D wasapi2=disabled
-D wasapi=disabled
-D gobject-cast-checks=disabled"
prt-get isinst openh264 && PKGMK_GSTBAD+=" -D openh264=enabled" || \
PKGMK_GSTBAD+=" -D openh264=disabled"
meson setup build $name-$version $PKGMK_GSTBAD \
-D package-name="GStreamer Bad Plugins (CRUX Linux)" \
-D package-origin="https://crux.nu/"

View File

@ -1,27 +0,0 @@
From a9fafd98b74fd184b178604095d35ac6105119b8 Mon Sep 17 00:00:00 2001
From: Antonio Rojas <arojas@archlinux.org>
Date: Sat, 24 Apr 2021 10:43:47 +0000
Subject: [PATCH] Fix build with OpenEXR 3
Add a header that is no longer transitively included
Part-of: <https://gitlab.freedesktop.org/gstreamer/gst-plugins-bad/-/merge_requests/2216>
---
ext/openexr/gstopenexrdec.cpp | 1 +
1 file changed, 1 insertion(+)
diff --git a/ext/openexr/gstopenexrdec.cpp b/ext/openexr/gstopenexrdec.cpp
index a83c35de9b..b85203e423 100644
--- a/ext/openexr/gstopenexrdec.cpp
+++ b/ext/openexr/gstopenexrdec.cpp
@@ -29,6 +29,7 @@
#include <ImfRgbaFile.h>
#include <ImfIO.h>
+#include <ImfInt64.h>
using namespace Imf;
using namespace Imath;
--
GitLab

View File

@ -1,25 +0,0 @@
From b83e85ab677c79b46f520abebd1ee031e3a139c0 Mon Sep 17 00:00:00 2001
From: Heiko Becker <heirecka@exherbo.org>
Date: Sun, 26 Sep 2021 21:34:30 +0200
Subject: [PATCH] neon: Allow building against neon 0.32.x
No API/ABI changes: https://github.com/notroj/neon/blob/0.32.0/NEWS#L3
Part-of: <https://gitlab.freedesktop.org/gstreamer/gstreamer/-/merge_requests/1267>
---
subprojects/gst-plugins-bad/ext/neon/meson.build | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/subprojects/gst-plugins-bad/ext/neon/meson.build b/subprojects/gst-plugins-bad/ext/neon/meson.build
index bf49be9111..abd9763649 100644
--- a/subprojects/gst-plugins-bad/ext/neon/meson.build
+++ b/subprojects/gst-plugins-bad/ext/neon/meson.build
@@ -1,4 +1,4 @@
-neon_dep = dependency('neon', version: ['>= 0.27', '<= 0.31.99'],
+neon_dep = dependency('neon', version: ['>= 0.27', '<= 0.32.99'],
required : get_option('neon'))
if neon_dep.found()
--
GitLab