sdl_sound: dropped unmaintained port

This commit is contained in:
Tim Biermann 2023-09-24 09:32:54 +02:00
parent f252c8afd6
commit 056f91bbce
Signed by: tb
GPG Key ID: 42F8B4E30B673606
6 changed files with 0 additions and 114 deletions

View File

@ -1,13 +0,0 @@
drwxr-xr-x root/root usr/
drwxr-xr-x root/root usr/bin/
-rwxr-xr-x root/root usr/bin/playsound
-rwxr-xr-x root/root usr/bin/playsound_simple
drwxr-xr-x root/root usr/include/
drwxr-xr-x root/root usr/include/SDL/
-rw-r--r-- root/root usr/include/SDL/SDL_sound.h
drwxr-xr-x root/root usr/lib/
lrwxrwxrwx root/root usr/lib/libSDL_sound-1.0.so.1 -> libSDL_sound-1.0.so.1.0.2
-rwxr-xr-x root/root usr/lib/libSDL_sound-1.0.so.1.0.2
-rw-r--r-- root/root usr/lib/libSDL_sound.a
-rwxr-xr-x root/root usr/lib/libSDL_sound.la
lrwxrwxrwx root/root usr/lib/libSDL_sound.so -> libSDL_sound-1.0.so.1.0.2

View File

@ -1,8 +0,0 @@
untrusted comment: verify with /etc/ports/contrib.pub
RWSagIOpLGJF3/+aHHlnrZly+NnlbtCdorqP9J1Ot1C4vFM2Fw52r/YsAufs03z+VWD9joIZpT36d83IAT23VmAwkLcC4xBH9QI=
SHA256 (Pkgfile) = 38f2634aee5b16082f69226c21734d2bea96ef3b6d46c1ee2e9c03268c5785af
SHA256 (.footprint) = 22e9000e02a3db704ddeca3759859a16b8a04c65b0abe73e8cfe44b888790d16
SHA256 (SDL_sound-1.0.3.tar.gz) = 3999fd0bbb485289a52be14b2f68b571cb84e380cc43387eadf778f64c79e6df
SHA256 (sdl-sound-1.0.3-physfs-3.0.1.patch) = d26095da9e1c0b519d5c51361a6ef172eaa1e3cb9e48c6b4f8138095dbfb07dd
SHA256 (sdl-sound-1.0.3-automake-1.13.patch) = 32b2fe3eb83e93a2f33557b35bb6b9e173ff342b8b1f7dd3778c123befcde7d8
SHA256 (sdl-sound-1.0.3-underlinking.patch) = 6e995658b975bc49a57c802ad33d5e85033a448955f2fcb922f10ce9a5ab5684

View File

@ -1,26 +0,0 @@
# Description: A library for decoding various sound formats.
# URL: http://icculus.org/SDL_sound/
# Maintainer: UNMAINTAINED
# Depends on: flac libmikmod libmodplug libvorbis smpeg speex
# Optional: lame mpg123 opus physfs pulseaudio
name=sdl_sound
version=1.0.3
release=2
source=(http://icculus.org/SDL_sound/downloads/SDL_sound-$version.tar.gz
sdl-sound-1.0.3-physfs-3.0.1.patch sdl-sound-1.0.3-automake-1.13.patch
sdl-sound-1.0.3-underlinking.patch)
build() {
cd SDL_sound-$version
patch -Np1 -i $SRC/sdl-sound-1.0.3-physfs-3.0.1.patch
patch -Np1 -i $SRC/sdl-sound-1.0.3-automake-1.13.patch
patch -Np1 -i $SRC/sdl-sound-1.0.3-underlinking.patch
CFLAGS+=" -I/usr/include/smpeg -Wno-error=deprecated-declarations"
CXXFLAGS+=" -I/usr/include/smpeg -Wno-error=deprecated-declarations"
./configure --prefix=/usr
make
make DESTDIR=$PKG install
}

View File

@ -1,11 +0,0 @@
--- SDL_sound-1.0.3/configure.in
+++ SDL_sound-1.0.3/configure.in
@@ -43,7 +43,7 @@
AC_CANONICAL_TARGET
dnl Setup for automake
-AM_CONFIG_HEADER(config.h)
+AC_CONFIG_HEADERS(config.h)
AM_INIT_AUTOMAKE(SDL_sound, $VERSION)

View File

@ -1,38 +0,0 @@
--- a/playsound/physfsrwops.h.ini 2008-04-17 13:56:21.000000000 -0400
+++ b/playsound/physfsrwops.h 2017-12-23 05:05:31.657371092 -0500
@@ -39,7 +39,7 @@
* @return A valid SDL_RWops structure on success, NULL on error. Specifics
* of the error can be gleaned from PHYSFS_getLastError().
*/
-__EXPORT__ SDL_RWops *PHYSFSRWOPS_openRead(const char *fname);
+SDL_RWops *PHYSFSRWOPS_openRead(const char *fname);
/**
* Open a platform-independent filename for writing, and make it accessible
@@ -51,7 +51,7 @@
* @return A valid SDL_RWops structure on success, NULL on error. Specifics
* of the error can be gleaned from PHYSFS_getLastError().
*/
-__EXPORT__ SDL_RWops *PHYSFSRWOPS_openWrite(const char *fname);
+SDL_RWops *PHYSFSRWOPS_openWrite(const char *fname);
/**
* Open a platform-independent filename for appending, and make it accessible
@@ -63,7 +63,7 @@
* @return A valid SDL_RWops structure on success, NULL on error. Specifics
* of the error can be gleaned from PHYSFS_getLastError().
*/
-__EXPORT__ SDL_RWops *PHYSFSRWOPS_openAppend(const char *fname);
+SDL_RWops *PHYSFSRWOPS_openAppend(const char *fname);
/**
* Make a SDL_RWops from an existing PhysicsFS file handle. You should
@@ -75,7 +75,7 @@
* @return A valid SDL_RWops structure on success, NULL on error. Specifics
* of the error can be gleaned from PHYSFS_getLastError().
*/
-__EXPORT__ SDL_RWops *PHYSFSRWOPS_makeRWops(PHYSFS_file *handle);
+SDL_RWops *PHYSFSRWOPS_makeRWops(PHYSFS_file *handle);
#ifdef __cplusplus
}

View File

@ -1,18 +0,0 @@
From: Julian Ospald <hasufell@gentoo.org>
Date: Tue Aug 21 12:42:14 UTC 2012
Subject: build system
fix underlinking
--- SDL_sound-1.0.3/Makefile.am
+++ SDL_sound-1.0.3/Makefile.am
@@ -32,7 +32,8 @@
-version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE)
libSDL_sound_la_LIBADD = \
decoders/libdecoders.la \
- $(TIMIDITY_LIB) $(MPGLIB_LIB)
+ $(TIMIDITY_LIB) $(MPGLIB_LIB) \
+ -lm
EXTRA_DIST = \
CREDITS \