cowpatty: initial commit, v4.8

This commit is contained in:
Alexandr Savca 2020-11-22 15:31:36 +02:00
parent 1b9e8c21ab
commit 1078cb672c
4 changed files with 52 additions and 0 deletions

8
cowpatty/.footprint Normal file
View File

@ -0,0 +1,8 @@
drwxr-xr-x root/root usr/
drwxr-xr-x root/root usr/bin/
-rwxr-xr-x root/root usr/bin/cowpatty
-rwxr-xr-x root/root usr/bin/genpmk
drwxr-xr-x root/root usr/share/
drwxr-xr-x root/root usr/share/man/
drwxr-xr-x root/root usr/share/man/man1/
-rw-r--r-- root/root usr/share/man/man1/cowpatty.1.gz

6
cowpatty/.signature Normal file
View File

@ -0,0 +1,6 @@
untrusted comment: verify with /etc/ports/contrib.pub
RWSagIOpLGJF3xHx2ge7ADLejU8cLnvCgfuUw8s1ReW8vrSI85FcJRE1/VEiK4vdTKJSzads9uQn+9Sa+sxv8rE4VJ2WTqllhQA=
SHA256 (Pkgfile) = f01c03de43deceaa1486cc4758fc930269e76a44a5187611e856e3eb705096b4
SHA256 (.footprint) = 9d8bc9a10100a2bf09d547afe4f17b186cc73bc729c7c0fd9214a9a2a4a8ad0e
SHA256 (cowpatty-4.8.tar.gz) = 8aae67f4823edb76dff036808137888d2479477ec1e52aa86d6cecd26d58aa23
SHA256 (fix_parallel_build.patch) = 9cfa7c1448166b5c82f6ed000a3632d53224a39cb44208de15ad28debc5fbc6d

21
cowpatty/Pkgfile Normal file
View File

@ -0,0 +1,21 @@
# Description: Brute-force dictionary attack against WPA-PSK
# URL: https://github.com/joswr1ght/cowpatty
# Maintainer: Alexandr Savca, alexandrsavca89 at gmail dot com
# Depends on: openssl libpcap
name=cowpatty
version=4.8
release=1
source=(https://github.com/joswr1ght/$name/archive/$version/$name-$version.tar.gz
fix_parallel_build.patch)
build() {
cd $name-$version
patch -p1 -i $SRC/fix_parallel_build.patch
make CFLAGS="${CFLAGS} -DOPENSSL" CC="gcc" BINDIR=$PKG/usr/bin install
# install man page manually
install -Dm0644 $name.1 $PKG/usr/share/man/man1/$name.1
}

View File

@ -0,0 +1,17 @@
diff -pruN cowpatty-4.8/Makefile cowpatty-4.8.new/Makefile
--- cowpatty-4.8/Makefile 2018-07-03 22:49:02.000000000 +0300
+++ cowpatty-4.8.new/Makefile 2020-10-03 18:49:58.182167312 +0300
@@ -20,11 +20,10 @@ CC = clang
all: $(PROGOBJ) $(PROG)
-cowpatty: common.h md5.c md5.h sha1.h cowpatty.c cowpatty.h sha1.c \
- sha1.h utils.c utils.h
+cowpatty: cowpatty.c cowpatty.h common.h md5 sha1 utils
$(CC) $(CFLAGS) cowpatty.c -o cowpatty utils.o md5.o sha1.o $(LDLIBS)
-genpmk: genpmk.c cowpatty.h utils.h sha1.h common.h
+genpmk: genpmk.c cowpatty.h common.h utils sha1
$(CC) $(CFLAGS) genpmk.c -o genpmk utils.o sha1.o $(LDLIBS)
utils: utils.c utils.h