dbus-python3: added missing dependencies

This commit is contained in:
Tim Biermann 2022-09-17 23:25:16 +02:00
parent 924568203d
commit 10ac86395f
Signed by: tb
GPG Key ID: 42F8B4E30B673606
3 changed files with 6 additions and 57 deletions

View File

@ -1,5 +1,5 @@
untrusted comment: verify with /etc/ports/contrib.pub
RWSagIOpLGJF3236CS6oE1ivCpLiPhS5S/NEjKgAlyfDe8VJvCI22qQIQouZ80g8E09zIXN/911BaCUxKMA+yKMbC6thyhqDCQk=
SHA256 (Pkgfile) = 1bc12ee99827924e76c6e6fc9d8c671a88fc23867497c87e9781f42a2f6bcd21
RWSagIOpLGJF34UL954f/ACbRjbFunN5/q73dfdVkWE5IQZ0FVY/XJLZMdbNHMM6sZoimwK6MRcAPiQwYALCBGskRnz0xiB70gg=
SHA256 (Pkgfile) = d1fba8e213f4b86242ea06415c9dd40f72291508a13074920f2bffd7311dbc90
SHA256 (.footprint) = a6aa402d139afbe6182c80904b10d844d4da621dcb7ee84da3fc461c35fcad40
SHA256 (dbus-python-1.3.2.tar.gz) = ad67819308618b5069537be237f8e68ca1c7fcc95ee4a121fe6845b1418248f8

View File

@ -1,52 +0,0 @@
From 380ae714f641a73a30f86ae8f5a2e05ac063b37f Mon Sep 17 00:00:00 2001
From: leigh123linux <leigh123linux@googlemail.com>
Date: Tue, 23 Feb 2016 07:32:08 +0000
Subject: [PATCH] Move python modules to architecture-specific directory
This is because dbus-python gets dragged in as a dependency of other
things people want to be multilib-compatible. As is the Python
modules conflict.
---
Makefile.am | 9 +++++----
1 file changed, 5 insertions(+), 4 deletions(-)
diff --git a/Makefile.am b/Makefile.am
index fd480d4..0859994 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -155,7 +155,8 @@ test_dbus_py_test_la_SOURCES = \
# === dbus package ===
-nobase_python_PYTHON = \
+dbuspydir = $(pyexecdir)
+nobase_dbuspy_DATA = \
dbus/bus.py \
dbus/connection.py \
dbus/_compat.py \
@@ -175,12 +176,12 @@ nobase_python_PYTHON = \
dbus/types.py
if !HAVE_PYTHON_3
-nobase_python_PYTHON += \
+nobase_dbuspy_DATA += \
dbus/gobject_service.py \
$(NULL)
endif
-check_py_sources = $(nobase_python_PYTHON)
+check_py_sources = $(nobase_dbuspy_DATA)
include $(top_srcdir)/tools/check-coding-style.mk
# === Devel stuff ===
@@ -416,7 +417,7 @@ uninstall-local: uninstall-local-sphinx
if ENABLE_DOCUMENTATION
all: doc/_build/.stamp
-doc/_build/.stamp: $(nobase_python_PYTHON) \
+doc/_build/.stamp: $(nobase_dbuspy_DATA) \
_dbus_bindings.la \
_dbus_glib_bindings.la \
$(sphinx_sources) \
--
2.17.0

View File

@ -1,11 +1,11 @@
# Description: D-Bus Python bindings
# URL: http://freedesktop.org/wiki/Software/DBusBindings
# Maintainer: Tim Biermann, tbier at posteo dot de
# Depends on: dbus-glib python3-pip
# Depends on: dbus-glib python3-pip python3-wheel
name=dbus-python3
version=1.3.2
release=1
release=2
source=(https://dbus.freedesktop.org/releases/dbus-python/dbus-python-$version.tar.gz)
build() {
@ -19,8 +19,9 @@ build() {
make
make DESTDIR=$PKG install
/usr/bin/python3 setup.py install --root=$PKG \
--optimize=1 \
--optimize=2 \
--skip-build
find $PKG -name '*.la' -type f -delete