gnome-keyring: added new dependency: gcr3; pulled patch for p11-kit config path

This commit is contained in:
Tim Biermann 2022-12-28 13:49:39 +00:00
parent 4edeb08602
commit 115b114ad7
4 changed files with 69 additions and 10 deletions

View File

@ -1,7 +1,3 @@
drwxr-xr-x root/root etc/
drwxr-xr-x root/root etc/pkcs11/
drwxr-xr-x root/root etc/pkcs11/modules/
-rw-r--r-- root/root etc/pkcs11/modules/gnome-keyring.module
drwxr-xr-x root/root lib/
drwxr-xr-x root/root lib/security/
-rwxr-xr-x root/root lib/security/pam_gnome_keyring.la
@ -48,6 +44,9 @@ drwxr-xr-x root/root usr/share/man/man1/
-rw-r--r-- root/root usr/share/man/man1/gnome-keyring-3.1.gz
-rw-r--r-- root/root usr/share/man/man1/gnome-keyring-daemon.1.gz
-rw-r--r-- root/root usr/share/man/man1/gnome-keyring.1.gz
drwxr-xr-x root/root usr/share/p11-kit/
drwxr-xr-x root/root usr/share/p11-kit/modules/
-rw-r--r-- root/root usr/share/p11-kit/modules/gnome-keyring.module
drwxr-xr-x root/root usr/share/xdg-desktop-portal/
drwxr-xr-x root/root usr/share/xdg-desktop-portal/portals/
-rw-r--r-- root/root usr/share/xdg-desktop-portal/portals/gnome-keyring.portal

View File

@ -1,5 +1,6 @@
untrusted comment: verify with /etc/ports/contrib.pub
RWSagIOpLGJF37hg8gp8zCS2ZMRa1ELO2FNxBDR+8bKYGCynb6ht0JbCnSft1CF3FfSvuKHcwzeSw3plihegTgTwbDOuwfPIKAY=
SHA256 (Pkgfile) = 76fb1a2554af2e84b2280666722d54676381eb412de623f729c5e5533992397e
SHA256 (.footprint) = 38d653e18c9298edebdbabb7e8cd55ee5fad104a556652488c8e4402f4413399
RWSagIOpLGJF3/qgi2BapKgJS83zn6NjROf84UyVsUWQhndkI3ToGgOrfoRj8+QPY2ap3QKTX9uRiPAs8MEQEIGsFHOaqcyabQY=
SHA256 (Pkgfile) = 6b2ee751ec1977b828359ebf2cdf91a5a7254948094dc04df6449388c22dfa50
SHA256 (.footprint) = f78b559ce9fb7ea778ce79f074ac70bcfac5adf7a3262e66b3d313d438d06bda
SHA256 (gnome-keyring-42.1.tar.gz) = 0fbadc355f7af19103c03b062ba32777bc6137cf24764c4486fbe2d10181becb
SHA256 (0001-build-Use-p11_module_configs-as-default-pkcs11-confi.patch) = 6985e3f7c60aa8dad794b1a9466f69737f3e9b5b7176e3888252c8c56647736a

View File

@ -0,0 +1,56 @@
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
From: "Jan Alexander Steffens (heftig)" <heftig@archlinux.org>
Date: Sat, 21 May 2022 18:42:21 +0000
Subject: [PATCH] build: Use p11_module_configs as default pkcs11-config dir
When building p11-kit with meson, `p11_system_config_modules` points at
the dir for system config in `/etc. This is its proper meaning.
When building p11-kit with autotools, `p11_system_config_modules` is a
copy of `p11_module_configs` "for compatibility", and points to the dir
for packaged configs in `/usr/share`.
We want the dir for packaged configs, so use the right variable.
---
configure.ac | 10 +++++-----
pkcs11/rpc-layer/Makefile.am | 2 +-
2 files changed, 6 insertions(+), 6 deletions(-)
diff --git a/configure.ac b/configure.ac
index 1bf7c14c8ccc..98d8c01018fb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -294,15 +294,15 @@ AC_ARG_WITH(pkcs11-config, [
[directory to install PKCS#11 config])
])
if test -z "$with_pkcs11_config" ; then
- P11_SYSTEM_CONFIG_MODULES=$($PKG_CONFIG p11-kit-1 --variable=p11_system_config_modules)
+ P11_MODULE_CONFIGS=$($PKG_CONFIG p11-kit-1 --variable=p11_module_configs)
else
- P11_SYSTEM_CONFIG_MODULES="$with_pkcs11_config"
+ P11_MODULE_CONFIGS="$with_pkcs11_config"
fi
-if test "$P11_SYSTEM_CONFIG_MODULES" = ""; then
+if test "$P11_MODULE_CONFIGS" = ""; then
AC_MSG_ERROR([Could not find location for pkcs11 module config])
fi
-AC_MSG_RESULT($P11_SYSTEM_CONFIG_MODULES)
-AC_SUBST(P11_SYSTEM_CONFIG_MODULES)
+AC_MSG_RESULT($P11_MODULE_CONFIGS)
+AC_SUBST(P11_MODULE_CONFIGS)
AC_MSG_CHECKING([module path to install pkcs11 modules])
AC_ARG_WITH(pkcs11-modules, [
diff --git a/pkcs11/rpc-layer/Makefile.am b/pkcs11/rpc-layer/Makefile.am
index ccdff9191ad4..d3a3b57bbc6e 100644
--- a/pkcs11/rpc-layer/Makefile.am
+++ b/pkcs11/rpc-layer/Makefile.am
@@ -46,7 +46,7 @@ gnome_keyring_pkcs11_la_LDFLAGS = \
-no-undefined -export-symbols-regex 'C_GetFunctionList'
# This is the configuration file that p11-kit uses to load the module
-pkcs11configdir = $(P11_SYSTEM_CONFIG_MODULES)
+pkcs11configdir = $(P11_MODULE_CONFIGS)
pkcs11config_DATA = \
pkcs11/rpc-layer/gnome-keyring.module

View File

@ -1,16 +1,19 @@
# Description: GNOME Keyring is a collection of components in GNOME that store secrets, passwords, keys, certificates and make them available to applications.
# URL: https://gnome.org
# Maintainer: Tim Biermann, tbier at posteo dot de
# Depends on: desktop-file-utils docbook-xsl gcr gnome-common
# Depends on: desktop-file-utils docbook-xsl gcr3 gnome-common
name=gnome-keyring
version=42.1
release=1
source=(https://github.com/GNOME/gnome-keyring/archive/$version/$name-$version.tar.gz)
release=2
source=(https://github.com/GNOME/gnome-keyring/archive/$version/$name-$version.tar.gz
0001-build-Use-p11_module_configs-as-default-pkcs11-confi.patch)
build() {
cd $name-$version
patch -Np1 -i $SRC/0001-build-Use-p11_module_configs-as-default-pkcs11-confi.patch
NOCONFIGURE=1 ./autogen.sh
./configure --prefix=/usr \
--with-pam-dir=/lib/security \