syslinux: fixed footprint, cleaned up and removed patch file

This commit is contained in:
Jose V Beneyto 2010-08-12 10:16:34 +00:00 committed by Bartlomiej Palmowski
parent 01ed04d99c
commit 1877f4dbb4
4 changed files with 9 additions and 51 deletions

View File

@ -212,6 +212,7 @@ drwxr-xr-x root/root usr/share/syslinux/dosutil/
-rw-r--r-- root/root usr/share/syslinux/sysdump.c32
-rw-r--r-- root/root usr/share/syslinux/syslinux.com
-rw-r--r-- root/root usr/share/syslinux/syslinux.exe
-rw-r--r-- root/root usr/share/syslinux/syslinux64.exe
-rw-r--r-- root/root usr/share/syslinux/vesainfo.c32
-rw-r--r-- root/root usr/share/syslinux/vesamenu.c32
-rw-r--r-- root/root usr/share/syslinux/vpdtest.c32

View File

@ -1,2 +1 @@
8f4b5571157f0025c6c5ed0986268a87 dos_out.patch
52912c03f5c275d6c0ac09180ebab81f syslinux-4.02.tar.bz2

View File

@ -6,25 +6,20 @@
name=syslinux
version=4.02
release=1
source=(http://www.kernel.org/pub/linux/utils/boot/$name/$name-$version.tar.bz2 \
dos_out.patch)
release=2
source=(http://www.kernel.org/pub/linux/utils/boot/$name/$name-$version.tar.bz2)
build() {
cd $name-$version
# do not build win/dos installers
patch -Np1 -i $SRC/dos_out.patch
# compilation will fail with LDFLAGS
unset LDFLAGS
make OPTFLAGS="$CFLAGS"
make INSTALLROOT=$PKG install
# fix to install extlinux in /usr/bin
sed -i Makefile -e 's|SBINDIR|BINDIR|g'
make clean
make OPTFLAGS="$CFLAGS" installer
make OPTFLAGS="$CFLAGS" INSTALLROOT=$PKG install
mv $PKG/sbin/* $PKG/usr/bin
rm -r $PKG/sbin
install -d $PKG/usr/share/syslinux/dosutil
cp dosutil/{copybs.com,eltorito.sys,mdiskchk.com} $PKG/usr/share/syslinux/dosutil
install -m 0644 dos/syslinux.com win32/syslinux.exe $PKG/usr/share/syslinux
}

View File

@ -1,37 +0,0 @@
diff -purN syslinux-4.02.orig/Makefile syslinux-4.02/Makefile
--- syslinux-4.02.orig/Makefile 2010-08-03 17:31:39.000000000 +0200
+++ syslinux-4.02/Makefile 2010-08-03 17:34:17.000000000 +0200
@@ -43,10 +43,7 @@ BOBJECTS = $(BTARGET) \
mbr/mbr_c.bin mbr/altmbr_c.bin mbr/gptmbr_c.bin \
mbr/mbr_f.bin mbr/altmbr_f.bin mbr/gptmbr_f.bin \
core/pxelinux.0 core/isolinux.bin core/isolinux-debug.bin \
- gpxe/gpxelinux.0 dos/syslinux.com \
- win32/syslinux.exe win64/syslinux64.exe \
- dosutil/*.com dosutil/*.sys \
- $(MODULES)
+ gpxe/gpxelinux.0 $(MODULES)
# BSUBDIRs build the on-target binary components.
# ISUBDIRs build the installer (host) components.
@@ -55,7 +52,7 @@ BOBJECTS = $(BTARGET) \
# files that depend only on the B phase, but may have to be regenerated
# for "make installer".
BSUBDIRS = codepage com32 lzo core memdisk modules mbr memdump gpxe sample \
- libinstaller dos win32 win64 dosutil
+ libinstaller
ITARGET =
IOBJECTS = $(ITARGET) \
utils/gethostip utils/isohybrid utils/mkdiskimage \
@@ -71,10 +68,10 @@ INSTALL_AUX = core/pxelinux.0 gpxe/gpx
core/isolinux-debug.bin \
dos/syslinux.com \
mbr/*.bin $(MODULES)
-INSTALL_AUX_OPT = win32/syslinux.exe win64/syslinux64.exe
+INSTALL_AUX_OPT =
# These directories manage their own installables
-INSTALLSUBDIRS = com32 utils dosutil
+INSTALLSUBDIRS = com32 utils
# Things to install in /boot/extlinux
EXTBOOTINSTALL = $(MODULES)