sdl_sound: fixed build

This commit is contained in:
Tim Biermann 2020-05-24 12:23:35 +00:00
parent 1597c6deed
commit 1bcbef0445
Signed by: tb
GPG Key ID: 42F8B4E30B673606
5 changed files with 84 additions and 5 deletions

View File

@ -1,5 +1,8 @@
untrusted comment: verify with /etc/ports/contrib.pub
RWSagIOpLGJF33Wrdbet4cDJtIkCXlPeRVLzEgDPCAPSJn/0G9q0kPLGvSCXBjENjuaolbG2cZXqNvmLwmr7Qo3kCIX8umtqgww=
SHA256 (Pkgfile) = 3f0113312694ef155d24b8093766b289029e5e8f9d855c1d458a33c3f43fab8f
RWSagIOpLGJF30qrOgkfcDcsERV5LjOI1uMM/Z/ooha3CrkGPGt2HTGT5JkHXUdihF/++en5agwsTRWQvNOM4M6rHS4DXVVGig0=
SHA256 (Pkgfile) = 9dafe6ac6d387cf620d09e2e541156fc156531f8aeed82afdc7886ee2eb4730d
SHA256 (.footprint) = 22e9000e02a3db704ddeca3759859a16b8a04c65b0abe73e8cfe44b888790d16
SHA256 (SDL_sound-1.0.3.tar.gz) = 3999fd0bbb485289a52be14b2f68b571cb84e380cc43387eadf778f64c79e6df
SHA256 (sdl-sound-1.0.3-physfs-3.0.1.patch) = d26095da9e1c0b519d5c51361a6ef172eaa1e3cb9e48c6b4f8138095dbfb07dd
SHA256 (sdl-sound-1.0.3-automake-1.13.patch) = 32b2fe3eb83e93a2f33557b35bb6b9e173ff342b8b1f7dd3778c123befcde7d8
SHA256 (sdl-sound-1.0.3-underlinking.patch) = 6e995658b975bc49a57c802ad33d5e85033a448955f2fcb922f10ce9a5ab5684

View File

@ -6,12 +6,21 @@
name=sdl_sound
version=1.0.3
release=1
source=(http://icculus.org/SDL_sound/downloads/SDL_sound-$version.tar.gz)
release=2
source=(http://icculus.org/SDL_sound/downloads/SDL_sound-$version.tar.gz
sdl-sound-1.0.3-physfs-3.0.1.patch sdl-sound-1.0.3-automake-1.13.patch
sdl-sound-1.0.3-underlinking.patch)
build() {
cd SDL_sound-$version
patch -Np1 -i $SRC/sdl-sound-1.0.3-physfs-3.0.1.patch
patch -Np1 -i $SRC/sdl-sound-1.0.3-automake-1.13.patch
patch -Np1 -i $SRC/sdl-sound-1.0.3-underlinking.patch
CFLAGS+=" -I/usr/include/smpeg -Wno-error=deprecated-declarations"
CXXFLAGS+=" -I/usr/include/smpeg -Wno-error=deprecated-declarations"
./configure --prefix=/usr
make
make
make DESTDIR=$PKG install
}

View File

@ -0,0 +1,11 @@
--- SDL_sound-1.0.3/configure.in
+++ SDL_sound-1.0.3/configure.in
@@ -43,7 +43,7 @@
AC_CANONICAL_TARGET
dnl Setup for automake
-AM_CONFIG_HEADER(config.h)
+AC_CONFIG_HEADERS(config.h)
AM_INIT_AUTOMAKE(SDL_sound, $VERSION)

View File

@ -0,0 +1,38 @@
--- a/playsound/physfsrwops.h.ini 2008-04-17 13:56:21.000000000 -0400
+++ b/playsound/physfsrwops.h 2017-12-23 05:05:31.657371092 -0500
@@ -39,7 +39,7 @@
* @return A valid SDL_RWops structure on success, NULL on error. Specifics
* of the error can be gleaned from PHYSFS_getLastError().
*/
-__EXPORT__ SDL_RWops *PHYSFSRWOPS_openRead(const char *fname);
+SDL_RWops *PHYSFSRWOPS_openRead(const char *fname);
/**
* Open a platform-independent filename for writing, and make it accessible
@@ -51,7 +51,7 @@
* @return A valid SDL_RWops structure on success, NULL on error. Specifics
* of the error can be gleaned from PHYSFS_getLastError().
*/
-__EXPORT__ SDL_RWops *PHYSFSRWOPS_openWrite(const char *fname);
+SDL_RWops *PHYSFSRWOPS_openWrite(const char *fname);
/**
* Open a platform-independent filename for appending, and make it accessible
@@ -63,7 +63,7 @@
* @return A valid SDL_RWops structure on success, NULL on error. Specifics
* of the error can be gleaned from PHYSFS_getLastError().
*/
-__EXPORT__ SDL_RWops *PHYSFSRWOPS_openAppend(const char *fname);
+SDL_RWops *PHYSFSRWOPS_openAppend(const char *fname);
/**
* Make a SDL_RWops from an existing PhysicsFS file handle. You should
@@ -75,7 +75,7 @@
* @return A valid SDL_RWops structure on success, NULL on error. Specifics
* of the error can be gleaned from PHYSFS_getLastError().
*/
-__EXPORT__ SDL_RWops *PHYSFSRWOPS_makeRWops(PHYSFS_file *handle);
+SDL_RWops *PHYSFSRWOPS_makeRWops(PHYSFS_file *handle);
#ifdef __cplusplus
}

View File

@ -0,0 +1,18 @@
From: Julian Ospald <hasufell@gentoo.org>
Date: Tue Aug 21 12:42:14 UTC 2012
Subject: build system
fix underlinking
--- SDL_sound-1.0.3/Makefile.am
+++ SDL_sound-1.0.3/Makefile.am
@@ -32,7 +32,8 @@
-version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE)
libSDL_sound_la_LIBADD = \
decoders/libdecoders.la \
- $(TIMIDITY_LIB) $(MPGLIB_LIB)
+ $(TIMIDITY_LIB) $(MPGLIB_LIB) \
+ -lm
EXTRA_DIST = \
CREDITS \