liba52: fix CFLAGS and force regenerate configure to avoid incorrect building, thanks horrorStruck

This commit is contained in:
Danny Rawlins 2011-10-06 01:40:49 +11:00
parent 58713f2f4e
commit 1f02203017
3 changed files with 65 additions and 4 deletions

View File

@ -1 +1,2 @@
550243ceecf1a48790d2f863cdfe6cf1 a52dec-0.7.4-host.patch
caa9f5bc44232dc8aeea773fea56be80 a52dec-0.7.4.tar.gz

View File

@ -2,18 +2,22 @@
# URL: http://liba52.sourceforge.net/
# Maintainer: Danny Rawlins, monster dot romster at gmail dot com
# Packager: Matt Housh, jaeger at morpheus dot net
# Depends on:
name=liba52
version=0.7.4
release=2
source=(http://liba52.sourceforge.net/files/a52dec-$version.tar.gz)
release=3
source=(http://liba52.sourceforge.net/files/a52dec-$version.tar.gz
a52dec-0.7.4-host.patch)
build() {
cd a52dec-$version
patch -p 1 -i $SRC/a52dec-0.7.4-host.patch
./bootstrap
./configure \
--prefix=/usr \
--mandir=$PKG//usr/man \
--disable-solaris-audio \
--disable-win \
--disable-static \
@ -26,4 +30,3 @@ build() {
# required for xine-lib
install -m644 liba52/a52_internal.h $PKG/usr/include/a52dec/
}

View File

@ -0,0 +1,57 @@
diff -pruN a52dec-0.7.4.orig/Makefile.am a52dec-0.7.4/Makefile.am
--- a52dec-0.7.4.orig/Makefile.am 2011-10-05 14:10:37.223711385 +0000
+++ a52dec-0.7.4/Makefile.am 2011-10-05 14:15:59.871711150 +0000
@@ -1,3 +1,5 @@
+ACLOCAL_AMFLAGS = -I m4
+
SUBDIRS = autotools include doc liba52 libao src vc++ test
EXTRA_DIST = HISTORY bootstrap
diff -pruN a52dec-0.7.4.orig/configure.in a52dec-0.7.4/configure.in
--- a52dec-0.7.4.orig/configure.in 2011-10-05 14:10:37.222711385 +0000
+++ a52dec-0.7.4/configure.in 2011-10-05 14:13:24.063711264 +0000
@@ -1,6 +1,7 @@
dnl Process this file with autoconf to produce a configure script.
AC_PREREQ(2.52)
AC_INIT
+AC_CONFIG_MACRO_DIR([m4])
AC_CONFIG_SRCDIR([src/a52dec.c])
AC_CONFIG_AUX_DIR(autotools)
AC_CONFIG_FILES([Makefile autotools/Makefile include/Makefile test/Makefile
@@ -32,15 +33,9 @@ if test x"$GCC" = x"yes"; then
dnl arch-specific flags
case "$host" in
- i?86-* | k?-*)
- case "$host" in
- i386-*) OPT_CFLAGS="$CFLAGS -mcpu=i386";;
- i486-*) OPT_CFLAGS="$CFLAGS -mcpu=i486";;
- i586-*) OPT_CFLAGS="$CFLAGS -mcpu=pentium";;
- i686-*) OPT_CFLAGS="$CFLAGS -mcpu=pentiumpro";;
- k6-*) OPT_CFLAGS="$CFLAGS -mcpu=k6";;
- esac
- AC_TRY_CFLAGS([$OPT_CFLAGS],[CFLAGS=$OPT_CFLAGS]);;
+ x86_64-*)
+ OPT_CFLAGS="$CFLAGS -fPIC"
+ AC_TRY_CFLAGS([$OPT_CFLAGS],[CFLAGS=$OPT_CFLAGS]);;
sparc-* | sparc64-*)
OPT_CFLAGS="$CFLAGS -mtune=ultrasparc"
AC_TRY_CFLAGS([$OPT_CFLAGS],[CFLAGS=$OPT_CFLAGS]);;
diff -pruN a52dec-0.7.4.orig/liba52/Makefile.am a52dec-0.7.4/liba52/Makefile.am
--- a52dec-0.7.4.orig/liba52/Makefile.am 2011-10-05 14:10:37.221711385 +0000
+++ a52dec-0.7.4/liba52/Makefile.am 2011-10-05 14:14:26.310711218 +0000
@@ -1,4 +1,4 @@
-CFLAGS = @CFLAGS@ @LIBA52_CFLAGS@
+AM_CFLAGS = @CFLAGS@ @LIBA52_CFLAGS@
lib_LTLIBRARIES = liba52.la
diff -pruN a52dec-0.7.4.orig/src/Makefile.am a52dec-0.7.4/src/Makefile.am
--- a52dec-0.7.4.orig/src/Makefile.am 2011-10-05 14:10:37.221711385 +0000
+++ a52dec-0.7.4/src/Makefile.am 2011-10-05 14:14:46.505711204 +0000
@@ -1,4 +1,4 @@
-CFLAGS = @A52DEC_CFLAGS@
+AM_CFLAGS = @A52DEC_CFLAGS@
bin_PROGRAMS = a52dec extract_a52
a52dec_SOURCES = a52dec.c getopt.c gettimeofday.c