gcj: clean up Pkgfile, fix patches and footprint

This commit is contained in:
Danny Rawlins 2008-01-10 23:49:14 +11:00
parent 04d2fc7e6b
commit 206bbffcf1
4 changed files with 30 additions and 30 deletions

View File

@ -11,15 +11,11 @@ drwxr-xr-x root/root usr/bin/
-rwxr-xr-x root/root usr/bin/gkeytool
-rwxr-xr-x root/root usr/bin/grmic
-rwxr-xr-x root/root usr/bin/grmiregistry
-rwxr-xr-x root/root usr/bin/jar
lrwxrwxrwx root/root usr/bin/jc1 -> /usr/libexec/gcc/i686-pc-linux-gnu/4.2.2/jc1
-rwxr-xr-x root/root usr/bin/jcf-dump
-rwxr-xr-x root/root usr/bin/jv-convert
-rwxr-xr-x root/root usr/bin/jv-scan
drwxr-xr-x root/root usr/lib/
drwxr-xr-x root/root usr/lib/distcc/
lrwxrwxrwx root/root usr/lib/distcc/gcj -> ../../bin/distcc
lrwxrwxrwx root/root usr/lib/distcc/jc1 -> ../../bin/distcc
drwxr-xr-x root/root usr/lib/gcc/
drwxr-xr-x root/root usr/lib/gcc/i686-pc-linux-gnu/
drwxr-xr-x root/root usr/lib/gcc/i686-pc-linux-gnu/4.2.2/
@ -4428,6 +4424,8 @@ lrwxrwxrwx root/root usr/lib/gcc/i686-pc-linux-gnu/4.2.2/libstdc++.so.6 -> libst
-rwxr-xr-x root/root usr/lib/gcc/i686-pc-linux-gnu/4.2.2/libsupc++.la
drwxr-xr-x root/root usr/lib/gcj-4.2.2/
-rw-r--r-- root/root usr/lib/gcj-4.2.2/classmap.db
-rwxr-xr-x root/root usr/lib/gcj-4.2.2/libgjsmalsa.la
-rwxr-xr-x root/root usr/lib/gcj-4.2.2/libgjsmalsa.so
-rw-r--r-- root/root usr/lib/gcj-4.2.2/libjvm.a
-rwxr-xr-x root/root usr/lib/gcj-4.2.2/libjvm.la
-rwxr-xr-x root/root usr/lib/gcj-4.2.2/libjvm.so

View File

@ -2,11 +2,11 @@
# URL: http://gcc.gnu.org/
# Maintainer: Danny Rawlins, romster at shortcircuit dot net dot au
# Packager: Aaron Marks, nymacro at gmail dot com
# Depends On: texinfo
# Depends On: alsa-lib
name=gcj
version=4.2.2
release=1
release=2
source=(ftp://ftp.gnu.org/pub/gnu/gcc/gcc-$version/gcc-{core,g++,java}-$version.tar.bz2 \
gcj-$version-nocheck-fixincludes.patch \
gcj-$version-fixinc.patch)
@ -35,7 +35,7 @@ build() {
make bootstrap
make check
make -j1 prefix=$PKG/usr install
make prefix=$PKG/usr install
ln -sf /usr/libexec/gcc/i686-pc-linux-gnu/$version/jc1 $PKG/usr/bin/jc1
@ -53,9 +53,11 @@ build() {
$PKG/usr/lib/gcc/*/$version/install-tools
# remove files already on the system out of the port
for i in $(find $PKG | sed -e "s|$PKG|/|"); do
if [ -e "$i" ] && [ ! -d "$i" ] ; then
rm $PKG/$i
for i in $(pkginfo -l gcc |sed -e "s|^|/|"); do
if [ -e "$i" ] && [ ! -d "$i" ]; then
if [ -e "$PKG$i" ]; then
rm "$PKG$i"
fi
fi
done

View File

@ -1,16 +1,16 @@
--- gcc-4.1-20060505/gcc/Makefile.in.orig 2006-05-12 12:50:13.051496504 +0200
+++ gcc-4.1-20060505/gcc/Makefile.in 2006-05-12 12:51:05.218565904 +0200
@@ -3178,12 +3178,7 @@
fi
rm -rf include; mkdir include
-chmod a+rx include
- (TARGET_MACHINE='$(target)'; srcdir=`cd $(srcdir); ${PWD_COMMAND}`; \
- SHELL='$(SHELL)'; MACRO_LIST=`${PWD_COMMAND}`/macro_list ; \
- export TARGET_MACHINE srcdir SHELL MACRO_LIST && \
- cd $(build_objdir)/fixincludes && \
- $(SHELL) ./fixinc.sh ../../gcc/include \
- $(SYSTEM_HEADER_DIR) $(OTHER_FIXINCLUDES_DIRS) )
+ cd $(build_objdir)/fixincludes
rm -f include/syslimits.h
if [ -f include/limits.h ]; then \
mv include/limits.h include/syslimits.h; \
diff -Nru gcc-4.2.1.orig/gcc/Makefile.in gcc-4.2.1/gcc/Makefile.in
--- gcc-4.2.1.orig/gcc/Makefile.in 2007-08-15 13:45:59.000000000 +0200
+++ gcc-4.2.1/gcc/Makefile.in 2007-08-15 14:57:32.000000000 +0200
@@ -3251,12 +3251,6 @@
$(MAKE) real-$(INSTALL_HEADERS_DIR) DESTDIR=`pwd`/../gcc/ \
libsubdir=. ; \
else \
- (TARGET_MACHINE='$(target)'; srcdir=`cd $(srcdir); ${PWD_COMMAND}`; \
- SHELL='$(SHELL)'; MACRO_LIST=`${PWD_COMMAND}`/macro_list ; \
- export TARGET_MACHINE srcdir SHELL MACRO_LIST && \
- cd $(build_objdir)/fixincludes && \
- $(SHELL) ./fixinc.sh ../../gcc/include \
- $(SYSTEM_HEADER_DIR) $(OTHER_FIXINCLUDES_DIRS) ); \
rm -f include/syslimits.h; \
if [ -f include/limits.h ]; then \
mv include/limits.h include/syslimits.h; \

View File

@ -1,7 +1,7 @@
diff -Nru gcc-4.0.3-old/fixincludes/Makefile.in gcc-4.0.3/fixincludes/Makefile.in
--- gcc-4.0.3-old/fixincludes/Makefile.in 2006-03-14 02:13:34.000000000 +0100
+++ gcc-4.0.3/fixincludes/Makefile.in 2006-03-14 02:17:39.000000000 +0100
@@ -163,9 +163,7 @@
diff -Nru gcc-4.2.1.orig/fixincludes/Makefile.in gcc-4.2.1/fixincludes/Makefile.in
--- gcc-4.2.1.orig/fixincludes/Makefile.in 2007-08-15 13:45:59.000000000 +0200
+++ gcc-4.2.1/fixincludes/Makefile.in 2007-08-15 14:21:16.000000000 +0200
@@ -169,9 +169,7 @@
cp $(srcdir)/../gcc/aclocal.m4 .
check : all