gcc-fortran: 4.0.3 -> 4.1.2
This commit is contained in:
parent
c71e4a706e
commit
213d996e01
@ -4,15 +4,23 @@ lrwxrwxrwx root/root usr/bin/f90 -> gfortran
|
|||||||
lrwxrwxrwx root/root usr/bin/f95 -> gfortran
|
lrwxrwxrwx root/root usr/bin/f95 -> gfortran
|
||||||
-rwxr-xr-x root/root usr/bin/gfortran
|
-rwxr-xr-x root/root usr/bin/gfortran
|
||||||
drwxr-xr-x root/root usr/lib/
|
drwxr-xr-x root/root usr/lib/
|
||||||
|
drwxr-xr-x root/root usr/lib/ccache/
|
||||||
|
lrwxrwxrwx root/root usr/lib/ccache/f90 -> ../../bin/ccache
|
||||||
|
lrwxrwxrwx root/root usr/lib/ccache/f95 -> ../../bin/ccache
|
||||||
|
lrwxrwxrwx root/root usr/lib/ccache/gfortran -> ../../bin/ccache
|
||||||
|
drwxr-xr-x root/root usr/lib/distcc/
|
||||||
|
lrwxrwxrwx root/root usr/lib/distcc/f90 -> ../../bin/distcc
|
||||||
|
lrwxrwxrwx root/root usr/lib/distcc/f95 -> ../../bin/distcc
|
||||||
|
lrwxrwxrwx root/root usr/lib/distcc/gfortran -> ../../bin/distcc
|
||||||
drwxr-xr-x root/root usr/lib/gcc/
|
drwxr-xr-x root/root usr/lib/gcc/
|
||||||
drwxr-xr-x root/root usr/lib/gcc/i686-pc-linux-gnu/
|
drwxr-xr-x root/root usr/lib/gcc/i686-pc-linux-gnu/
|
||||||
drwxr-xr-x root/root usr/lib/gcc/i686-pc-linux-gnu/4.0.3/
|
drwxr-xr-x root/root usr/lib/gcc/i686-pc-linux-gnu/4.1.2/
|
||||||
-rwxr-xr-x root/root usr/lib/gcc/i686-pc-linux-gnu/4.0.3/f951
|
-rwxr-xr-x root/root usr/lib/gcc/i686-pc-linux-gnu/4.1.2/f951
|
||||||
-rw-r--r-- root/root usr/lib/libgfortran.a
|
-rw-r--r-- root/root usr/lib/libgfortran.a
|
||||||
-rwxr-xr-x root/root usr/lib/libgfortran.la
|
-rwxr-xr-x root/root usr/lib/libgfortran.la
|
||||||
lrwxrwxrwx root/root usr/lib/libgfortran.so -> libgfortran.so.0.0.0
|
lrwxrwxrwx root/root usr/lib/libgfortran.so -> libgfortran.so.1.0.0
|
||||||
lrwxrwxrwx root/root usr/lib/libgfortran.so.0 -> libgfortran.so.0.0.0
|
lrwxrwxrwx root/root usr/lib/libgfortran.so.1 -> libgfortran.so.1.0.0
|
||||||
-rwxr-xr-x root/root usr/lib/libgfortran.so.0.0.0
|
-rwxr-xr-x root/root usr/lib/libgfortran.so.1.0.0
|
||||||
-rw-r--r-- root/root usr/lib/libgfortranbegin.a
|
-rw-r--r-- root/root usr/lib/libgfortranbegin.a
|
||||||
-rwxr-xr-x root/root usr/lib/libgfortranbegin.la
|
-rwxr-xr-x root/root usr/lib/libgfortranbegin.la
|
||||||
drwxr-xr-x root/root usr/man/
|
drwxr-xr-x root/root usr/man/
|
||||||
|
@ -1,3 +1,4 @@
|
|||||||
347231730fb44b609b69226c3e432d80 gcc-core-4.0.3.tar.bz2
|
2af3fb599635219171c6ae1f3034888a gcc-core-4.1.2.tar.bz2
|
||||||
e35acd0ee75799f0a82b6e9c7e330073 gcc-fortran-4.0.3-version.patch
|
30e33e6ecedfc346f48240589414aa92 gcc-fortran-4.1.2-fixinc.patch
|
||||||
62db1b0901dccad81f6bc2792dbbbd49 gcc-fortran-4.0.3.tar.bz2
|
36fb6ec15a5f2a6572da0b02a3cf9d66 gcc-fortran-4.1.2-nocheck-fixincludes.patch
|
||||||
|
39621038e425c73f955db8c8db411c34 gcc-fortran-4.1.2.tar.bz2
|
||||||
|
@ -5,18 +5,23 @@
|
|||||||
# Depends on: libmpfr
|
# Depends on: libmpfr
|
||||||
|
|
||||||
name=gcc-fortran
|
name=gcc-fortran
|
||||||
version=4.0.3
|
version=4.1.2
|
||||||
release=3
|
release=3
|
||||||
source=(ftp://sources.redhat.com/pub/gcc/releases/gcc-$version/gcc-{core,fortran}-$version.tar.bz2 \
|
source=(ftp://sources.redhat.com/pub/gcc/releases/gcc-$version/gcc-{core,fortran}-$version.tar.bz2 \
|
||||||
gcc-fortran-$version-version.patch)
|
gcc-fortran-$version-nocheck-fixincludes.patch \
|
||||||
|
gcc-fortran-$version-fixinc.patch)
|
||||||
|
|
||||||
build() {
|
build() {
|
||||||
patch -d gcc-$version -p1 -i $SRC/gcc-fortran-$version-version.patch
|
patch -d gcc-$version -p1 -i $SRC/gcc-fortran-$version-nocheck-fixincludes.patch
|
||||||
cd gcc-$version
|
patch -d gcc-$version -p1 -i $SRC/gcc-fortran-$version-fixinc.patch
|
||||||
|
|
||||||
|
sed -i -e 's|VERSUFFIX ""|VERSUFFIX " (CRUX)"|' \
|
||||||
|
gcc-$version/gcc/version.c
|
||||||
|
|
||||||
mkdir build
|
mkdir build
|
||||||
cd build
|
cd build
|
||||||
|
|
||||||
../configure \
|
../gcc-$version/configure \
|
||||||
--prefix=/usr \
|
--prefix=/usr \
|
||||||
--libexecdir=/usr/lib \
|
--libexecdir=/usr/lib \
|
||||||
--enable-languages=f95 \
|
--enable-languages=f95 \
|
||||||
@ -27,15 +32,15 @@ build() {
|
|||||||
--disable-nls \
|
--disable-nls \
|
||||||
--with-x=no
|
--with-x=no
|
||||||
|
|
||||||
make
|
make bootstrap
|
||||||
#make check
|
make check
|
||||||
make DESTDIR=$PKG install
|
make DESTDIR=$PKG install
|
||||||
|
|
||||||
ln -s gfortran $PKG/usr/bin/f90
|
ln -fs gfortran $PKG/usr/bin/f90
|
||||||
ln -s gfortran $PKG/usr/bin/f95
|
ln -fs gfortran $PKG/usr/bin/f95
|
||||||
|
|
||||||
# remove un-needed files
|
# remove un-needed files
|
||||||
find $PKG -name 'README' -exec rm {} \;
|
find $PKG -name 'README' -delete
|
||||||
|
|
||||||
rm \
|
rm \
|
||||||
$PKG/usr/lib/libiberty.a \
|
$PKG/usr/lib/libiberty.a \
|
||||||
@ -62,5 +67,21 @@ build() {
|
|||||||
for i in `find $PKG -name '*.la' | sed -e "s|$PKG|/|"`; do
|
for i in `find $PKG -name '*.la' | sed -e "s|$PKG|/|"`; do
|
||||||
sed -i "s|-L$SRC[^ ]* ||g" $PKG/$i
|
sed -i "s|-L$SRC[^ ]* ||g" $PKG/$i
|
||||||
done
|
done
|
||||||
|
|
||||||
|
# install distcc symlinks if distcc is installed
|
||||||
|
if prt-get listinst distcc > /dev/null; then
|
||||||
|
install -d $PKG/usr/lib/distcc
|
||||||
|
for c in f90 f95 gfortran; do
|
||||||
|
cd $PKG/usr/lib/distcc && ln -s ../../bin/distcc $c
|
||||||
|
done
|
||||||
|
fi
|
||||||
|
|
||||||
|
# install ccache symlinks if ccache is installed
|
||||||
|
if prt-get listinst ccache > /dev/null; then
|
||||||
|
install -d $PKG/usr/lib/ccache
|
||||||
|
for c in f90 f95 gfortran; do
|
||||||
|
cd $PKG/usr/lib/ccache && ln -s ../../bin/ccache $c
|
||||||
|
done
|
||||||
|
fi
|
||||||
}
|
}
|
||||||
|
|
||||||
|
@ -1,12 +0,0 @@
|
|||||||
diff -Nru gcc-4.0.3-old/gcc/version.c gcc-4.0.3/gcc/version.c
|
|
||||||
--- gcc-4.0.3-old/gcc/version.c 2006-03-14 02:13:18.000000000 +0100
|
|
||||||
+++ gcc-4.0.3/gcc/version.c 2006-03-14 02:14:20.000000000 +0100
|
|
||||||
@@ -5,7 +5,7 @@
|
|
||||||
please modify this string to indicate that, e.g. by putting your
|
|
||||||
organization's name in parentheses at the end of the string. */
|
|
||||||
|
|
||||||
-const char version_string[] = "4.0.3";
|
|
||||||
+const char version_string[] = "4.0.3 (CRUX)";
|
|
||||||
|
|
||||||
/* This is the location of the online document giving instructions for
|
|
||||||
reporting bugs. If you distribute a modified version of GCC,
|
|
16
gcc-fortran/gcc-fortran-4.1.2-fixinc.patch
Normal file
16
gcc-fortran/gcc-fortran-4.1.2-fixinc.patch
Normal file
@ -0,0 +1,16 @@
|
|||||||
|
--- gcc-4.1-20060505/gcc/Makefile.in.orig 2006-05-12 12:50:13.051496504 +0200
|
||||||
|
+++ gcc-4.1-20060505/gcc/Makefile.in 2006-05-12 12:51:05.218565904 +0200
|
||||||
|
@@ -3178,12 +3178,7 @@
|
||||||
|
fi
|
||||||
|
rm -rf include; mkdir include
|
||||||
|
-chmod a+rx include
|
||||||
|
- (TARGET_MACHINE='$(target)'; srcdir=`cd $(srcdir); ${PWD_COMMAND}`; \
|
||||||
|
- SHELL='$(SHELL)'; MACRO_LIST=`${PWD_COMMAND}`/macro_list ; \
|
||||||
|
- export TARGET_MACHINE srcdir SHELL MACRO_LIST && \
|
||||||
|
- cd $(build_objdir)/fixincludes && \
|
||||||
|
- $(SHELL) ./fixinc.sh ../../gcc/include \
|
||||||
|
- $(SYSTEM_HEADER_DIR) $(OTHER_FIXINCLUDES_DIRS) )
|
||||||
|
+ cd $(build_objdir)/fixincludes
|
||||||
|
rm -f include/syslimits.h
|
||||||
|
if [ -f include/limits.h ]; then \
|
||||||
|
mv include/limits.h include/syslimits.h; \
|
14
gcc-fortran/gcc-fortran-4.1.2-nocheck-fixincludes.patch
Normal file
14
gcc-fortran/gcc-fortran-4.1.2-nocheck-fixincludes.patch
Normal file
@ -0,0 +1,14 @@
|
|||||||
|
diff -Nru gcc-4.0.3-old/fixincludes/Makefile.in gcc-4.0.3/fixincludes/Makefile.in
|
||||||
|
--- gcc-4.0.3-old/fixincludes/Makefile.in 2006-03-14 02:13:34.000000000 +0100
|
||||||
|
+++ gcc-4.0.3/fixincludes/Makefile.in 2006-03-14 02:17:39.000000000 +0100
|
||||||
|
@@ -163,9 +163,7 @@
|
||||||
|
cp $(srcdir)/../gcc/aclocal.m4 .
|
||||||
|
|
||||||
|
check : all
|
||||||
|
- autogen -T $(srcdir)/check.tpl $(srcdir)/inclhack.def
|
||||||
|
- $(SHELL) ./check.sh $(srcdir)/tests/base
|
||||||
|
- @rm -f ./check.sh
|
||||||
|
+ echo "No check here.."
|
||||||
|
|
||||||
|
install : all
|
||||||
|
-rm -rf $(DESTDIR)$(itoolsdir)
|
Loading…
x
Reference in New Issue
Block a user