syslinux: updated to 4.02

This commit is contained in:
Jose V Beneyto 2010-08-03 17:40:31 +02:00 committed by Bartlomiej Palmowski
parent ecb0718217
commit 2293237e2a
4 changed files with 22 additions and 15 deletions

View File

@ -53,6 +53,7 @@ drwxr-sr-x root/root usr/share/syslinux/com32/include/bitsize/
-rw-r--r-- root/root usr/share/syslinux/com32/include/endian.h
-rw-r--r-- root/root usr/share/syslinux/com32/include/errno.h
-rw-r--r-- root/root usr/share/syslinux/com32/include/fcntl.h
-rw-r--r-- root/root usr/share/syslinux/com32/include/getopt.h
drwxr-sr-x root/root usr/share/syslinux/com32/include/gplinclude/
-rw-r--r-- root/root usr/share/syslinux/com32/include/gplinclude/README
-rw-r--r-- root/root usr/share/syslinux/com32/include/gplinclude/cpuid.h
@ -214,3 +215,4 @@ drwxr-xr-x root/root usr/share/syslinux/dosutil/
-rw-r--r-- root/root usr/share/syslinux/vesainfo.c32
-rw-r--r-- root/root usr/share/syslinux/vesamenu.c32
-rw-r--r-- root/root usr/share/syslinux/vpdtest.c32
-rw-r--r-- root/root usr/share/syslinux/whichsys.c32

View File

@ -1,2 +1,2 @@
31d7443aba31984a52806b0e9d859e0f dos_out.patch
fbc5b153928d0489e429c7ab4384b0d9 syslinux-4.01.tar.bz2
8f4b5571157f0025c6c5ed0986268a87 dos_out.patch
52912c03f5c275d6c0ac09180ebab81f syslinux-4.02.tar.bz2

View File

@ -5,15 +5,20 @@
# Depends on: mtools perl
name=syslinux
version=4.01
release=2
version=4.02
release=1
source=(http://www.kernel.org/pub/linux/utils/boot/$name/$name-$version.tar.bz2 \
dos_out.patch)
build() {
cd $name-$version
# do not build win/dos installers
patch -Np1 -i $SRC/dos_out.patch
# compilation will fail with LDFLAGS
unset LDFLAGS
make OPTFLAGS="$CFLAGS"
make INSTALLROOT=$PKG install

View File

@ -1,32 +1,32 @@
--- syslinux-4.01/Makefile 2010-07-02 18:19:39.000000000 +0000
+++ syslinux-4.01/Makefile.new 2010-07-16 19:02:01.987047109 +0000
@@ -43,9 +43,7 @@
diff -purN syslinux-4.02.orig/Makefile syslinux-4.02/Makefile
--- syslinux-4.02.orig/Makefile 2010-08-03 17:31:39.000000000 +0200
+++ syslinux-4.02/Makefile 2010-08-03 17:34:17.000000000 +0200
@@ -43,10 +43,7 @@ BOBJECTS = $(BTARGET) \
mbr/mbr_c.bin mbr/altmbr_c.bin mbr/gptmbr_c.bin \
mbr/mbr_f.bin mbr/altmbr_f.bin mbr/gptmbr_f.bin \
core/pxelinux.0 core/isolinux.bin core/isolinux-debug.bin \
- gpxe/gpxelinux.0 dos/syslinux.com win32/syslinux.exe \
- gpxe/gpxelinux.0 dos/syslinux.com \
- win32/syslinux.exe win64/syslinux64.exe \
- dosutil/*.com dosutil/*.sys \
- $(MODULES)
+ gpxe/gpxelinux.0 $(MODULES)
# BSUBDIRs build the on-target binary components.
# ISUBDIRs build the installer (host) components.
@@ -54,7 +52,7 @@
@@ -55,7 +52,7 @@ BOBJECTS = $(BTARGET) \
# files that depend only on the B phase, but may have to be regenerated
# for "make installer".
BSUBDIRS = codepage com32 lzo core memdisk modules mbr memdump gpxe sample \
- libinstaller dos win32 dosutil
- libinstaller dos win32 win64 dosutil
+ libinstaller
ITARGET =
IOBJECTS = $(ITARGET) \
utils/gethostip utils/isohybrid utils/mkdiskimage \
@@ -68,12 +66,11 @@
# Things to install in /usr/lib/syslinux
INSTALL_AUX = core/pxelinux.0 gpxe/gpxelinux.0 core/isolinux.bin \
@@ -71,10 +68,10 @@ INSTALL_AUX = core/pxelinux.0 gpxe/gpx
core/isolinux-debug.bin \
- dos/syslinux.com win32/syslinux.exe \
dos/syslinux.com \
mbr/*.bin $(MODULES)
-INSTALL_AUX_OPT = win32/syslinux.exe
-INSTALL_AUX_OPT = win32/syslinux.exe win64/syslinux64.exe
+INSTALL_AUX_OPT =
# These directories manage their own installables