pjsua: dropped unmaintained port
This commit is contained in:
parent
f74be215b4
commit
2323201cf4
@ -1,12 +0,0 @@
|
||||
drwxr-xr-x root/root usr/
|
||||
drwxr-xr-x root/root usr/bin/
|
||||
-rwxr-xr-x root/root usr/bin/pjsua
|
||||
drwxr-xr-x root/root usr/lib/
|
||||
drwxr-xr-x root/root usr/lib/python3.9/
|
||||
drwxr-xr-x root/root usr/lib/python3.9/site-packages/
|
||||
drwxr-xr-x root/root usr/lib/python3.9/site-packages/__pycache__/
|
||||
-rw-r--r-- root/root usr/lib/python3.9/site-packages/__pycache__/pjsua2.cpython-39.opt-1.pyc
|
||||
-rw-r--r-- root/root usr/lib/python3.9/site-packages/__pycache__/pjsua2.cpython-39.pyc
|
||||
-rwxr-xr-x root/root usr/lib/python3.9/site-packages/_pjsua2.cpython-39-x86_64-linux-gnu.so
|
||||
-rw-r--r-- root/root usr/lib/python3.9/site-packages/pjsua2-2.10-py3.9.egg-info
|
||||
-rw-r--r-- root/root usr/lib/python3.9/site-packages/pjsua2.py
|
@ -1,7 +0,0 @@
|
||||
untrusted comment: verify with /etc/ports/contrib.pub
|
||||
RWSagIOpLGJF3x5UxbCRPzex4QxNxeiIz+oIweQRqcRiszt/QrNP6DasV56KWUksydo1/R++cOO3NUHi5hHW7F+fKZJ1Wbw5pAI=
|
||||
SHA256 (Pkgfile) = f77de81bee0a0c72920aa428f0c53cd61f6a0f0d587274b1b76e63c01e0e68b6
|
||||
SHA256 (.footprint) = 7c971688245f599f06ff9c6231e223a89b7b92571515977cfcb2731eed195e8b
|
||||
SHA256 (pjproject-2.10.tar.gz) = 936a4c5b98601b52325463a397ddf11ab4106c6a7b04f8dc7cdd377efbb597de
|
||||
SHA256 (config_site.h) = 61fa2a76d069aa5c95b6e2c539f7b20e2ccf0b126fc60c18117762541d0a7472
|
||||
SHA256 (0001-Don-t-build-Java-bindings.patch) = c6673d97185c2383140b6d915aeaa7e525c9cfb5f51c097472cf4773b4f87ab4
|
@ -1,26 +0,0 @@
|
||||
From c80630d6923f50b29fc136e75a8bed5de4ae50dd Mon Sep 17 00:00:00 2001
|
||||
From: Caleb Maclennan <caleb@alerque.com>
|
||||
Date: Sat, 22 Feb 2020 04:54:58 +0000
|
||||
Subject: [PATCH] Don't build Java bindings
|
||||
|
||||
Signed-off-by: Caleb Maclennan <caleb@alerque.com>
|
||||
---
|
||||
pjsip-apps/src/swig/Makefile | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/pjsip-apps/src/swig/Makefile b/pjsip-apps/src/swig/Makefile
|
||||
index abb317b..1f4759f 100644
|
||||
--- a/pjsip-apps/src/swig/Makefile
|
||||
+++ b/pjsip-apps/src/swig/Makefile
|
||||
@@ -7,7 +7,7 @@ else
|
||||
ifneq ($(findstring ios,$(TARGET_NAME)),)
|
||||
LANG = csharp
|
||||
else
|
||||
- LANG = python java
|
||||
+ LANG = python
|
||||
endif
|
||||
endif
|
||||
|
||||
--
|
||||
2.25.1
|
||||
|
@ -1,52 +0,0 @@
|
||||
# Description: Multimedia communication library
|
||||
# URL: https://www.pjsip.org/
|
||||
# Maintainer: Alan Mizrahi, alan at mizrahi dot com dot ve
|
||||
# Depends on: pjproject swig
|
||||
|
||||
name=pjsua
|
||||
version=2.10
|
||||
release=1
|
||||
source=(https://github.com/pjsip/pjproject/archive/$version/pjproject-$version.tar.gz
|
||||
config_site.h 0001-Don-t-build-Java-bindings.patch)
|
||||
|
||||
# Related ports:
|
||||
# pjsua: Standalone user-agent.
|
||||
# pjsip: The minimum that asterisk needs for res_pjsip.so and friends. Dynamic libraries.
|
||||
# pjproject: Libraries with most things enabled. Static and dynamic libraries.
|
||||
|
||||
build() {
|
||||
cd pjproject-$version
|
||||
patch -Np1 -i $SRC/0001-Don-t-build-Java-bindings.patch
|
||||
|
||||
export CFLAGS+=" -fPIC -DNDEBUG -Wno-error=deprecated-declarations"
|
||||
export CXXFLAGS+=" -fPIC -DNDEBUG -Wno-error=deprecated-declarations"
|
||||
|
||||
# pjsua will be dynamically linked as long as pjproject is installed beforehand.
|
||||
# otherwise it will be statically linked.
|
||||
./configure \
|
||||
--prefix=/usr \
|
||||
--with-external-pa \
|
||||
--with-external-gsm \
|
||||
--with-external-speex \
|
||||
--with-external-srtp \
|
||||
--with-sdl=/usr \
|
||||
--disable-openh264 \
|
||||
--enable-libsamplerate \
|
||||
--disable-resample_dll \
|
||||
$( [ -f /usr/lib/libpjsua.so ] && echo --enable-shared )
|
||||
|
||||
cp $SRC/config_site.h pjlib/include/pj/config_site.h
|
||||
|
||||
make -j1 dep
|
||||
make -j1
|
||||
|
||||
make -j1 -C pjsip-apps/src/swig
|
||||
pushd pjsip-apps/src/swig/python
|
||||
python3 setup.py build
|
||||
python3 setup.py install --root=$PKG --optimize=1 --skip-build
|
||||
popd
|
||||
make DESTDIR=$PKG -j1 -C pjsip-apps/src/swig
|
||||
|
||||
# install pjsua only
|
||||
install -D -m755 pjsip-apps/bin/pjsua-`./config.guess` $PKG/usr/bin/pjsua
|
||||
}
|
@ -1,3 +0,0 @@
|
||||
#define PJ_DEBUG 0
|
||||
#define PJ_TIMER_DEBUG 0
|
||||
#define PJ_HAS_IPV6 1
|
Loading…
x
Reference in New Issue
Block a user