dragonbox: initial commit, version 1.1.3

This commit is contained in:
Tim Biermann 2022-07-17 19:23:12 +02:00
parent 6a6f97ba5f
commit 27d3a3dae7
Signed by: tb
GPG Key ID: 42F8B4E30B673606
4 changed files with 69 additions and 0 deletions

13
dragonbox/.footprint Normal file
View File

@ -0,0 +1,13 @@
drwxr-xr-x root/root usr/
drwxr-xr-x root/root usr/include/
drwxr-xr-x root/root usr/include/dragonbox/
-rw-r--r-- root/root usr/include/dragonbox/dragonbox.h
-rw-r--r-- root/root usr/include/dragonbox/dragonbox_to_chars.h
drwxr-xr-x root/root usr/lib/
drwxr-xr-x root/root usr/lib/cmake/
drwxr-xr-x root/root usr/lib/cmake/dragonbox-1.1.3/
-rw-r--r-- root/root usr/lib/cmake/dragonbox-1.1.3/dragonboxConfig.cmake
-rw-r--r-- root/root usr/lib/cmake/dragonbox-1.1.3/dragonboxConfigVersion.cmake
-rw-r--r-- root/root usr/lib/cmake/dragonbox-1.1.3/dragonboxTargets-noconfig.cmake
-rw-r--r-- root/root usr/lib/cmake/dragonbox-1.1.3/dragonboxTargets.cmake
-rw-r--r-- root/root usr/lib/libdragonbox_to_chars.a

6
dragonbox/.signature Normal file
View File

@ -0,0 +1,6 @@
untrusted comment: verify with /etc/ports/contrib.pub
RWSagIOpLGJF3x1/x21y0zEN7y9qTXPMJfxQwwVG56Xlth77iCJgz1CuPtclVOZTePg2eblaHr9QAybZMvooFOw16SpsydGXUgs=
SHA256 (Pkgfile) = c8a384a18302b25ead019a60b0d64c3b9e7cb6fc8c438149f4796c3f6b2220c3
SHA256 (.footprint) = e11a77202700ff9cec8185770b6863f1d3ba28d7af3eef986557f84f9a839559
SHA256 (dragonbox-1.1.3.tar.gz) = 09d63b05e9c594ec423778ab59b7a5aa1d76fdd71d25c7048b0258c4ec9c3384
SHA256 (include.patch) = c3d6717547229bcc3424c98f3e14a77ddc79a282373ba378b06f9da7bdf53e05

22
dragonbox/Pkgfile Normal file
View File

@ -0,0 +1,22 @@
# Description: a float-to-string conversion algorithm based on Schubfach
# URL: https://github.com/jk-jeon/dragonbox
# Maintainer: Tim Biermann, tbier at posteo dot de
# Depends on: cmake ninja
name=dragonbox
version=1.1.3
release=1
source=(https://github.com/jk-jeon/dragonbox/archive/$version/$name-$version.tar.gz
include.patch)
build() {
patch -Np1 -d $name-$version -i $SRC/include.patch
cmake -S $name-$version -B build -G Ninja \
-D CMAKE_INSTALL_PREFIX=/usr \
-D CMAKE_INSTALL_LIBDIR=lib \
-Wno-dev
cmake --build build
DESTDIR=$PKG cmake --install build
}

28
dragonbox/include.patch Normal file
View File

@ -0,0 +1,28 @@
diff -Naur dragonbox-1.1.3.orig/CMakeLists.txt dragonbox-1.1.3/CMakeLists.txt
--- dragonbox-1.1.3.orig/CMakeLists.txt 2022-07-17 01:40:02.730339794 +0200
+++ dragonbox-1.1.3/CMakeLists.txt 2022-07-17 01:42:08.326148387 +0200
@@ -57,8 +57,7 @@
"When invoked with --install, dragonbox_to_chars.h/.cpp are installed along with dragonbox.h"
On)
-set(dragonbox_directory "dragonbox-${PROJECT_VERSION}")
-set(dragonbox_include_directory "${CMAKE_INSTALL_INCLUDEDIR}/${dragonbox_directory}")
+set(dragonbox_include_directory "${CMAKE_INSTALL_INCLUDEDIR}/")
set(dragonbox_install_targets "dragonbox")
if (DRAGONBOX_INSTALL_TO_CHARS)
@@ -73,6 +72,7 @@
INCLUDES #
DESTINATION "${dragonbox_include_directory}")
+set(dragonbox_directory "dragonbox-${PROJECT_VERSION}")
set(dragonbox_install_cmakedir "${CMAKE_INSTALL_LIBDIR}/cmake/${dragonbox_directory}")
write_basic_package_version_file(
@@ -120,4 +120,4 @@
/Zi /permissive-
$<$<NOT:$<CXX_COMPILER_ID:Clang>>:/experimental:newLambdaProcessor>
$<$<CONFIG:Release>:/GL>)
-endif()
\ No newline at end of file
+endif()