iotop: deleted unmaintained port

This commit is contained in:
Tim Biermann 2021-03-08 19:11:26 +00:00
parent a030f22b64
commit 3310329325
Signed by: tb
GPG Key ID: 42F8B4E30B673606
5 changed files with 0 additions and 95 deletions

View File

@ -1,28 +0,0 @@
drwxr-xr-x root/root usr/
drwxr-xr-x root/root usr/lib/
drwxr-xr-x root/root usr/lib/python3.9/
drwxr-xr-x root/root usr/lib/python3.9/site-packages/
drwxr-xr-x root/root usr/lib/python3.9/site-packages/iotop/
-rw-r--r-- root/root usr/lib/python3.9/site-packages/iotop/__init__.py (EMPTY)
drwxr-xr-x root/root usr/lib/python3.9/site-packages/iotop/__pycache__/
-rw-r--r-- root/root usr/lib/python3.9/site-packages/iotop/__pycache__/__init__.cpython-39.pyc
-rw-r--r-- root/root usr/lib/python3.9/site-packages/iotop/__pycache__/data.cpython-39.pyc
-rw-r--r-- root/root usr/lib/python3.9/site-packages/iotop/__pycache__/genetlink.cpython-39.pyc
-rw-r--r-- root/root usr/lib/python3.9/site-packages/iotop/__pycache__/ioprio.cpython-39.pyc
-rw-r--r-- root/root usr/lib/python3.9/site-packages/iotop/__pycache__/netlink.cpython-39.pyc
-rw-r--r-- root/root usr/lib/python3.9/site-packages/iotop/__pycache__/ui.cpython-39.pyc
-rw-r--r-- root/root usr/lib/python3.9/site-packages/iotop/__pycache__/version.cpython-39.pyc
-rw-r--r-- root/root usr/lib/python3.9/site-packages/iotop/__pycache__/vmstat.cpython-39.pyc
-rw-r--r-- root/root usr/lib/python3.9/site-packages/iotop/data.py
-rw-r--r-- root/root usr/lib/python3.9/site-packages/iotop/genetlink.py
-rw-r--r-- root/root usr/lib/python3.9/site-packages/iotop/ioprio.py
-rw-r--r-- root/root usr/lib/python3.9/site-packages/iotop/netlink.py
-rw-r--r-- root/root usr/lib/python3.9/site-packages/iotop/ui.py
-rw-r--r-- root/root usr/lib/python3.9/site-packages/iotop/version.py
-rw-r--r-- root/root usr/lib/python3.9/site-packages/iotop/vmstat.py
drwxr-xr-x root/root usr/sbin/
-rwxr-xr-x root/root usr/sbin/iotop
drwxr-xr-x root/root usr/share/
drwxr-xr-x root/root usr/share/man/
drwxr-xr-x root/root usr/share/man/man8/
-rw-r--r-- root/root usr/share/man/man8/iotop.8.gz

View File

@ -1,6 +0,0 @@
untrusted comment: verify with /etc/ports/contrib.pub
RWSagIOpLGJF329A/wiK7kSdjtccjw9bglL7SW+ACEK/ORUYi2O1uWwDHHX6SpcdcLMEHdm7LDdrMTmunlLYH9s/yDRrSt+mWAE=
SHA256 (Pkgfile) = c34a2b57534d3ee3289a88bf3bd8bf0a29f4ee6637027bcd45cb1e9f38beb3c2
SHA256 (.footprint) = 47fae6b0fabaa4b3ff0c1da63359f8be63dbe21eeac32133f71ef816775ee6a7
SHA256 (iotop-0.6.tar.bz2) = 3adea2a24eda49bbbaeb4e6ed2042355b441dbd7161e883067a02bfc8dcef75b
SHA256 (0001-Make-setp.py-compatible-with-python3.patch) = 1f1eb0cfde45911de9429771d90c9a282f5fed23455a9678a8e44e205f4103a3

View File

@ -1,30 +0,0 @@
From 98a5985e52e7041eb96c80dd95fd5c70634f5ee7 Mon Sep 17 00:00:00 2001
From: Justin Lecher <jlec@gentoo.org>
Date: Tue, 18 Jun 2013 08:19:28 +0200
Subject: [PATCH 1/4] Make setp.py compatible with python3
Dictionaries in python 3 do not contain the itervalues() method anymore.
The values() method should be used and can also safely applied for
python 2.
Signed-off-by: Justin Lecher <jlec@gentoo.org>
---
setup.py | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/setup.py b/setup.py
index 7150102..9de6068 100755
--- a/setup.py
+++ b/setup.py
@@ -7,7 +7,7 @@ from iotop.version import VERSION
# Dirty hack to make setup.py install the iotop script to sbin/ instead of bin/
# while still honoring the choice of installing into local/ or not.
if hasattr(distutils_install, 'INSTALL_SCHEMES'):
- for d in distutils_install.INSTALL_SCHEMES.itervalues():
+ for d in distutils_install.INSTALL_SCHEMES.values():
if d.get('scripts', '').endswith('/bin'):
d['scripts'] = d['scripts'][:-len('/bin')] + '/sbin'
--
2.24.1

View File

@ -1,20 +0,0 @@
# Description: top like program to display I/O load.
# URL: http://guichaz.free.fr/iotop/
# Maintainer: Fredrik Rinnestam, fredrik at crux dot nu
# Depends on: python3
name=iotop
version=0.6
release=2
source=(http://guichaz.free.fr/$name/files/$name-$version.tar.bz2 \
0001-Make-setp.py-compatible-with-python3.patch)
build() {
cd $name-$version
chmod ag+r iotop.8
patch -p1 -i $SRC/0001-Make-setp.py-compatible-with-python3.patch
/usr/bin/python3 setup.py install --root=$PKG --prefix=/usr
rm -r $PKG/usr/lib/python*/site-packages/iotop-*.egg-info
}

View File

@ -1,11 +0,0 @@
README for iotop
REQUIREMENTS
iotop requires Linux kernel >= 2.6.20 with the TASK_DELAY_ACCT and TASK_IO_ACCOUNTING options enabled.
PRE-INSTALL
POST-INSTALL
PRECAUTION