arpspoof: initial commit, v0.1.0.8359467

This commit is contained in:
Alexandr Savca 2020-11-21 12:33:17 +02:00
parent 01034c4da1
commit 39e2aea123
6 changed files with 90 additions and 0 deletions

14
arpspoof/.footprint Normal file
View File

@ -0,0 +1,14 @@
drwxr-xr-x root/root usr/
drwxr-xr-x root/root usr/bin/
-rwxr-xr-x root/root usr/bin/arpspoof
drwxr-xr-x root/root usr/lib/
drwxr-xr-x root/root usr/lib/python3.7/
drwxr-xr-x root/root usr/lib/python3.7/site-packages/
drwxr-xr-x root/root usr/lib/python3.7/site-packages/arpspoof/
-rw-r--r-- root/root usr/lib/python3.7/site-packages/arpspoof/__init__.py
drwxr-xr-x root/root usr/lib/python3.7/site-packages/arpspoof/__pycache__/
-rw-r--r-- root/root usr/lib/python3.7/site-packages/arpspoof/__pycache__/__init__.cpython-37.opt-1.pyc
-rw-r--r-- root/root usr/lib/python3.7/site-packages/arpspoof/__pycache__/__init__.cpython-37.pyc
-rw-r--r-- root/root usr/lib/python3.7/site-packages/arpspoof/__pycache__/arpspoof.cpython-37.opt-1.pyc
-rw-r--r-- root/root usr/lib/python3.7/site-packages/arpspoof/__pycache__/arpspoof.cpython-37.pyc
-rw-r--r-- root/root usr/lib/python3.7/site-packages/arpspoof/arpspoof.py

7
arpspoof/.signature Normal file
View File

@ -0,0 +1,7 @@
untrusted comment: verify with /etc/ports/contrib.pub
RWSagIOpLGJF31AzEqDWhXPc/GtIOCQjmEwAA2CUWJaAaP2PdAwG/b0123Gg/ir/ygKC5zOCt0/vUOBi0hCkfV4f8NZ1yhMmdg0=
SHA256 (Pkgfile) = 65d5c1da0054c64144190bedc56c08ecc3f9c8c0d3db8f6cbb018e9b3bf1e8e5
SHA256 (.footprint) = 9d73fe2e6c80194a3b82afcc9fb42e9c99350e50a299d2df5e68fe4683b1d881
SHA256 (arpspoof-83594671338218dd80d6328485179cf62f943c9d.zip) = 591e9447394db3d24ce77ef4d6cb40b7f4dc3dcd6e212815b93f20f3b10a8503
SHA256 (0001-arpspoof.py-show-help-without-root-privileges.patch) = c1cf0f365e88bd41ff9e8632fde68f74dafd15c812dff81cceb7e6c53e518252
SHA256 (arpspoof.sh) = b0a083bae3740aa9920b5386f144b0110e3d94fa0dbc1cd0dac974f1e822cd17

View File

@ -0,0 +1,30 @@
From c7b2e59aea9264113dcd4823bfebc33e1cb33fe3 Mon Sep 17 00:00:00 2001
From: Alexandr Savca <alexandrsavca89@gmail.com>
Date: Wed, 23 Sep 2020 14:43:59 +0300
Subject: [PATCH] arpspoof.py: show help without root privileges
---
arpspoof/arpspoof.py | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/arpspoof/arpspoof.py b/arpspoof/arpspoof.py
index 61c1d42..024648a 100644
--- a/arpspoof/arpspoof.py
+++ b/arpspoof/arpspoof.py
@@ -59,11 +59,12 @@ def init_args():
def main():
+ options, args = init_args()
+
if os.geteuid() != 0:
print("[-] Run me as root")
sys.exit(1)
- options, args = init_args()
host = args[0]
mac = get_if_hwaddr(options.interface)
--
2.28.0

29
arpspoof/Pkgfile Normal file
View File

@ -0,0 +1,29 @@
# Description: Poison hosts via arp-requests as well as arp-replies
# URL: https://github.com/byt3bl33d3r/arpspoof
# Maintainer: Alexandr Savca, alexandrsavca89 at gmail dot com
# Depends on: scapy
name=arpspoof
version=0.1.0.8359467
_commit=83594671338218dd80d6328485179cf62f943c9d
release=1
source=(https://github.com/byt3bl33d3r/$name/archive/$_commit/$name-$_commit.zip
0001-arpspoof.py-show-help-without-root-privileges.patch
$name.sh)
build() {
cd $name-$_commit
patch -p1 < $SRC/0001-arpspoof.py-show-help-without-root-privileges.patch
sed -i "s|Usage: %prog|Usage: $name|" $name/$name.py
python3 setup.py build
python3 setup.py install \
--prefix=/usr --root=$PKG --optimize=1 --skip-build
# remove junk
rm -r $PKG/usr/lib/python*/site-packages/$name-*.egg-info
# install wrapper
install -Dm755 $SRC/$name.sh $PKG/usr/bin/$name
}

7
arpspoof/README Normal file
View File

@ -0,0 +1,7 @@
README for arpspoof
NOTES
Basic spoofing usage:
arpspoof -i ${IFACE} -t ${VICTIM_IP} ${GW_IP} &
arpspoof -i ${IFACE} -t ${GW_IP} ${VICTIM_IP} &

3
arpspoof/arpspoof.sh Normal file
View File

@ -0,0 +1,3 @@
#!/bin/sh
PYVER=$(python3 -V | grep -Po '\d\.\d')
python3 /usr/lib/python${PYVER}/site-packages/arpspoof/arpspoof.py