privoxy: updated the patch as well since it didn't apply on openbsd
This commit is contained in:
parent
203866f298
commit
3b700cd3bf
@ -1,3 +1,3 @@
|
||||
9ba1024292ab59ed61e7cf7aea67cfc7 privoxy
|
||||
c3b34c620e1174f0c0b91aa2a04ceae4 privoxy-3.0.6-stable-src.tar.gz
|
||||
331e80626f29af345c5cd904f21025ae privoxy.diff
|
||||
bd4f165c28b6bbfca08c3ea6b3204087 privoxy.diff
|
||||
|
@ -1,19 +1,7 @@
|
||||
$OpenBSD: patch-GNUmakefile_in,v 1.2 2003/04/01 20:52:59 sturm Exp $
|
||||
--- GNUmakefile.in.orig Mon Nov 4 02:04:03 2002
|
||||
+++ GNUmakefile.in Sat Mar 29 18:17:02 2003
|
||||
@@ -226,7 +226,7 @@ PTHREAD_LIB = @PTHREAD_ONLY@@PTHREAD_LI
|
||||
SRCS = $(C_SRC) $(W32_SRC) $(PCRS_SRC) $(PCRE_SRC) $(REGEX_SRC)
|
||||
OBJS = $(C_OBJS) $(W32_OBJS) $(PCRS_OBJS) $(PCRE_OBJS) $(REGEX_OBJS)
|
||||
HDRS = $(C_HDRS) $(W32_HDRS) $(PCRS_HDRS) $(PCRE_OBJS) $(REGEX_HDRS)
|
||||
-LIBS = @LIBS@ $(W32_LIB) $(SOCKET_LIB) $(PTHREAD_LIB)
|
||||
+LIBS = @LDFLAGS@ @LIBS@ $(W32_LIB) $(SOCKET_LIB) $(PTHREAD_LIB)
|
||||
|
||||
|
||||
#############################################################################
|
||||
$OpenBSD: patch-cgi_c,v 1.2 2003/04/01 20:52:59 sturm Exp $
|
||||
--- cgi.c.orig Tue Mar 11 20:26:25 2003
|
||||
+++ cgi.c Sat Mar 29 18:17:02 2003
|
||||
@@ -1399,7 +1399,7 @@ jb_err cgi_error_unknown(struct client_s
|
||||
diff -rup ../privoxy-3.0.6-stable.orig/cgi.c ./cgi.c
|
||||
--- ../privoxy-3.0.6-stable.orig/cgi.c 2006-11-21 15:28:41.167678250 +0100
|
||||
+++ ./cgi.c 2006-11-21 15:29:06.048895730 +0100
|
||||
@@ -1533,7 +1533,7 @@ jb_err cgi_error_unknown(struct client_s
|
||||
rsp->head_length = 0;
|
||||
rsp->is_static = 0;
|
||||
|
||||
@ -22,7 +10,7 @@ $OpenBSD: patch-cgi_c,v 1.2 2003/04/01 20:52:59 sturm Exp $
|
||||
|
||||
rsp->body = malloc(strlen(body_prefix) + strlen(errnumbuf) + strlen(body_suffix) + 1);
|
||||
if (rsp->body == NULL)
|
||||
@@ -1596,7 +1596,7 @@ struct http_response *finish_http_respon
|
||||
@@ -1776,7 +1776,7 @@ struct http_response *finish_http_respon
|
||||
/*
|
||||
* Fill in the HTTP Status
|
||||
*/
|
||||
@ -31,7 +19,7 @@ $OpenBSD: patch-cgi_c,v 1.2 2003/04/01 20:52:59 sturm Exp $
|
||||
err = enlist_first(rsp->headers, buf);
|
||||
|
||||
/*
|
||||
@@ -1608,7 +1608,7 @@ struct http_response *finish_http_respon
|
||||
@@ -1788,7 +1788,7 @@ struct http_response *finish_http_respon
|
||||
}
|
||||
if (!err)
|
||||
{
|
||||
@ -40,10 +28,11 @@ $OpenBSD: patch-cgi_c,v 1.2 2003/04/01 20:52:59 sturm Exp $
|
||||
err = enlist(rsp->headers, buf);
|
||||
}
|
||||
|
||||
$OpenBSD: patch-cgisimple_c,v 1.1.1.1 2002/11/29 09:41:39 sturm Exp $
|
||||
--- cgisimple.c.orig Sun Nov 17 12:20:12 2002
|
||||
+++ cgisimple.c Sun Nov 17 12:21:30 2002
|
||||
@@ -843,13 +843,13 @@ jb_err cgi_show_status(struct client_sta
|
||||
Only in .: cgi.c~
|
||||
diff -rup ../privoxy-3.0.6-stable.orig/cgisimple.c ./cgisimple.c
|
||||
--- ../privoxy-3.0.6-stable.orig/cgisimple.c 2006-11-21 15:28:41.168678098 +0100
|
||||
+++ ./cgisimple.c 2006-11-21 15:29:06.051895274 +0100
|
||||
@@ -1007,13 +1007,13 @@ jb_err cgi_show_status(struct client_sta
|
||||
perc_rej = (float)local_urls_rejected * 100.0F /
|
||||
(float)local_urls_read;
|
||||
|
||||
@ -60,7 +49,7 @@ $OpenBSD: patch-cgisimple_c,v 1.1.1.1 2002/11/29 09:41:39 sturm Exp $
|
||||
if (!err) err = map(exports, "percent-blocked", 1, buf, 1);
|
||||
}
|
||||
|
||||
@@ -1382,7 +1382,7 @@ static char *show_rcs(void)
|
||||
@@ -1571,7 +1571,7 @@ static char *show_rcs(void)
|
||||
#define SHOW_RCS(__x) \
|
||||
{ \
|
||||
extern const char __x[]; \
|
||||
@ -69,20 +58,20 @@ $OpenBSD: patch-cgisimple_c,v 1.1.1.1 2002/11/29 09:41:39 sturm Exp $
|
||||
string_append(&result, buf); \
|
||||
}
|
||||
|
||||
$OpenBSD: patch-configure_in,v 1.2 2003/04/01 20:52:59 sturm Exp $
|
||||
--- configure.in.orig Tue Mar 25 19:25:00 2003
|
||||
+++ configure.in Sat Mar 29 18:17:02 2003
|
||||
Only in .: cgisimple.c~
|
||||
diff -rup ../privoxy-3.0.6-stable.orig/configure.in ./configure.in
|
||||
--- ../privoxy-3.0.6-stable.orig/configure.in 2006-11-21 15:28:41.170677794 +0100
|
||||
+++ ./configure.in 2006-11-21 15:29:06.054894818 +0100
|
||||
@@ -1,4 +1,4 @@
|
||||
-dnl Process this file with autoconf to produce a configure script.
|
||||
+/rdnl Process this file with autoconf to produce a configure script.
|
||||
dnl
|
||||
dnl $Id: patch-configure_in,v 1.2 2003/04/01 20:52:59 sturm Exp $
|
||||
dnl $Id: configure.in,v 1.96 2006/11/18 14:42:51 fabiankeil Exp $
|
||||
dnl
|
||||
@@ -705,24 +705,6 @@ if test $dodk != no; then
|
||||
fi
|
||||
@@ -760,24 +760,6 @@ fi
|
||||
AC_SUBST(WDUMP)
|
||||
AC_SUBST(DB2HTML)
|
||||
-
|
||||
|
||||
-dnl If we use rpm, we need to check where %_topdir is
|
||||
-AC_CHECK_PROGS(RPMBIN,rpm,false)
|
||||
-if test $RPMBIN != false; then
|
||||
@ -100,13 +89,15 @@ $OpenBSD: patch-configure_in,v 1.2 2003/04/01 20:52:59 sturm Exp $
|
||||
-dnl Check for man2html for docs.
|
||||
-AC_CHECK_PROGS(MAN2HTML,man2html,false)
|
||||
-AC_SUBST(MAN2HTML)
|
||||
|
||||
-
|
||||
dnl Set doc status flag for conditional content inclusions
|
||||
DOC_STATUS=p-not-stable
|
||||
$OpenBSD: patch-errlog_c,v 1.2 2003/04/01 20:52:59 sturm Exp $
|
||||
--- errlog.c.orig Thu Mar 6 22:41:04 2003
|
||||
+++ errlog.c Sat Mar 29 18:17:02 2003
|
||||
@@ -564,7 +564,7 @@ void log_error(int loglevel, char *fmt,
|
||||
if test $CODE_STATUS = stable; then
|
||||
Only in .: configure.in~
|
||||
diff -rup ../privoxy-3.0.6-stable.orig/errlog.c ./errlog.c
|
||||
--- ../privoxy-3.0.6-stable.orig/errlog.c 2006-11-21 15:28:41.197673690 +0100
|
||||
+++ ./errlog.c 2006-11-21 15:29:06.057894362 +0100
|
||||
@@ -633,7 +633,7 @@ void log_error(int loglevel, char *fmt,
|
||||
case 'd':
|
||||
ival = va_arg( ap, int );
|
||||
oldoutc = outc;
|
||||
@ -115,7 +106,7 @@ $OpenBSD: patch-errlog_c,v 1.2 2003/04/01 20:52:59 sturm Exp $
|
||||
if (outc < BUFFER_SIZE-1)
|
||||
{
|
||||
strcpy(outbuf + oldoutc, tempbuf);
|
||||
@@ -577,7 +577,7 @@ void log_error(int loglevel, char *fmt,
|
||||
@@ -646,7 +646,7 @@ void log_error(int loglevel, char *fmt,
|
||||
case 'u':
|
||||
uval = va_arg( ap, unsigned );
|
||||
oldoutc = outc;
|
||||
@ -124,7 +115,7 @@ $OpenBSD: patch-errlog_c,v 1.2 2003/04/01 20:52:59 sturm Exp $
|
||||
if (outc < BUFFER_SIZE-1)
|
||||
{
|
||||
strcpy(outbuf + oldoutc, tempbuf);
|
||||
@@ -594,13 +594,13 @@ void log_error(int loglevel, char *fmt,
|
||||
@@ -663,13 +663,13 @@ void log_error(int loglevel, char *fmt,
|
||||
{
|
||||
lval = va_arg( ap, long );
|
||||
oldoutc = outc;
|
||||
@ -140,7 +131,7 @@ $OpenBSD: patch-errlog_c,v 1.2 2003/04/01 20:52:59 sturm Exp $
|
||||
}
|
||||
else
|
||||
{
|
||||
@@ -700,7 +700,7 @@ void log_error(int loglevel, char *fmt,
|
||||
@@ -767,7 +767,7 @@ void log_error(int loglevel, char *fmt,
|
||||
#endif /* ndef HAVE_STRERROR */
|
||||
if (sval == NULL)
|
||||
{
|
||||
@ -149,7 +140,7 @@ $OpenBSD: patch-errlog_c,v 1.2 2003/04/01 20:52:59 sturm Exp $
|
||||
sval = tempbuf;
|
||||
}
|
||||
#endif /* ndef _WIN32 */
|
||||
@@ -754,7 +754,7 @@ void log_error(int loglevel, char *fmt,
|
||||
@@ -821,7 +821,7 @@ void log_error(int loglevel, char *fmt,
|
||||
hrs = ((days < -1 ? 24 : 1 < days ? -24 : days * 24) + tm_now->tm_hour - gmt.tm_hour);
|
||||
mins = hrs * 60 + tm_now->tm_min - gmt.tm_min;
|
||||
strftime (tempbuf, BUFFER_SIZE-6, "%d/%b/%Y:%H:%M:%S ", tm_now);
|
||||
@ -158,10 +149,11 @@ $OpenBSD: patch-errlog_c,v 1.2 2003/04/01 20:52:59 sturm Exp $
|
||||
}
|
||||
oldoutc = outc;
|
||||
outc += strlen(tempbuf);
|
||||
$OpenBSD: patch-filters_c,v 1.2 2003/04/01 20:52:59 sturm Exp $
|
||||
--- filters.c.orig Fri Feb 28 07:52:45 2003
|
||||
+++ filters.c Sat Mar 29 18:17:02 2003
|
||||
@@ -958,7 +958,7 @@ struct http_response *trust_url(struct c
|
||||
Only in .: errlog.c~
|
||||
diff -rup ../privoxy-3.0.6-stable.orig/filters.c ./filters.c
|
||||
--- ../privoxy-3.0.6-stable.orig/filters.c 2006-11-21 15:28:41.199673386 +0100
|
||||
+++ ./filters.c 2006-11-21 15:29:06.061893754 +0100
|
||||
@@ -1054,7 +1054,7 @@ struct http_response *trust_url(struct c
|
||||
p = strdup("");
|
||||
for (tl = csp->config->trust_list; (t = *tl) != NULL ; tl++)
|
||||
{
|
||||
@ -170,7 +162,7 @@ $OpenBSD: patch-filters_c,v 1.2 2003/04/01 20:52:59 sturm Exp $
|
||||
string_append(&p, buf);
|
||||
}
|
||||
err = map(exports, "trusted-referrers", 1, p, 0);
|
||||
@@ -980,7 +980,7 @@ struct http_response *trust_url(struct c
|
||||
@@ -1076,7 +1076,7 @@ struct http_response *trust_url(struct c
|
||||
p = strdup("");
|
||||
for (l = csp->config->trust_info->first; l ; l = l->next)
|
||||
{
|
||||
@ -179,10 +171,23 @@ $OpenBSD: patch-filters_c,v 1.2 2003/04/01 20:52:59 sturm Exp $
|
||||
string_append(&p, buf);
|
||||
}
|
||||
err = map(exports, "trust-info", 1, p, 0);
|
||||
$OpenBSD: patch-jcc_c,v 1.2 2003/04/01 20:52:59 sturm Exp $
|
||||
--- jcc.c.orig Mon Mar 17 11:48:59 2003
|
||||
+++ jcc.c Sat Mar 29 19:10:14 2003
|
||||
@@ -1417,7 +1417,7 @@ static void chat(struct client_state *cs
|
||||
Only in .: filters.c~
|
||||
diff -rup ../privoxy-3.0.6-stable.orig/GNUmakefile.in ./GNUmakefile.in
|
||||
--- ../privoxy-3.0.6-stable.orig/GNUmakefile.in 2006-11-21 15:28:41.164678706 +0100
|
||||
+++ ./GNUmakefile.in 2006-11-21 15:29:06.044896338 +0100
|
||||
@@ -226,7 +226,7 @@ PTHREAD_LIB = @PTHREAD_ONLY@@PTHREAD_LI
|
||||
SRCS = $(C_SRC) $(W32_SRC) $(PCRS_SRC) $(PCRE_SRC) $(REGEX_SRC)
|
||||
OBJS = $(C_OBJS) $(W32_OBJS) $(PCRS_OBJS) $(PCRE_OBJS) $(REGEX_OBJS)
|
||||
HDRS = $(C_HDRS) $(W32_HDRS) $(PCRS_HDRS) $(PCRE_OBJS) $(REGEX_HDRS)
|
||||
-LIBS = @LIBS@ $(W32_LIB) $(SOCKET_LIB) $(PTHREAD_LIB)
|
||||
+LIBS = @LDFLAGS@ @LIBS@ $(W32_LIB) $(SOCKET_LIB) $(PTHREAD_LIB)
|
||||
|
||||
|
||||
#############################################################################
|
||||
diff -rup ../privoxy-3.0.6-stable.orig/jcc.c ./jcc.c
|
||||
--- ../privoxy-3.0.6-stable.orig/jcc.c 2006-11-21 15:28:41.203672778 +0100
|
||||
+++ ./jcc.c 2006-11-21 15:29:06.063893450 +0100
|
||||
@@ -1575,7 +1575,7 @@ static void chat(struct client_state *cs
|
||||
* This is NOT the body, so
|
||||
* Let's pretend the server just sent us a blank line.
|
||||
*/
|
||||
@ -191,7 +196,7 @@ $OpenBSD: patch-jcc_c,v 1.2 2003/04/01 20:52:59 sturm Exp $
|
||||
|
||||
/*
|
||||
* Now, let the normal header parsing algorithm below do its
|
||||
@@ -2438,7 +2438,7 @@ static void listen_loop(void)
|
||||
@@ -2711,7 +2711,7 @@ static void listen_loop(void)
|
||||
|
||||
log_error(LOG_LEVEL_ERROR, "can't fork: %E");
|
||||
|
||||
@ -200,10 +205,11 @@ $OpenBSD: patch-jcc_c,v 1.2 2003/04/01 20:52:59 sturm Exp $
|
||||
|
||||
write_socket(csp->cfd, buf, strlen(buf));
|
||||
close_socket(csp->cfd);
|
||||
$OpenBSD: patch-miscutil_c,v 1.2 2003/04/01 20:52:59 sturm Exp $
|
||||
--- miscutil.c.orig Tue Nov 12 09:28:18 2002
|
||||
+++ miscutil.c Sat Mar 29 18:17:03 2003
|
||||
@@ -382,7 +382,7 @@ char *safe_strerror(int err)
|
||||
Only in .: jcc.c~
|
||||
diff -rup ../privoxy-3.0.6-stable.orig/miscutil.c ./miscutil.c
|
||||
--- ../privoxy-3.0.6-stable.orig/miscutil.c 2006-11-21 15:28:41.205672474 +0100
|
||||
+++ ./miscutil.c 2006-11-21 15:29:06.065893146 +0100
|
||||
@@ -426,7 +426,7 @@ char *safe_strerror(int err)
|
||||
|
||||
if (s == NULL)
|
||||
{
|
||||
@ -212,10 +218,12 @@ $OpenBSD: patch-miscutil_c,v 1.2 2003/04/01 20:52:59 sturm Exp $
|
||||
s = buf;
|
||||
}
|
||||
|
||||
$OpenBSD: patch-urlmatch_c,v 1.2 2003/04/01 20:52:59 sturm Exp $
|
||||
--- urlmatch.c.orig Fri Feb 28 08:09:29 2003
|
||||
+++ urlmatch.c Sat Mar 29 18:17:03 2003
|
||||
@@ -686,7 +686,7 @@ jb_err create_url_spec(struct url_spec *
|
||||
Only in .: miscutil.c~
|
||||
Only in .: privoxy.patch
|
||||
diff -rup ../privoxy-3.0.6-stable.orig/urlmatch.c ./urlmatch.c
|
||||
--- ../privoxy-3.0.6-stable.orig/urlmatch.c 2006-11-21 15:28:41.802581730 +0100
|
||||
+++ ./urlmatch.c 2006-11-21 15:29:06.067892842 +0100
|
||||
@@ -713,7 +713,7 @@ jb_err create_url_spec(struct url_spec *
|
||||
return JB_ERR_MEMORY;
|
||||
}
|
||||
|
||||
@ -224,3 +232,4 @@ $OpenBSD: patch-urlmatch_c,v 1.2 2003/04/01 20:52:59 sturm Exp $
|
||||
|
||||
errcode = regcomp(url->preg, rebuf,
|
||||
(REG_EXTENDED|REG_NOSUB|REG_ICASE));
|
||||
Only in .: urlmatch.c~
|
||||
|
Loading…
x
Reference in New Issue
Block a user