ebtables: initial import

This commit is contained in:
Mikhail Kolesnik 2006-11-14 14:43:47 +02:00
parent bf034823af
commit 406f5aee0e
5 changed files with 100 additions and 0 deletions

31
ebtables/.footprint Normal file
View File

@ -0,0 +1,31 @@
drwxr-xr-x root/root etc/
-rw-r--r-- root/root etc/ethertypes
drwxr-xr-x root/root usr/
drwxr-xr-x root/root usr/lib/
-rwxr-xr-x root/root usr/lib/libebt_802_3.so
-rwxr-xr-x root/root usr/lib/libebt_among.so
-rwxr-xr-x root/root usr/lib/libebt_arp.so
-rwxr-xr-x root/root usr/lib/libebt_arpreply.so
-rwxr-xr-x root/root usr/lib/libebt_ip.so
-rwxr-xr-x root/root usr/lib/libebt_limit.so
-rwxr-xr-x root/root usr/lib/libebt_log.so
-rwxr-xr-x root/root usr/lib/libebt_mark.so
-rwxr-xr-x root/root usr/lib/libebt_mark_m.so
-rwxr-xr-x root/root usr/lib/libebt_nat.so
-rwxr-xr-x root/root usr/lib/libebt_pkttype.so
-rwxr-xr-x root/root usr/lib/libebt_redirect.so
-rwxr-xr-x root/root usr/lib/libebt_standard.so
-rwxr-xr-x root/root usr/lib/libebt_stp.so
-rwxr-xr-x root/root usr/lib/libebt_ulog.so
-rwxr-xr-x root/root usr/lib/libebt_vlan.so
-rwxr-xr-x root/root usr/lib/libebtable_broute.so
-rwxr-xr-x root/root usr/lib/libebtable_filter.so
-rwxr-xr-x root/root usr/lib/libebtable_nat.so
-rwxr-xr-x root/root usr/lib/libebtc.so
drwxr-xr-x root/root usr/man/
drwxr-xr-x root/root usr/man/man8/
-rw-r--r-- root/root usr/man/man8/ebtables.8.gz
drwxr-xr-x root/root usr/sbin/
-rwxr-xr-x root/root usr/sbin/ebtables
-rwxr-xr-x root/root usr/sbin/ebtables-restore
-rwxr-xr-x root/root usr/sbin/ebtables-save

2
ebtables/.md5sum Normal file
View File

@ -0,0 +1,2 @@
5a0c146b8f3fb917a0bd55be9532e6f0 ebtables-v2.0.8-rc2.diff
f07111fcc1966be669278433c35dcc28 ebtables-v2.0.8-rc2.tar.gz

18
ebtables/Pkgfile Normal file
View File

@ -0,0 +1,18 @@
# Description: A firewalling tool to transparently filter network traffic passing a bridge
# URL: http://ebtables.sourceforge.net/
# Maintainer: Mikhail Kolesnik, mike at openbunker dot org
# Depends on:
name=ebtables
version=2.0.8-rc2
release=1
source=(http://dl.sourceforge.net/sourceforge/$name/$name-v$version.tar.gz \
ebtables-v$version.diff)
build() {
cd $name-v$version
patch -p1 -i ../ebtables-v$version.diff
make
make DESTDIR=$PKG install
rm -rf $PKG/etc/{rc.d,sysconfig}
}

11
ebtables/README Normal file
View File

@ -0,0 +1,11 @@
README for ebtables
REQUIREMENTS
PRE-INSTALL
POST-INSTALL
RESOURCES
Some info on the kernel configuration is available at:
http://ebtables.sourceforge.net/download.html

View File

@ -0,0 +1,38 @@
diff -Nru ebtables-v2.0.8-rc2-orig/Makefile ebtables-v2.0.8-rc2/Makefile
--- ebtables-v2.0.8-rc2-orig/Makefile 2006-03-30 20:24:57.000000000 +0300
+++ ebtables-v2.0.8-rc2/Makefile 2006-10-10 22:59:50.000000000 +0300
@@ -6,15 +6,15 @@
# default paths
LIBDIR:=/usr/lib
-MANDIR:=/usr/local/man
-BINDIR:=/usr/local/sbin
+MANDIR:=/usr/man
+BINDIR:=/usr/sbin
ETCDIR:=/etc
-INITDIR:=/etc/rc.d/init.d
+INITDIR:=/etc/rc.d
SYSCONFIGDIR:=/etc/sysconfig
DESTDIR:=
# include DESTDIR param
-override LIBDIR:=$(DESTDIR)$(LIBDIR)/$(PROGNAME)
+override LIBDIR:=$(DESTDIR)$(LIBDIR)
override MANDIR:=$(DESTDIR)$(MANDIR)
override BINDIR:=$(DESTDIR)$(BINDIR)
override ETCDIR:=$(DESTDIR)$(ETCDIR)
@@ -160,11 +160,11 @@
.PHONY: scripts
scripts: ebtables-save ebtables.sysv ebtables-config
cat ebtables-save | sed 's/__EXEC_PATH__/$(tmp1)/g' > ebtables-save_
- install -m 0755 -o root -g root ebtables-save_ $(BINDIR)/ebtables-save
+ install -D -m 0755 -o root -g root ebtables-save_ $(BINDIR)/ebtables-save
cat ebtables.sysv | sed 's/__EXEC_PATH__/$(tmp1)/g' | sed 's/__SYSCONFIG__/$(tmp2)/g' > ebtables.sysv_
- install -m 0755 -o root -g root ebtables.sysv_ $(INITDIR)/ebtables
+ install -D -m 0755 -o root -g root ebtables.sysv_ $(INITDIR)/ebtables
cat ebtables-config | sed 's/__SYSCONFIG__/$(tmp2)/g' > ebtables-config_
- install -m 0600 -o root -g root ebtables-config_ $(SYSCONFIGDIR)/ebtables-config
+ install -D -m 0600 -o root -g root ebtables-config_ $(SYSCONFIGDIR)/ebtables-config
rm -f ebtables-save_ ebtables.sysv_ ebtables-config_
$(MANDIR)/man8/ebtables.8: ebtables.8