torsocks: deleted unmaintained port

This commit is contained in:
Tim Biermann 2021-02-15 09:50:42 +00:00
parent 49d34b0f48
commit 407c76748e
7 changed files with 0 additions and 227 deletions

View File

@ -1,21 +0,0 @@
drwxr-xr-x root/root etc/
drwxr-xr-x root/root etc/tor/
-rw-r--r-- root/root etc/tor/torsocks.conf
drwxr-xr-x root/root usr/
drwxr-xr-x root/root usr/bin/
-rwxr-xr-x root/root usr/bin/torsocks
drwxr-xr-x root/root usr/lib/
drwxr-xr-x root/root usr/lib/torsocks/
-rw-r--r-- root/root usr/lib/torsocks/libtorsocks.a
-rwxr-xr-x root/root usr/lib/torsocks/libtorsocks.la
lrwxrwxrwx root/root usr/lib/torsocks/libtorsocks.so -> libtorsocks.so.0.0.0
lrwxrwxrwx root/root usr/lib/torsocks/libtorsocks.so.0 -> libtorsocks.so.0.0.0
-rwxr-xr-x root/root usr/lib/torsocks/libtorsocks.so.0.0.0
drwxr-xr-x root/root usr/share/
drwxr-xr-x root/root usr/share/man/
drwxr-xr-x root/root usr/share/man/man1/
-rw-r--r-- root/root usr/share/man/man1/torsocks.1.gz
drwxr-xr-x root/root usr/share/man/man5/
-rw-r--r-- root/root usr/share/man/man5/torsocks.conf.5.gz
drwxr-xr-x root/root usr/share/man/man8/
-rw-r--r-- root/root usr/share/man/man8/torsocks.8.gz

View File

@ -1,8 +0,0 @@
untrusted comment: verify with /etc/ports/contrib.pub
RWSagIOpLGJF37fqgLRVeSi+SupO8oPp+Pq0GEbZAXDUedIE+K4QM4DSCYwJr6MPNfmsr2yKXh+pCJu/qmWlO6nCeBV5YqvRRAo=
SHA256 (Pkgfile) = ccfbf322cfa3dd2268c20f02d2c3a1ff83bc75d1601c39eb46268e19bcbe3706
SHA256 (.footprint) = 84e7a17cbfbe9ce795d4f4fd350124647c3f03861002c739f2b424b3748abf36
SHA256 (torsocks-2.3.0.tar.xz) = b9f1b981d6b3fd4e1820de1eee325f8a7038c84765d5a6cd9af12571d5cc3622
SHA256 (4c00ec8773fd63fa48ef49e1ccf2adac598427be.patch) = c30c02ad83a270eaeef1a8a7ae0e21ddc97705c9c425ad1c7493eb9cd5e58f64
SHA256 (d4b0a84bdf2a1895c8ec3091dc2767fd9f8c2d66.patch) = b5626099e7bf98d4aeba6c4265d28a2bb0c8b15e77ae7dd7be83d301f293e384
SHA256 (fb7db9ecd0be04385ad5ae40e6e802cd80bb3455.patch) = 3a4f8b55cdfdcd529bf53d6d13185bf8fba16a5b109b0067773b5d4f5b3ce8e8

View File

@ -1,94 +0,0 @@
From 4c00ec8773fd63fa48ef49e1ccf2adac598427be Mon Sep 17 00:00:00 2001
From: Alejandro Alvarado <44826516+seisvelas@users.noreply.github.com>
Date: Mon, 17 Dec 2018 19:25:18 -0600
Subject: Add getdents / getdents64 support re ticket 28861
---
src/common/compat.h | 8 ++++++++
src/lib/syscall.c | 37 +++++++++++++++++++++++++++++++++++++
2 files changed, 45 insertions(+)
diff --git a/src/common/compat.h b/src/common/compat.h
index a9b73c2..d79301f 100644
--- a/src/common/compat.h
+++ b/src/common/compat.h
@@ -129,6 +129,12 @@ void tsocks_once(tsocks_once_t *o, void (*init_routine)(void));
#ifndef __NR_memfd_create
#define __NR_memfd_create -19
#endif
+#ifndef __NR_getdents
+#define __NR_getdents -20
+#endif
+#ifndef __NR_getdents64
+#define __NR_getdents64 -21
+#endif
#define TSOCKS_NR_SOCKET __NR_socket
#define TSOCKS_NR_CONNECT __NR_connect
@@ -149,6 +155,8 @@ void tsocks_once(tsocks_once_t *o, void (*init_routine)(void));
#define TSOCKS_NR_CLOCK_GETTIME __NR_clock_gettime
#define TSOCKS_NR_FORK __NR_fork
#define TSOCKS_NR_MEMFD_CREATE __NR_memfd_create
+#define TSOCKS_NR_GETDENTS __NR_getdents
+#define TSOCKS_NR_GETDENTS64 __NR_getdents64
/*
* Despite glibc providing wrappers for these calls for a long time
diff --git a/src/lib/syscall.c b/src/lib/syscall.c
index 7fba580..f793da7 100644
--- a/src/lib/syscall.c
+++ b/src/lib/syscall.c
@@ -437,6 +437,37 @@ static LIBC_SYSCALL_RET_TYPE handle_memfd_create(va_list args)
return tsocks_libc_syscall(TSOCKS_NR_MEMFD_CREATE, name, flags);
}
+/*
+ * Handle getdents(2) syscall.
+ */
+static LIBC_SYSCALL_RET_TYPE handle_getdents(va_list args)
+{
+ unsigned int fd;
+ struct linux_dirent *dirp;
+ unsigned int count;
+
+ fd = va_arg(args, __typeof__(fd));
+ dirp = va_arg(args, __typeof__(dirp));
+ count = va_arg(args, __typeof__(count));
+
+ return tsocks_libc_syscall(TSOCKS_NR_GETDENTS, fd, dirp, count);
+}
+/*
+ * Handle getdents64(2) syscall.
+ */
+static LIBC_SYSCALL_RET_TYPE handle_getdents64(va_list args)
+{
+ unsigned int fd;
+ struct linux_dirent64 *dirp;
+ unsigned int count;
+
+ fd = va_arg(args, __typeof__(fd));
+ dirp = va_arg(args, __typeof__(dirp));
+ count = va_arg(args, __typeof__(count));
+
+ return tsocks_libc_syscall(TSOCKS_NR_GETDENTS64, fd, dirp, count);
+}
+
#endif /* __linux__ */
/*
@@ -558,6 +589,12 @@ LIBC_SYSCALL_RET_TYPE tsocks_syscall(long int number, va_list args)
case TSOCKS_NR_MEMFD_CREATE:
ret = handle_memfd_create(args);
break;
+ case TSOCKS_NR_GETDENTS:
+ ret = handle_getdents(args);
+ break;
+ case TSOCKS_NR_GETDENTS64:
+ ret = handle_getdents64(args);
+ break;
#endif /* __linux__ */
default:
/*
--
cgit v1.2.1

View File

@ -1,34 +0,0 @@
# Description: Wrapper to safely torify applications
# URL: https://gitweb.torproject.org/torsocks.git
# Maintainer: UNMAINTAINED
# Optional: tor
name=torsocks
version=2.3.0
release=2
source=(https://people.torproject.org/~dgoulet/$name/$name-$version.tar.xz
4c00ec8773fd63fa48ef49e1ccf2adac598427be.patch
d4b0a84bdf2a1895c8ec3091dc2767fd9f8c2d66.patch
fb7db9ecd0be04385ad5ae40e6e802cd80bb3455.patch)
build() {
cd $name-$version
# Disable tests requiring network access
for test in dns fd_passing getpeername; do
sed -i -e "/^\ttest_${test} \\\\\$/d" tests/Makefile.am || \
{ echo 1>&2 "Failed to disable network tests!"; exit 1; }
done
patch -p1 -i $SRC/4c00ec8773fd63fa48ef49e1ccf2adac598427be.patch
patch -p1 -i $SRC/d4b0a84bdf2a1895c8ec3091dc2767fd9f8c2d66.patch
patch -p1 -i $SRC/fb7db9ecd0be04385ad5ae40e6e802cd80bb3455.patch
autoreconf -f -i
./configure --prefix=/usr --sysconfdir=/etc
make V=1
make DESTDIR=$PKG install
rm -r $PKG/usr/share/doc
}

View File

@ -1,13 +0,0 @@
README for torsocks
REQUIREMENTS
We do not depend on tor which might be running on a different box.
But if we do not have running tor instance on a different box, then
we must install it.
PRECAUTION
If you have added some specific settings to /etc/tor/torsocks.conf
and want to prevent the loss of your data upon update, make sure
you edited /etc/pkgadd.conf and added the following line:
UPGRADE ^etc/tor/torsocks.conf$ NO

View File

@ -1,32 +0,0 @@
From d4b0a84bdf2a1895c8ec3091dc2767fd9f8c2d66 Mon Sep 17 00:00:00 2001
From: Ola Bini <ola@autonomia.digital>
Date: Thu, 9 Jul 2020 18:31:41 +0000
Subject: Fixes an issue when calling recvmsg on a domain socket non-blocking
Since the original flags are not taken into account when peeking, the peek
recvmsg call will hang forever in certain circumstances, including in all QT
applications running Wayland. This fix simply adds the original flags, so that
the peeking recvmsg call might be nonblocking, if the original call was
nonblocking.
Closes #40001
---
src/lib/recv.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/lib/recv.c b/src/lib/recv.c
index d1bbaea..abdd1fa 100644
--- a/src/lib/recv.c
+++ b/src/lib/recv.c
@@ -92,7 +92,7 @@ LIBC_RECVMSG_RET_TYPE tsocks_recvmsg(LIBC_RECVMSG_SIG)
do {
/* Just peek the data to inspect the payload for fd. */
- ret = tsocks_libc_recvmsg(sockfd, &msg_hdr, MSG_PEEK);
+ ret = tsocks_libc_recvmsg(sockfd, &msg_hdr, MSG_PEEK | flags);
} while (ret < 0 && errno == EINTR);
if (ret < 0) {
/* Use the current errno set by the call above. */
--
cgit v1.2.1

View File

@ -1,25 +0,0 @@
From fb7db9ecd0be04385ad5ae40e6e802cd80bb3455 Mon Sep 17 00:00:00 2001
From: anonhelper <torcontrib@airmail.cc>
Date: Wed, 21 Oct 2020 02:07:26 +0000
Subject: Fixed out-of-bounds write in onion pool.
---
src/common/onion.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/common/onion.c b/src/common/onion.c
index 6a61d83..d99bf5c 100644
--- a/src/common/onion.c
+++ b/src/common/onion.c
@@ -62,7 +62,7 @@ static int insert_onion_entry(struct onion_entry *entry,
assert(entry);
assert(pool);
- if (pool->count > pool->size) {
+ if (pool->count >= pool->size) {
/* Double the size of the pool. */
ret = resize_onion_pool(pool, pool->size * 2);
if (ret < 0) {
--
cgit v1.2.1