pugixml: Initial import
This commit is contained in:
parent
7f0fe366e1
commit
409dbaa068
14
pugixml/.footprint
Normal file
14
pugixml/.footprint
Normal file
@ -0,0 +1,14 @@
|
||||
drwxr-xr-x root/root usr/
|
||||
drwxr-xr-x root/root usr/include/
|
||||
-rw-r--r-- root/root usr/include/pugiconfig.hpp
|
||||
-rw-r--r-- root/root usr/include/pugixml.hpp
|
||||
drwxr-xr-x root/root usr/lib/
|
||||
drwxr-xr-x root/root usr/lib/cmake/
|
||||
drwxr-xr-x root/root usr/lib/cmake/pugixml/
|
||||
-rw-r--r-- root/root usr/lib/cmake/pugixml/pugixml-config-release.cmake
|
||||
-rw-r--r-- root/root usr/lib/cmake/pugixml/pugixml-config.cmake
|
||||
lrwxrwxrwx root/root usr/lib/libpugixml.so -> libpugixml.so.1
|
||||
lrwxrwxrwx root/root usr/lib/libpugixml.so.1 -> libpugixml.so.1.9
|
||||
-rwxr-xr-x root/root usr/lib/libpugixml.so.1.9
|
||||
drwxr-xr-x root/root usr/lib/pkgconfig/
|
||||
-rw-r--r-- root/root usr/lib/pkgconfig/pugixml.pc
|
6
pugixml/.signature
Normal file
6
pugixml/.signature
Normal file
@ -0,0 +1,6 @@
|
||||
untrusted comment: verify with /etc/ports/contrib.pub
|
||||
RWSagIOpLGJF39+xTPlBFnbHOkq8/JZtBpy7oeAfVnefDf6L9jRYFL6uiqRc+JeIsgm5KR36+GUenlruqLK1dZ3FrGSx285oGQ0=
|
||||
SHA256 (Pkgfile) = 87e3916b3e96dfb4ebe70a92404762ff82dbfbdf36764a8ca92a5bb154eacfed
|
||||
SHA256 (.footprint) = 15f038ae5d904f127c03982131e484eaae4e043f8d522bf88193541997497f89
|
||||
SHA256 (pugixml-1.9.tar.gz) = d156d35b83f680e40fd6412c4455fdd03544339779134617b9b28d19e11fdba6
|
||||
SHA256 (pkg-config.patch) = a0e47aed9f28c061b889d05b34d30c29cb06eeb262f5c306ef3f80c81412ee43
|
26
pugixml/Pkgfile
Normal file
26
pugixml/Pkgfile
Normal file
@ -0,0 +1,26 @@
|
||||
# Description: Light-weight, simple and fast XML parser for C++ with XPath support
|
||||
# URL: http://pugixml.org
|
||||
# Maintainer: Pedja, predivan at mts dot rs
|
||||
# Depends on: cmake
|
||||
|
||||
name=pugixml
|
||||
version=1.9
|
||||
release=2
|
||||
source=(http://github.com/zeux/pugixml/releases/download/v$version/$name-$version.tar.gz
|
||||
pkg-config.patch)
|
||||
|
||||
build() {
|
||||
cd $name-$version
|
||||
patch -p1 -i $SRC/pkg-config.patch
|
||||
|
||||
mkdir -p build && cd build
|
||||
cmake \
|
||||
-DCMAKE_BUILD_TYPE=Release \
|
||||
-DCMAKE_INSTALL_PREFIX=/usr \
|
||||
-DCMAKE_INSTALL_LIBDIR=lib \
|
||||
-DBUILD_SHARED_LIBS=ON ../
|
||||
make
|
||||
make DESTDIR=$PKG install
|
||||
# weird
|
||||
# touch $PKG/usr/include/*.hpp -r $PKG/usr/lib/cmake/pugixml/pugixml-config.cmake
|
||||
}
|
71
pugixml/pkg-config.patch
Normal file
71
pugixml/pkg-config.patch
Normal file
@ -0,0 +1,71 @@
|
||||
From 314dc6a95baaca90294a8ea957d9810e3bee0f62 Mon Sep 17 00:00:00 2001
|
||||
From: Eli Schwartz <eschwartz93@gmail.com>
|
||||
Date: Mon, 9 Apr 2018 01:46:30 -0400
|
||||
Subject: [PATCH] cmake: always install the pkg-config file
|
||||
|
||||
There's really never a reason to *not* want this installed. If an option
|
||||
is needed to specify installing in a versioned subdirectory, this option
|
||||
should be explicitly described rather than hidden in something else.
|
||||
|
||||
As an added bonus, this makes the CMake install code slightly *less*
|
||||
complicated.
|
||||
---
|
||||
CMakeLists.txt | 10 ++++------
|
||||
scripts/pugixml.pc.in | 6 +++---
|
||||
2 files changed, 7 insertions(+), 9 deletions(-)
|
||||
|
||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index 90fa6793..d7bc1b20 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -4,7 +4,7 @@ project(pugixml)
|
||||
|
||||
option(BUILD_SHARED_LIBS "Build shared instead of static library" OFF)
|
||||
option(BUILD_TESTS "Build tests" OFF)
|
||||
-option(BUILD_PKGCONFIG "Build in PKGCONFIG mode" OFF)
|
||||
+option(USE_VERSIONED_LIBDIR "Use a private subdirectory to install the headers and libs" OFF)
|
||||
|
||||
set(BUILD_DEFINES "" CACHE STRING "Build defines")
|
||||
|
||||
@@ -55,7 +55,7 @@ endif()
|
||||
set_target_properties(pugixml PROPERTIES VERSION 1.9 SOVERSION 1)
|
||||
get_target_property(PUGIXML_VERSION_STRING pugixml VERSION)
|
||||
|
||||
-if(BUILD_PKGCONFIG)
|
||||
+if(USE_VERSIONED_LIBDIR)
|
||||
# Install library into its own directory under LIBDIR
|
||||
set(INSTALL_SUFFIX /pugixml-${PUGIXML_VERSION_STRING})
|
||||
endif()
|
||||
@@ -71,10 +71,8 @@ install(TARGETS pugixml EXPORT pugixml-config
|
||||
install(FILES ${HEADERS} DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}${INSTALL_SUFFIX})
|
||||
install(EXPORT pugixml-config DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/pugixml)
|
||||
|
||||
-if(BUILD_PKGCONFIG)
|
||||
- configure_file(scripts/pugixml.pc.in ${PROJECT_BINARY_DIR}/pugixml.pc @ONLY)
|
||||
- install(FILES ${PROJECT_BINARY_DIR}/pugixml.pc DESTINATION ${CMAKE_INSTALL_PREFIX}/lib/pkgconfig)
|
||||
-endif()
|
||||
+configure_file(scripts/pugixml.pc.in ${PROJECT_BINARY_DIR}/pugixml.pc @ONLY)
|
||||
+install(FILES ${PROJECT_BINARY_DIR}/pugixml.pc DESTINATION ${CMAKE_INSTALL_PREFIX}/lib/pkgconfig)
|
||||
|
||||
if(BUILD_TESTS)
|
||||
file(GLOB TEST_SOURCES tests/*.cpp)
|
||||
diff --git a/scripts/pugixml.pc.in b/scripts/pugixml.pc.in
|
||||
index 3c97c28d..804c4d38 100644
|
||||
--- a/scripts/pugixml.pc.in
|
||||
+++ b/scripts/pugixml.pc.in
|
||||
@@ -1,11 +1,11 @@
|
||||
prefix=@CMAKE_INSTALL_PREFIX@
|
||||
exec_prefix=${prefix}
|
||||
-includedir=${prefix}/include/pugixml-@PUGIXML_VERSION_STRING@
|
||||
-libdir=${exec_prefix}/lib/pugixml-@PUGIXML_VERSION_STRING@
|
||||
+includedir=${prefix}/include@INSTALL_SUFFIX@
|
||||
+libdir=${exec_prefix}/lib@INSTALL_SUFFIX@
|
||||
|
||||
Name: pugixml
|
||||
Description: Light-weight, simple and fast XML parser for C++ with XPath support.
|
||||
URL: http://pugixml.org/
|
||||
Version: @PUGIXML_VERSION_STRING@
|
||||
Cflags: -I${includedir}
|
||||
-Libs: -L${libdir} -lpugixml
|
||||
\ No newline at end of file
|
||||
+Libs: -L${libdir} -lpugixml
|
Loading…
x
Reference in New Issue
Block a user