openmpi: 5.0.2 -> 5.0.3

This commit is contained in:
Tim Biermann 2024-04-26 23:55:19 +02:00
parent 22a415d6e2
commit 45d3e40a9e
Signed by: tb
GPG Key ID: 42F8B4E30B673606
4 changed files with 81 additions and 2587 deletions

File diff suppressed because it is too large Load Diff

View File

@ -1,5 +1,6 @@
untrusted comment: verify with /etc/ports/contrib.pub
RWSagIOpLGJF37gj9jRAN1xuB3btg/KDBXLBDrqyfFezpvfIlEN1wWAxFMarJELsI6qyM2LwnU8cMYNkwqu1OLLF2xYT2yXSZgs=
SHA256 (Pkgfile) = 6fc0747635806c6aa3cf1e4a0b381ac32e6089aa92ff596768029a6eecd1129f
SHA256 (.footprint) = 31a995055b33be6df70927902bd71117e0bb6afbb80072665868c2d92f72efc0
SHA256 (openmpi-5.0.2.tar.bz2) = ee46ad8eeee2c3ff70772160bff877cbf38c330a0bc3b3ddc811648b3396698f
RWSagIOpLGJF35/qVczrTj1npHIc2JGIvU9fmAgbnF0Kt3NRhCFQ2LRMWQAzrO14OlNbrq9mLD6qkK30Rlr0d2lEyiGvLEs+BQY=
SHA256 (Pkgfile) = 9b98716b99ccb99414153391012612992edbbf91c20f300b96f3a327892c1baa
SHA256 (.footprint) = db0f3ab6504136490469c2d6cc944abdf431cff00a6bdbb51d9b9b4dd8fe5526
SHA256 (openmpi-5.0.3.tar.bz2) = 990582f206b3ab32e938aa31bbf07c639368e4405dca196fabe7f0f76eeda90b
SHA256 (fortran-flags.patch) = 3ee8f2aaa0e61ec95a6665459eb824ff7c67a3937dbe67dad07cdeed62a7681b

View File

@ -5,13 +5,17 @@
# Optional: cuda
name=openmpi
version=5.0.2
version=5.0.3
release=1
source=(https://www.open-mpi.org/software/ompi/v${version%.*}/downloads/$name-$version.tar.bz2)
source=(https://www.open-mpi.org/software/ompi/v${version%.*}/downloads/$name-$version.tar.bz2
fortran-flags.patch)
build() {
cd $name-$version
patch -Np1 -i $SRC/fortran-flags.patch
./autogen.pl --force
./configure \
--prefix=/usr \
--sysconfdir=/etc/$name \
@ -24,6 +28,7 @@ build() {
--enable-mpi1-compatibility \
--with-sge \
--without-slurm \
--with-libevent=external \
FC=/usr/bin/gfortran \
LDFLAGS="${LDFLAGS} -Wl,-z,noexecstack"
@ -37,4 +42,6 @@ build() {
install -dm 755 $PKG/etc/ld.so.conf.d
echo /usr/lib/$name > $PKG/etc/ld.so.conf.d/$name.conf
rm -r $PKG/usr/share/doc
}

View File

@ -0,0 +1,61 @@
Workaound for missing -I/usr/include in the OpenMPI FORTRAN wrapper, which
breaks includes of OpenMPI FORTRAN definitions.
Upstream issue: https://github.com/open-mpi/ompi/issues/12257
Void issue: https://github.com/void-linux/void-packages/issues/49322
Arch inspiration: https://gitlab.archlinux.org/archlinux/packaging/packages/openmpi/-/blob/main/PKGBUILD
--- a/opal/tools/wrappers/opal_wrapper.c
+++ b/opal/tools/wrappers/opal_wrapper.c
@@ -59,8 +59,7 @@
#define OPAL_INCLUDE_FLAG "-I"
#define OPAL_LIBDIR_FLAG "-L"
-static const char * filtered_args[] = { "-I/usr/include",
- "-L/usr/lib",
+static const char * filtered_args[] = { "-L/usr/lib",
"-L/usr/lib64",
NULL };
--- a/configure
+++ b/configure
@@ -212365,8 +212365,8 @@
fi
- { printf "%s\n" "$as_me:${as_lineno-$LINENO}: result: $OMPI_WRAPPER_EXTRA_FCFLAGS" >&5
-printf "%s\n" "$OMPI_WRAPPER_EXTRA_FCFLAGS" >&6; }
+ { printf "%s\n" "$as_me:${as_lineno-$LINENO}: result: $OMPI_WRAPPER_FCFLAGS" >&5
+printf "%s\n" "$OMPI_WRAPPER_FCFLAGS" >&6; }
{ printf "%s\n" "$as_me:${as_lineno-$LINENO}: checking for OMPI wrapper FCFLAGS_PREFIX" >&5
printf %s "checking for OMPI wrapper FCFLAGS_PREFIX... " >&6; }
@@ -213138,7 +213138,7 @@
printf "%s\n" "#define OMPI_WRAPPER_CXXFLAGS \"$OMPI_WRAPPER_CXXFLAGS\"" >>confdefs.h
-printf "%s\n" "#define OMPI_WRAPPER_FCFLAGS \"$OMPI_WRAPPER__FCFLAGS\"" >>confdefs.h
+printf "%s\n" "#define OMPI_WRAPPER_FCFLAGS \"$OMPI_WRAPPER_FCFLAGS\"" >>confdefs.h
printf "%s\n" "#define OMPI_WRAPPER_LDFLAGS \"$OMPI_WRAPPER_LDFLAGS\"" >>confdefs.h
@@ -213310,8 +213310,8 @@
fi
- { printf "%s\n" "$as_me:${as_lineno-$LINENO}: result: $OSHMEM_WRAPPER_EXTRA_FCFLAGS" >&5
-printf "%s\n" "$OSHMEM_WRAPPER_EXTRA_FCFLAGS" >&6; }
+ { printf "%s\n" "$as_me:${as_lineno-$LINENO}: result: $OSHMEM_WRAPPER_FCFLAGS" >&5
+printf "%s\n" "$OSHMEM_WRAPPER_FCFLAGS" >&6; }
{ printf "%s\n" "$as_me:${as_lineno-$LINENO}: checking for OSHMEM wrapper FCFLAGS_PREFIX" >&5
printf %s "checking for OSHMEM wrapper FCFLAGS_PREFIX... " >&6; }
@@ -214098,7 +214098,7 @@
printf "%s\n" "#define OSHMEM_WRAPPER_CXXFLAGS \"$OSHMEM_WRAPPER_CXXFLAGS\"" >>confdefs.h
-printf "%s\n" "#define OSHMEM_WRAPPER_FCFLAGS \"$OSHMEM_WRAPPER__FCFLAGS\"" >>confdefs.h
+printf "%s\n" "#define OSHMEM_WRAPPER_FCFLAGS \"$OSHMEM_WRAPPER_FCFLAGS\"" >>confdefs.h
printf "%s\n" "#define OSHMEM_WRAPPER_LDFLAGS \"$OSHMEM_WRAPPER_LDFLAGS\"" >>confdefs.h