firefox: fix build for rust 1.50.0

This commit is contained in:
Danny Rawlins 2021-02-15 19:42:41 +11:00
parent 126d76d50a
commit 4ddc8c42f1
3 changed files with 49 additions and 4 deletions

View File

@ -1,7 +1,8 @@
untrusted comment: verify with /etc/ports/contrib.pub
RWSagIOpLGJF3x+Bni5sZSR+9A3VmggXKBrvc/sDD40gZ/oqDqTV3z0gQ0v24Vley7DyyP52Cc8hNFL8V3LQsv8sZ/cVlI3KWgg=
SHA256 (Pkgfile) = c71836461b559a54ff60fb18f3a61c9bf0cba90a2371d0a074093563e961847b
RWSagIOpLGJF31Dy2zaw5zFIWm/CjylT/7b7ZECRvfK4QNLQBGx18W/ImxgF7K6DMA4u/SLAf+dhqiixk3RXgSIaMQqdtzqMgww=
SHA256 (Pkgfile) = e637f5162cf6a26f11dcc10237ce9009389502dc44400af47fb48a0cdd50e2c5
SHA256 (.footprint) = 8b8bebe1e51e7e8d82a57e60b95e4fd85c806ecbcbb15ad1774730025ba0e931
SHA256 (firefox-85.0.2.source.tar.xz) = b157cdc265daa6140ec8daef2bc98d335f871e7e9ac235287fb199e11c164287
SHA256 (firefox.desktop) = 8ba3439f3dfc5cab883641969c93d8d15f8f20d7188d9568346b2edad52d6f91
SHA256 (0001-Use-remoting-name-for-GDK-application-names.patch) = 8b236bbf3ae5cb28d1dd742f543c0079fac06af5aa80bc2051defeba95f0ae21
SHA256 (fix-rust-1.50-build.patch) = d3c6e7277eabdbe03db1fbd9768c008e3da628878fb52f31e2812ebfe78e8d58

View File

@ -6,16 +6,22 @@
name=firefox
version=85.0.2
release=1
release=2
source=(https://archive.mozilla.org/pub/firefox/releases/$version/source/$name-$version.source.tar.xz
firefox.desktop
0001-Use-remoting-name-for-GDK-application-names.patch)
0001-Use-remoting-name-for-GDK-application-names.patch
fix-rust-1.50-build.patch)
build() {
cd firefox-$version
# https://bugzilla.mozilla.org/show_bug.cgi?id=1530052
patch -p1 -i $SRC/0001-Use-remoting-name-for-GDK-application-names.patch
# https://bugzilla.mozilla.org/show_bug.cgi?id=1684261
# https://hg.mozilla.org/mozilla-central/rev/48f46a7eada9
patch -p1 -i $SRC/fix-rust-1.50-build.patch
if [ $(/usr/bin/python -c "import sys; print sys.stdout.encoding") = 'UTF-8' ]; then
printf "\e[031mError: set an UTF-8 locale to compile this!\033[0m\n"
exit 1

View File

@ -0,0 +1,38 @@
diff -pruN firefox-85.0.2.orig/.cargo/config.in firefox-85.0.2/.cargo/config.in
--- firefox-85.0.2.orig/.cargo/config.in 2021-02-15 19:15:28.519967793 +1100
+++ firefox-85.0.2/.cargo/config.in 2021-02-15 19:16:49.418429299 +1100
@@ -3,7 +3,7 @@
# Please do not edit.
[source."https://github.com/shravanrn/nix/"]
-branch = "r0.13.1"
+rev = "4af6c367603869a30fddb5ffb0aba2b9477ba92e"
git = "https://github.com/shravanrn/nix/"
replace-with = "vendored-sources"
diff -pruN firefox-85.0.2.orig/Cargo.lock firefox-85.0.2/Cargo.lock
--- firefox-85.0.2.orig/Cargo.lock 2021-02-15 19:15:28.527968036 +1100
+++ firefox-85.0.2/Cargo.lock 2021-02-15 19:21:02.839140162 +1100
@@ -3409,7 +3409,7 @@ dependencies = [
[[package]]
name = "nix"
version = "0.13.1"
-source = "git+https://github.com/shravanrn/nix/?branch=r0.13.1#4af6c367603869a30fddb5ffb0aba2b9477ba92e"
+source = "git+https://github.com/shravanrn/nix/?rev=4af6c367603869a30fddb5ffb0aba2b9477ba92e#4af6c367603869a30fddb5ffb0aba2b9477ba92e"
dependencies = [
"bitflags",
"cc",
diff -pruN firefox-85.0.2.orig/Cargo.toml firefox-85.0.2/Cargo.toml
--- firefox-85.0.2.orig/Cargo.toml 2021-02-15 19:15:26.631910345 +1100
+++ firefox-85.0.2/Cargo.toml 2021-02-15 19:24:17.448061552 +1100
@@ -76,8 +76,8 @@ chardetng = { git = "https://github.com/
libudev-sys = { path = "dom/webauthn/libudev-sys" }
packed_simd = { git = "https://github.com/hsivonen/packed_simd", rev="0917fe780032a6bbb23d71be545f9c1834128d75" }
rlbox_lucet_sandbox = { git = "https://github.com/PLSysSec/rlbox_lucet_sandbox/", rev="f3cace4fb8b53db0849c62af4fa62bade5a620f7" }
-nix = { git = "https://github.com/shravanrn/nix/", branch = "r0.13.1", rev="4af6c367603869a30fddb5ffb0aba2b9477ba92e" }
-spirv_cross = { git = "https://github.com/kvark/spirv_cross", branch = "wgpu4", rev = "e9eff10f964957e7a001c5f712effe17ce09aa99" }
+nix = { git = "https://github.com/shravanrn/nix/", rev="4af6c367603869a30fddb5ffb0aba2b9477ba92e" }
+spirv_cross = { git = "https://github.com/kvark/spirv_cross", branch = "wgpu4" }
# failure's backtrace feature might break our builds, see bug 1608157.
failure = { git = "https://github.com/badboy/failure", rev = "64af847bc5fdcb6d2438bec8a6030812a80519a5" }
failure_derive = { git = "https://github.com/badboy/failure", rev = "64af847bc5fdcb6d2438bec8a6030812a80519a5" }