transmission-gtk: updated to version 4.0.6

This commit is contained in:
Juergen Daubert 2024-05-31 11:55:25 +02:00
parent 5bdfebba51
commit 4f833f9af6
3 changed files with 45 additions and 5 deletions

View File

@ -1,5 +1,6 @@
untrusted comment: verify with /etc/ports/contrib.pub
RWSagIOpLGJF329yvRxwXzBlclWVaAv2li1s1JkBzv+Hv67S5XBHG2bEBcTUhFtpL4buI3c2ilGkn8maFfFdyVzkLs+IBuUhQgw=
SHA256 (Pkgfile) = 5349831a6e7b30ca540ae460c6e79650ab6de5663dc25ca495456fb6d3891fe8
RWSagIOpLGJF3y3Cmoc5O4lne/jZockRy+Hd2sk6Ts1hdRzT1FGQqqnewISqJjeM+81uzibXXrbFUrJYO02iwiTU5vaurx/kyQE=
SHA256 (Pkgfile) = a340b90df11ba4a62f017bf333dbf9dd2435efe09822c5911f1fdf78b06fa6aa
SHA256 (.footprint) = ad92f5a5e6d40eaa92cdeb1dc3b71e0ca9fbae6b6598e9858543510d01c6d8f7
SHA256 (transmission-4.0.5.tar.xz) = fd68ff114a479200043c30c7e69dba4c1932f7af36ca4c5b5d2edcb5866e6357
SHA256 (transmission-4.0.6.tar.xz) = 2a38fe6d8a23991680b691c277a335f8875bdeca2b97c6b26b598bc9c7b0c45f
SHA256 (miniupnp.patch) = 6361cafbe879132ea68bd859d816fb95913443c62d0ad1db3e95ea485aef6197

View File

@ -4,11 +4,14 @@
# Depends on: curl gtkmm3 libevent
name=transmission-gtk
version=4.0.5
version=4.0.6
release=1
source=(https://github.com/transmission/transmission/releases/download/$version/transmission-$version.tar.xz)
source=(https://github.com/transmission/transmission/releases/download/$version/transmission-$version.tar.xz
miniupnp.patch)
build() {
patch -d transmission-$version -p1 -i $SRC/miniupnp.patch
cmake -S transmission-$version -B build -G Ninja \
-D CMAKE_BUILD_TYPE=Release \
-D CMAKE_INSTALL_PREFIX=/usr \

View File

@ -0,0 +1,36 @@
From a72a93764e556da6b45d086162e8bc941277ab0d Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?C=C5=93ur?= <coeur@gmx.fr>
Date: Sat, 16 Mar 2024 07:19:51 +0800
Subject: [PATCH] deps: update miniupnp to 2.3.4 (miniupnpc 2.2.6) (#6459)
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -497,7 +497,13 @@ if(NOT USE_SYSTEM_NATPMP)
NATPMP_STATICLIB)
endif()
-tr_add_external_auto_library(MINIUPNPC miniupnpc miniupnpc
+if(WIN32)
+ # https://github.com/miniupnp/miniupnp/pull/304
+ set(TR_MINIUPNPC_LIBNAME libminiupnpc)
+else()
+ set(TR_MINIUPNPC_LIBNAME miniupnpc)
+endif()
+tr_add_external_auto_library(MINIUPNPC miniupnp/miniupnpc ${TR_MINIUPNPC_LIBNAME}
TARGET miniupnpc::libminiupnpc
CMAKE_ARGS
-DUPNPC_BUILD_STATIC=ON
@@ -508,9 +514,10 @@ if(NOT USE_SYSTEM_MINIUPNPC)
INTERFACE
MINIUPNP_STATICLIB)
- set(MINIUPNPC_VERSION 1.9)
- set(MINIUPNPC_API_VERSION 12)
+ set(MINIUPNPC_VERSION 2.2)
+ set(MINIUPNPC_API_VERSION 17)
endif()
+unset(TR_MINIUPNPC_LIBNAME)
target_compile_definitions(miniupnpc::libminiupnpc
INTERFACE