memtest86+: 2.11 -> 4.20

This commit is contained in:
Danny Rawlins 2011-11-07 12:04:25 +11:00
parent e5bbb9614e
commit 50b9fbf291
3 changed files with 2 additions and 26 deletions

View File

@ -1,3 +1,2 @@
3554b58e74e11ad17f01b9b2e218cd62 memtest86+-2.11-makefile_cflags_asflags.patch
abdc336e015ba789c6e63321c0e99e81 memtest86+-2.11-makefile_install_remove.patch
e457774139c0bfef899359df91f49b3e memtest86+-2.11.tar.gz
ef62c2f5be616676c8c62066dedc46b3 memtest86+-4.20.tar.gz

View File

@ -2,18 +2,15 @@
# URL: http://www.memtest.org/
# Maintainer: Danny Rawlins, monster dot romster at gmail dot com
# Packager: Mark Rosenstand, mark at borkware dot net
# Depends on:
name=memtest86+
version=2.11
version=4.20
release=1
source=(http://www.memtest.org/download/$version/$name-$version.tar.gz
memtest86+-2.11-makefile_cflags_asflags.patch
memtest86+-2.11-makefile_install_remove.patch)
build() {
cd $name-$version
patch -p 1 -i $SRC/memtest86+-2.11-makefile_cflags_asflags.patch
patch -p 1 -i $SRC/memtest86+-2.11-makefile_install_remove.patch
make memtest.bin
make DESTDIR=$PKG install-memtest.bin

View File

@ -1,20 +0,0 @@
diff -pruN memtest86+-2.11.orig/Makefile memtest86+-2.11/Makefile
--- memtest86+-2.11.orig/Makefile 2008-12-24 10:41:30.410800131 +0000
+++ memtest86+-2.11/Makefile 2008-12-24 10:51:17.727550623 +0000
@@ -8,10 +8,13 @@
#
FDISK=/dev/fd0
-AS=as -32
-CC=gcc
+AS?=as
+CC?=gcc
-CFLAGS= -Wall -march=i486 -m32 -Os -fomit-frame-pointer -fno-builtin -ffreestanding -fPIC
+CPPFLAGS=-m32
+CFLAGS?=-0s -march=i486 -fomit-frame-pointer
+CFLAGS+= -m32 -fPIC -Wall -ffreestanding -fno-builtin
+ASFLAGS=-32
OBJS= head.o reloc.o main.o test.o init.o lib.o patn.o screen_buffer.o \
config.o linuxbios.o memsize.o pci.o controller.o random.o extra.o \