mkvtoolnix: 7.8.0 -> 8.6.1

This commit is contained in:
Danny Rawlins 2015-12-02 23:32:18 +11:00
parent 81b50381b8
commit 52dad09e15
4 changed files with 17 additions and 45 deletions

View File

@ -4,10 +4,10 @@ drwxr-xr-x root/root usr/bin/
-rwxr-xr-x root/root usr/bin/mkvinfo
-rwxr-xr-x root/root usr/bin/mkvmerge
-rwxr-xr-x root/root usr/bin/mkvpropedit
drwxr-xr-x root/root usr/man/
drwxr-xr-x root/root usr/man/man1/
-rw-r--r-- root/root usr/man/man1/mkvextract.1.gz
-rw-r--r-- root/root usr/man/man1/mkvinfo.1.gz
-rw-r--r-- root/root usr/man/man1/mkvmerge.1.gz
-rw-r--r-- root/root usr/man/man1/mkvpropedit.1.gz
-rw-r--r-- root/root usr/man/man1/mkvtoolnix-gui.1.gz
drwxr-xr-x root/root usr/share/
drwxr-xr-x root/root usr/share/man/
drwxr-xr-x root/root usr/share/man/man1/
-rw-r--r-- root/root usr/share/man/man1/mkvextract.1.gz
-rw-r--r-- root/root usr/share/man/man1/mkvinfo.1.gz
-rw-r--r-- root/root usr/share/man/man1/mkvmerge.1.gz
-rw-r--r-- root/root usr/share/man/man1/mkvpropedit.1.gz

View File

@ -1,2 +1 @@
db72bf028eeedd3029129e9c3a15a028 boost-1.58.patch
91fd8f34c25b8d3980c3e39b3cb6ae6c mkvtoolnix-7.8.0.tar.xz
acc96607003542f3dcc810b54cd1981b mkvtoolnix-8.6.1.tar.xz

View File

@ -6,39 +6,32 @@
# Nice to have: wxgtk
name=mkvtoolnix
version=7.8.0
release=2
source=(http://www.bunkus.org/videotools/mkvtoolnix/sources/$name-$version.tar.xz
boost-1.58.patch)
version=8.6.1
release=1
source=(http://www.bunkus.org/videotools/mkvtoolnix/sources/$name-$version.tar.xz)
build() {
cd $name-$version
patch -p1 -i $SRC/boost-1.58.patch
local JOBS=$(awk 'BEGIN{RS="-j|--jobs="} NR==2 {print $1}' <<< $MAKEFLAGS)
test -n "$JOBS" && export DRAKETHREADS="$JOBS"
# Disable automagic curl dep used for online update checking
sed -i -e '/curl/d' configure.in
export CURL_CFLAGS="" CURL_LIBS=""
# export CFLAGS="${CFLAGS} -DBOOST_FILESYSTEM_VERSION=3"
# export CXXFLAGS="${CXXFLAGS} -DBOOST_FILESYSTEM_VERSION=3"
export CFLAGS="${CFLAGS} -DBOOST_FILESYSTEM_VERSION=3"
export CXXFLAGS="${CXXFLAGS} -DBOOST_FILESYSTEM_VERSION=3"
autoreconf -vfi
# autoreconf -vfi
./configure \
--prefix=/usr \
--mandir=/usr/man \
--disable-precompiled-headers
--disable-precompiled-headers \
--without-curl
[ "$CXX" ] || CXX=g++
./drake CXX="$CXX"
./drake DESTDIR=$PKG install
rm -r \
$PKG/usr/man/{de,uk,ja,nl,zh_CN} \
$PKG/usr/share/man/{ca,de,es,uk,ja,nl,zh_CN} \
$PKG/usr/share/locale
# remove doc's if wxgtk is installed

View File

@ -1,20 +0,0 @@
--- ./lib/boost/utf8_codecvt_facet/utf8_codecvt_facet.cpp.orig
+++ ./lib/boost/utf8_codecvt_facet/utf8_codecvt_facet.cpp
@@ -171,14 +171,13 @@
// How many char objects can I process to get <= max_limit
// wchar_t objects?
int utf8_codecvt_facet::do_length(
- BOOST_CODECVT_DO_LENGTH_CONST std::mbstate_t &,
+ const std::mbstate_t &,
const char * from,
const char * from_end,
std::size_t max_limit
+) const
#if BOOST_WORKAROUND(__IBMCPP__, BOOST_TESTED_AT(600))
-) const throw()
-#else
-) const
+ throw()
#endif
{
// RG - this code is confusing! I need a better way to express it.