wmdiscotux: initial import

This commit is contained in:
Mikhail Kolesnik 2006-11-02 18:08:43 +02:00
parent 5a9ef9b79f
commit 57af70bd94
4 changed files with 67 additions and 0 deletions

5
wmdiscotux/.footprint Normal file
View File

@ -0,0 +1,5 @@
drwxr-xr-x root/root usr/
drwxr-xr-x root/root usr/lib/
drwxr-xr-x root/root usr/lib/xmms/
drwxr-xr-x root/root usr/lib/xmms/Visualization/
-rwxr-xr-x root/root usr/lib/xmms/Visualization/libwmdiscotux.so

2
wmdiscotux/.md5sum Normal file
View File

@ -0,0 +1,2 @@
0e3b8bd5d8974ab1892040c59ef77ca3 wmdiscotux-1.3.patch
8043c73f29f1305446594a0353ad7839 wmdiscotux-1.3.tar.gz

17
wmdiscotux/Pkgfile Normal file
View File

@ -0,0 +1,17 @@
# Description: A visualization plugin for XMMS
# URL: http://fragment.stc.cx/?page=wmdiscotux
# Maintainer: Mikhail Kolesnik, mike at openbunker dot org
# Depends on: xmms
name=wmdiscotux
version=1.3
release=1
source=(http://fragment.stc.cx/files/$name-$version.tar.gz \
$name-$version.patch)
build() {
cd $name-$version
patch -p1 -i $SRC/$name-$version.patch
make
make DESTDIR=$PKG install
}

View File

@ -0,0 +1,43 @@
diff -ru wmdiscotux-1.3-orig/Makefile wmdiscotux-1.3/Makefile
--- wmdiscotux-1.3-orig/Makefile 2000-11-15 20:33:43.000000000 +0200
+++ wmdiscotux-1.3/Makefile 2006-01-29 13:11:51.000000000 +0200
@@ -1,6 +1,6 @@
CC = gcc
-INCLUDEDIR = -I/usr/include -I/usr/X11R6/include -I/usr/local/include
-CFLAGS = -O2 -Wall $(INCLUDEDIR) -fPIC `glib-config --cflags`
+INCLUDEDIR = -I/usr/include/gtk-1.2 -I/usr/include -I/usr/X11R6/include
+CFLAGS += -Wall $(INCLUDEDIR) -fPIC `glib-config --cflags`
LFLAGS = -shared -fPIC -lpthread -L/usr/lib -ldl -lm -L/usr/X11R6/lib -lXpm -lX11
libwmdiscotux.so: wmdiscotux.o wmgeneral.o
@@ -10,5 +10,5 @@
rm -f *.o core *.so*
install: libwmdiscotux.so
- cp libwmdiscotux.so `xmms-config --visualization-plugin-dir`
+ /usr/bin/install -D -o 0 -g 0 -s -m 755 libwmdiscotux.so $(PKG)`xmms-config --visualization-plugin-dir`/libwmdiscotux.so
diff -ru wmdiscotux-1.3-orig/wmdiscotux.c wmdiscotux-1.3/wmdiscotux.c
--- wmdiscotux-1.3-orig/wmdiscotux.c 2000-11-16 16:51:52.000000000 +0200
+++ wmdiscotux-1.3/wmdiscotux.c 2006-01-29 12:56:57.000000000 +0200
@@ -359,16 +359,10 @@
gtk_container_border_width(GTK_CONTAINER(dialog), 5);
- label = gtk_label_new ("
-wmDiscoTux\n\
-v " VERSION "\n\
-
-by Antti Takala <fragment@nic.fi>\n\
-
-get the newest version from:\n\
-http://wmdiscotux.stc.cx/\n\
-
-");
+ label = gtk_label_new ("\nwmDiscoTux\n\\n\
+v " VERSION "\n\\n\nby Antti Takala <fragment@nic.fi>\n\\n\n\
+get the newest version from:\n\\n\
+http://wmdiscotux.stc.cx/\n\\n\n");
gtk_box_pack_start(GTK_BOX(GTK_DIALOG(dialog)->vbox), label, FALSE, FALSE, 0);
gtk_widget_show(label);