getmail: 4.7.6 -> 4.8.0

This commit is contained in:
James Mills 2008-03-05 21:39:51 +10:00
parent ae55e39fd0
commit 58aeb7c46d
4 changed files with 58 additions and 15 deletions

View File

@ -7,7 +7,7 @@ drwxr-xr-x root/root usr/bin/
drwxr-xr-x root/root usr/lib/
drwxr-xr-x root/root usr/lib/python2.5/
drwxr-xr-x root/root usr/lib/python2.5/site-packages/
-rw-r--r-- root/root usr/lib/python2.5/site-packages/getmail-4.7.2-py2.5.egg-info
-rw-r--r-- root/root usr/lib/python2.5/site-packages/getmail-4.8.0-py2.5.egg-info
drwxr-xr-x root/root usr/lib/python2.5/site-packages/getmailcore/
-rw-r--r-- root/root usr/lib/python2.5/site-packages/getmailcore/__init__.py
-rw-r--r-- root/root usr/lib/python2.5/site-packages/getmailcore/__init__.pyc
@ -39,4 +39,3 @@ drwxr-xr-x root/root usr/man/man1/
-rw-r--r-- root/root usr/man/man1/getmail_fetch.1.gz
-rw-r--r-- root/root usr/man/man1/getmail_maildir.1.gz
-rw-r--r-- root/root usr/man/man1/getmail_mbox.1.gz
drwxr-xr-x root/root usr/share/

View File

@ -1,2 +1,2 @@
17eda7b41ef9bf3eccccd907ecec5f3d getmail-4.7.2.tar.gz
31c54fec5587b8d6076eafe42c091a66 getmail.diff
9a9d1bcace912ac342cb98f03225fe04 getmail-4.8.0.diff
140070e58510cf42468eb965189735cd getmail-4.8.0.tar.gz

View File

@ -1,21 +1,19 @@
# Description: POP3 mail retriever with reliable Maildir and command delivery
# URL: http://pyropus.ca/software/getmail/
# Maintainer: James Mills, prologic at shortcircuit dot net dot au
# Packager: Han Boetes, han at mijncomputer dot nl
# URL: http://pyropus.ca/software/getmail/
# Maintainer: James Mills, prologic at shortcircuit dot net dot au
# Packager: Han Boetes, han at mijncomputer dot nl
#
# Depends on: python
# Depends on: python
name=getmail
version=4.7.2
release=2
version=4.8.0
release=1
source=(http://pyropus.ca/software/$name/old-versions/$name-$version.tar.gz
getmail.diff)
$name-$version.diff)
build() {
cd $name-$version
patch -i $SRC/getmail.diff
python setup.py install --root=$PKG
rm -rf $PKG/usr/share/doc
sed -i 's|#!/usr/bin/python|& -Wignore:.:DeprecationWarning:.:0|' $PKG/usr/bin/getmail
patch -p1 < $SRC/$name-$version.diff
python setup.py install --prefix=/usr --root=$PKG
chown -R root:root $PKG
}

View File

@ -0,0 +1,46 @@
diff -Nru getmail-4.8.0.orig/setup.py getmail-4.8.0/setup.py
--- getmail-4.8.0.orig/setup.py 2008-03-05 21:32:57.000000000 +1000
+++ getmail-4.8.0/setup.py 2008-03-05 21:35:24.000000000 +1000
@@ -35,16 +35,8 @@
# hack hack hack hack hack hack hack
datadir = args[pos + 1]
-GETMAILDOCDIR = os.path.join(
- datadir or prefix,
- 'share',
- 'doc',
- 'getmail-%s' % __version__
-)
-
GETMAILMANDIR = os.path.join(
datadir or prefix,
- 'share',
'man',
'man1'
)
@@ -98,25 +90,6 @@
'getmail_mbox'
],
data_files=[
- (GETMAILDOCDIR, [
- './README',
- './getmail.spec',
- 'docs/BUGS',
- 'docs/COPYING',
- 'docs/CHANGELOG',
- 'docs/TODO',
- 'docs/THANKS',
- 'docs/configuration.html',
- 'docs/configuration.txt',
- 'docs/documentation.html',
- 'docs/documentation.txt',
- 'docs/faq.html',
- 'docs/faq.txt',
- 'docs/getmaildocs.css',
- 'docs/getmailrc-examples',
- 'docs/troubleshooting.html',
- 'docs/troubleshooting.txt',
- ]),
(GETMAILMANDIR, [
'docs/getmail.1',
'docs/getmail_fetch.1',