scorched3d: 43.2a -> 43.3
This commit is contained in:
parent
012b88b988
commit
594249d64a
File diff suppressed because it is too large
Load Diff
@ -1,3 +1 @@
|
||||
876de173218fd83a2b0a30255ba694fa Scorched3D-43.2a-src.tar.gz
|
||||
ccc23027eeb13723b69432bd7bf5703a scorched3d-43.2-misc.patch
|
||||
959a024702c2cbeeef028d17b5521ecd scorched3d-43.2-openal.patch
|
||||
3e4aa690ddb2d7dfa26d283faf59f897 Scorched3D-43.3-src.tar.gz
|
||||
|
@ -5,20 +5,13 @@
|
||||
# Depends on: sdl_mixer sdl_net wxgtk freealut fftw
|
||||
|
||||
name=scorched3d
|
||||
version=43.2a
|
||||
version=43.3
|
||||
release=1
|
||||
source=(http://download.sourceforge.net/scorched3d/Scorched3D-$version-src.tar.gz
|
||||
scorched3d-43.2-openal.patch
|
||||
scorched3d-43.2-misc.patch)
|
||||
source=(http://download.sourceforge.net/scorched3d/Scorched3D-$version-src.tar.gz)
|
||||
|
||||
build() {
|
||||
cd scorched
|
||||
|
||||
touch INSTALL NEWS AUTHORS ChangeLog
|
||||
patch -p 1 -i $SRC/scorched3d-43.2-openal.patch
|
||||
patch -p 1 -i $SRC/scorched3d-43.2-misc.patch
|
||||
autoreconf
|
||||
|
||||
./configure \
|
||||
--prefix=/usr \
|
||||
--datadir=/usr/share/scorched3d \
|
||||
|
@ -1,26 +0,0 @@
|
||||
diff -pruN scorched.orig/configure.ac scorched/configure.ac
|
||||
--- scorched.orig/configure.ac 2010-11-16 12:10:55.194706554 +0000
|
||||
+++ scorched/configure.ac 2010-11-16 12:13:24.084293554 +0000
|
||||
@@ -13,22 +13,6 @@ AC_PROG_CXX
|
||||
AC_PROG_INSTALL
|
||||
AC_PROG_RANLIB
|
||||
|
||||
-LDFLAGS="-L/usr/X11R6/lib -L/usr/X11R6"
|
||||
-CPPFLAGS="-I/usr/X11R6/include -I/usr/X11R6"
|
||||
-
|
||||
-if test `uname` == Darwin; then
|
||||
-LDFLAGS="$LDFLAGS -lmx"
|
||||
-CPPFLAGS="$CPPFLAGS -DFFTW_USE_DOUBLE -D__DARWIN__ -D__MACOSX__"
|
||||
-else
|
||||
-LDFLAGS="$LDFLAGS -L/usr/local/lib"
|
||||
-CPPFLAGS="$CPPFLAGS -I/usr/local/include"
|
||||
-fi
|
||||
-
|
||||
-AC_CHECK_LIB(fridge, beer, echo "Hmm?!",[
|
||||
- echo "Warning: No beer found in fridge!";
|
||||
- echo "We highly suggest that you rectify this situation immediately."
|
||||
-])
|
||||
-
|
||||
AC_ARG_ENABLE(serveronly,
|
||||
[ --enable-serveronly Enable server only compilation],
|
||||
, enable_serveronly=no,
|
@ -1,32 +0,0 @@
|
||||
diff -pruN scorched.orig/configure-al.m4 scorched/configure-al.m4
|
||||
--- scorched.orig/configure-al.m4 2010-11-16 11:59:34.712924554 +0000
|
||||
+++ scorched/configure-al.m4 2010-11-16 12:03:22.675886054 +0000
|
||||
@@ -7,25 +7,9 @@ AC_ARG_ENABLE(openaltest,
|
||||
[ --disable-openaltest Do not try to compile and run a test OpenAL program],
|
||||
, enable_openaltest=yes)
|
||||
AC_MSG_CHECKING(for OpenAL support)
|
||||
-AC_PATH_PROG(OPENAL_CONFIG, openal-config, no)
|
||||
-if test x$OPENAL_CONFIG = xno; then
|
||||
- echo "*** The openal-config script installed by OpenAL could not be found"
|
||||
- echo "*** Make sure openal-config is in your path, or set the OPENAL_CONFIG"
|
||||
- echo "*** environment variable to the full path to openal-config."
|
||||
-
|
||||
- AC_MSG_ERROR([*** Can't find the openal library. Try: http://www.openal.org/])
|
||||
-else
|
||||
-
|
||||
- if test x"$use_static_openal" = x"yes"; then
|
||||
- AL_LIBS="/usr/local/lib/libopenal.a"
|
||||
- else
|
||||
- AL_LIBS="`$OPENAL_CONFIG --libs`"
|
||||
- fi
|
||||
-
|
||||
- AL_CFLAGS="`$OPENAL_CONFIG --cflags`"
|
||||
-
|
||||
- AC_MSG_RESULT(yes)
|
||||
-fi
|
||||
+AL_LIBS="-lopenal"
|
||||
+AL_CFLAGS="-I/usr/include/AL"
|
||||
+AC_MSG_RESULT(yes)
|
||||
|
||||
AC_MSG_CHECKING(for Freealut support)
|
||||
AC_PATH_PROG(FREEALUT_CONFIG, freealut-config, no)
|
Loading…
x
Reference in New Issue
Block a user