vdpau-video: new port

This commit is contained in:
Danny Rawlins 2010-11-14 18:29:38 +11:00
parent 009b767bfe
commit 59500df920
4 changed files with 47 additions and 0 deletions

7
vdpau-video/.footprint Normal file
View File

@ -0,0 +1,7 @@
drwxr-xr-x root/root usr/
drwxr-xr-x root/root usr/lib/
drwxr-xr-x root/root usr/lib/dri/
lrwxrwxrwx root/root usr/lib/dri/nvidia_drv_video.so -> vdpau_drv_video.so
lrwxrwxrwx root/root usr/lib/dri/s3g_drv_video.so -> vdpau_drv_video.so
-rwxr-xr-x root/root usr/lib/dri/vdpau_drv_video.la
-rwxr-xr-x root/root usr/lib/dri/vdpau_drv_video.so

2
vdpau-video/.md5sum Normal file
View File

@ -0,0 +1,2 @@
9be53b93d6f73af9fbc6536819773028 enable-glx.patch
6aac5517fb76a0cd539d0fb77def8b2d vdpau-video-0.7.2.tar.gz

25
vdpau-video/Pkgfile Normal file
View File

@ -0,0 +1,25 @@
# Description: VDPAU back-end for NVIDIA and VIA chipsets.
# URL: http://www.splitted-desktop.com/~gbeauchesne/vdpau-video/
# Maintainer: Danny Rawlins, monster dot romster at gmail dot com
# Packager: Danny Rawlins, monster dot romster at gmail dot com
# Depends on: libvdpau libvs mesa3d
name=vdpau-video
version=0.7.2
release=1
source=(http://www.splitted-desktop.com/~gbeauchesne/$name/$name-$version.tar.gz
enable-glx.patch)
build() {
cd $name-$version
patch -p 1 -i $SRC/enable-glx.patch
autoreconf -fi
./configure \
--prefix=/usr \
--enable-glx
make
make DESTDIR=$PKG install
}

View File

@ -0,0 +1,13 @@
diff -Nur vdpau-video-0.7.2.orig/configure.ac vdpau-video-0.7.2/configure.ac
--- vdpau-video-0.7.2.orig/configure.ac 2010-10-08 00:09:53.000000000 -0700
+++ vdpau-video-0.7.2/configure.ac 2010-10-08 11:34:00.536686684 -0700
@@ -203,7 +203,7 @@
# error "VA-API version >= 0.30.0-sds$LIBVA_GLX_SDS_VERSION_0_30 is required"
# endif
#elif VA_MAJOR_VERSION == 0 && VA_MINOR_VERSION == 31
- # if !defined(VA_SDS_VERSION) || (VA_SDS_VERSION < $LIBVA_GLX_SDS_VERSION_0_31)
+ # if !VA_CHECK_VERSION(0,31,0)
# error "VA-API version >= 0.31.0-sds$LIBVA_GLX_SDS_VERSION_0_31 is required"
# endif
#else