exa: cherry-pick PR that changes default folder icon
This commit is contained in:
parent
0cfc7e5696
commit
5a0544bdf6
@ -1,5 +1,6 @@
|
||||
untrusted comment: verify with /etc/ports/contrib.pub
|
||||
RWSagIOpLGJF3xO87CXpdfwQAe/EphlxmJ25AksJJu6TEMWbQ2DVVnwsxyj/V23z0MUl893SNwNtQM9m15z0054+sjV+KeAK2g0=
|
||||
SHA256 (Pkgfile) = 9c9a9dc78ee66a99fdf705b98d1d6281060c82292252de423efe060fd13e2835
|
||||
RWSagIOpLGJF3zOpvtcnDUuVEH8U9/Qd8kEsh+vLp/tD9IRcDXkgnlhUbmQjI0zvjJoR5cmifzjV8bq58eWoUC2FYWDiK86HfQQ=
|
||||
SHA256 (Pkgfile) = 5ea35b8b0a1101731507f1ffc1efb7b139e24d8d416a7ee75c915461ab99e049
|
||||
SHA256 (.footprint) = bc31d95b8c11ef950831c0aaa1721d3a40aa918182ea44bd94d88b9b212d02d6
|
||||
SHA256 (exa-0.10.1.tar.gz) = ff0fa0bfc4edef8bdbbb3cabe6fdbd5481a71abbbcc2159f402dea515353ae7c
|
||||
SHA256 (1051.patch) = d772cd21a7172f7de2f79de844f10d1c6423a2e739c899e57e985f22a8dbb7dc
|
||||
|
22
exa/1051.patch
Normal file
22
exa/1051.patch
Normal file
@ -0,0 +1,22 @@
|
||||
From 6c848831b214bd7fd7b5fc886ecd9c44f20d9250 Mon Sep 17 00:00:00 2001
|
||||
From: CT-66 <css.com@protonmail.com>
|
||||
Date: Sun, 3 Apr 2022 04:54:13 +0530
|
||||
Subject: [PATCH] changed default folder icon
|
||||
|
||||
---
|
||||
src/output/icons.rs | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/output/icons.rs b/src/output/icons.rs
|
||||
index a2bc1ada..af216512 100644
|
||||
--- a/src/output/icons.rs
|
||||
+++ b/src/output/icons.rs
|
||||
@@ -100,7 +100,7 @@ pub fn icon_for_file(file: &File<'_>) -> char {
|
||||
"bin" => '\u{e5fc}', //
|
||||
".git" => '\u{f1d3}', //
|
||||
".idea" => '\u{e7b5}', //
|
||||
- _ => '\u{f115}' //
|
||||
+ _ => '\u{f413}' //
|
||||
}
|
||||
}
|
||||
else if let Some(icon) = extensions.icon_file(file) { icon }
|
@ -5,14 +5,17 @@
|
||||
|
||||
name=exa
|
||||
version=0.10.1
|
||||
release=1
|
||||
source=(https://github.com/ogham/exa/archive/v$version/$name-$version.tar.gz)
|
||||
release=2
|
||||
source=(https://github.com/ogham/exa/archive/v$version/$name-$version.tar.gz
|
||||
1051.patch)
|
||||
|
||||
build() {
|
||||
prt-get isinst sccache && export RUSTC_WRAPPER=/usr/bin/sccache
|
||||
mkdir "$PKGMK_SOURCE_DIR/rust" || true
|
||||
export CARGO_HOME="$PKGMK_SOURCE_DIR/rust"
|
||||
|
||||
patch -Np1 -d $name-$version -i $SRC/1051.patch
|
||||
|
||||
cargo update --manifest-path $name-$version/Cargo.toml
|
||||
cargo fetch --manifest-path $name-$version/Cargo.toml
|
||||
cargo build --release --locked --manifest-path $name-$version/Cargo.toml
|
||||
|
Loading…
x
Reference in New Issue
Block a user