upx: 4.0.0 -> 4.0.1

This commit is contained in:
Tim Biermann 2022-11-19 17:13:36 +00:00
parent cc99538761
commit 5d2f54b4fc
3 changed files with 8 additions and 81 deletions

View File

@ -1,6 +1,5 @@
untrusted comment: verify with /etc/ports/contrib.pub
RWSagIOpLGJF31XCSU7T4T7dHfGSwTsjF1I6W2resB+w3sb31ineNJ5xwi2LUNpnO0Ce4DBXSTcf3JwpdFAgEI7E791R45KmMwA=
SHA256 (Pkgfile) = 1593d84fbda30649f58eb738a0eb80715f869d4a92286d22a60dc0b66bec51d7
RWSagIOpLGJF37eq0dDHTp1XffSZzViMGAr0Ac86hI+vVJispYH953BViNq0RZDTWIZsBSpBor6XOWw5s9culvZnr4bFaGJ7lAY=
SHA256 (Pkgfile) = b1883b089961f5f5c517dd7a23f0d5a9253e2438adcae12935d7f26a0519f8b3
SHA256 (.footprint) = 4c1267857f05230db56e631d77bd98e5e15f48f232b4a188bc1eed8a5320ebad
SHA256 (upx-4.0.0-src.tar.xz) = eaf938f8824e65f06852142fda97f8349ad660612979fa311618109c819f36ea
SHA256 (system-deps.patch) = 3afbbf23b7e902a00c96a27036188566a8405dc54abe2d57d444a1fe748adb1c
SHA256 (upx-4.0.1-src.tar.xz) = 77003c8e2e29aa9804e2fbaeb30f055903420b3e01d95eafe01aed957fb7e190

View File

@ -4,21 +4,20 @@
# Depends on: lz4 ucl zlib
name=upx
version=4.0.0
version=4.0.1
release=1
source=(https://github.com/upx/upx/releases/download/v$version/upx-$version-src.tar.xz
system-deps.patch)
source=(https://github.com/upx/upx/releases/download/v$version/upx-$version-src.tar.xz)
build() {
patch -Np1 -d $name-$version-src -i $SRC/system-deps.patch
rm -rf $name-$version-src/vendor/ucl
cmake -S $name-$version-src -B build -G Ninja \
-D CMAKE_INSTALL_PREFIX=/usr \
-D CMAKE_INSTALL_LIBDIR=lib \
-D CMAKE_BUILD_TYPE=Release \
-D CMAKE_CXX_FLAGS_RELEASE="$CXXFLAGS" \
-D CMAKE_C_FLAGS_RELEASE="$CFLAGS" \
-D UPX_CONFIG_DISABLE_WERROR=ON \
-D UPX_CONFIG_DISABLE_SANITIZE=ON \
-D UPX_CONFIG_DISABLE_GITREV=ON \
-Wno-dev
cmake --build build

View File

@ -1,71 +0,0 @@
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 22db99a..abf8f65 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -70,21 +70,18 @@ endif()
# targets and compilation flags
#***********************************************************************
-file(GLOB ucl_SOURCES "vendor/ucl/src/*.c")
-list(SORT ucl_SOURCES)
-add_library(upx_vendor_ucl STATIC ${ucl_SOURCES})
-set_property(TARGET upx_vendor_ucl PROPERTY C_STANDARD 11)
-
file(GLOB zlib_SOURCES "vendor/zlib/*.c")
list(SORT zlib_SOURCES)
add_library(upx_vendor_zlib STATIC ${zlib_SOURCES})
set_property(TARGET upx_vendor_zlib PROPERTY C_STANDARD 11)
+find_package(PkgConfig REQUIRED)
+pkg_check_modules(upx_vendor_ucl REQUIRED ucl IMPORTED_TARGET GLOBAL)
file(GLOB upx_SOURCES "src/*.cpp" "src/util/*.cpp")
list(SORT upx_SOURCES)
add_executable(upx ${upx_SOURCES})
set_property(TARGET upx PROPERTY CXX_STANDARD 14)
-target_link_libraries(upx upx_vendor_ucl upx_vendor_zlib)
+target_link_libraries(upx ucl upx_vendor_zlib)
if(UPX_CONFIG_DISABLE_WERROR)
set(warn_Werror "")
@@ -118,25 +115,8 @@ else()
add_definitions(-fno-tree-vectorize)
endif()
-set(t upx_vendor_ucl)
-target_include_directories(${t} PRIVATE vendor/ucl/include vendor/ucl)
-if(MSVC)
- target_compile_options(${t} PRIVATE -J -W4 ${warn_WX})
-else()
- target_compile_options(${t} PRIVATE -Wall -Wextra -Wvla ${warn_Werror})
-endif()
-
-set(t upx_vendor_zlib)
-if(MSVC)
- target_compile_options(${t} PRIVATE -DHAVE_STDARG_H -DHAVE_VSNPRINTF -J -W3 ${warn_WX})
-else()
- target_compile_options(${t} PRIVATE -DHAVE_STDARG_H -DHAVE_UNISTD_H -DHAVE_VSNPRINTF)
- # clang-15: -Wno-strict-prototypes is needed to silence the new -Wdeprecated-non-prototype warning
- target_compile_options(${t} PRIVATE -Wall -Wextra -Wvla -Wno-strict-prototypes ${warn_Werror})
-endif()
-
set(t upx)
-target_include_directories(${t} PRIVATE vendor)
+target_include_directories(${t} PRIVATE upx_vendor_ucl_INCLUDE_DIRS vendor)
target_compile_definitions(${t} PRIVATE $<$<CONFIG:Debug>:DEBUG=1>)
if(GITREV_SHORT)
target_compile_definitions(${t} PRIVATE UPX_VERSION_GITREV="${GITREV_SHORT}${GITREV_PLUS}")
diff --git a/src/conf.h b/src/conf.h
index e50b250..449161d 100644
--- a/src/conf.h
+++ b/src/conf.h
@@ -161,8 +161,8 @@ typedef unsigned char upx_byte;
#define WITH_ZLIB 1
#if (WITH_UCL)
# define ucl_compress_config_t REAL_ucl_compress_config_t
-# include <ucl/include/ucl/uclconf.h>
-# include <ucl/include/ucl/ucl.h>
+# include <ucl/uclconf.h>
+# include <ucl/ucl.h>
# undef ucl_compress_config_t
# undef ucl_compress_config_p
#endif