ipcalc: update to 1.0.1

This commit is contained in:
Steffen Nurpmeso 2021-06-20 00:05:12 +02:00
parent 0cbd5636b6
commit 5d3f93fdc3
3 changed files with 6 additions and 58 deletions

View File

@ -1,6 +1,5 @@
untrusted comment: verify with /etc/ports/contrib.pub
RWSagIOpLGJF34JjnPwt2cfhTk2kfhJABgMoqdaRPSzZ/G9AktNiW6QTekdQ+9nyngWeMANRnEVyN27j4ISHiR2RxwjZVw8gqAc=
SHA256 (Pkgfile) = 44163133ec1841b6f5da21e4f1a23885c305ff2524fa19d9cdb04f67ac47288c
RWSagIOpLGJF3yf1B5pi0lNNgmtiXtMyh1Y0/MzM/iiBSzAv0E1U5yrdrgykFSVUEkrZQdnaQTJDKYItNDFDLLrNxYc0VEdQYQo=
SHA256 (Pkgfile) = 29a293d48db612f4cc6caefdfa5363da196207dd235e827b149c6cc05504b47a
SHA256 (.footprint) = 7afe696a7c62c307d705f3089bfdf168f6098e7ae4a97f173210ba2831f2eb53
SHA256 (ipcalc-1.0.0.tar.bz2) = d7aca371335ab3e35364bcfe34cd0229db005be8bebb9236608ec318cb3f7748
SHA256 (build.patch) = 15cb7289cdc104b34e43f447df1ce70ca97b510a9b7058aee4ab3472a3827b6c
SHA256 (ipcalc-1.0.1.tar.bz2) = dac080c0773cc14c1d6f818899351d2286cace85751dd9dc704944e54c2c3565

View File

@ -4,21 +4,19 @@
# Depends on: meson ninja
name=ipcalc
version=1.0.0
version=1.0.1
release=1
source=(https://gitlab.com/${name}/${name}/-/archive/${version}/\
${name}-${version}.tar.bz2 build.patch)
${name}-${version}.tar.bz2)
build() {
cd ${name}-${version}
patch -Np1 -i "${SRC}"/build.patch
meson setup build
ninja -C build
cat > ./ipcalc.1 <<- \!
.Dd April 9, 2021
.Dd June 20, 2021
.Dt IPCALC 1
.Os
.

View File

@ -1,49 +0,0 @@
commit 322294d7bf61f9fdf0e45e9b6c6013a7c6a35bfd
Author: Derrick Lyndon Pallas <derrick@meter.com>
AuthorDate: 2020-10-14 18:25:54 +0000
Commit: Derrick Lyndon Pallas <derrick@meter.com>
CommitDate: 2020-10-14 18:33:24 +0000
Do not fail to build if ronn is missing
If ruby-ronn is missing, we can not compile the man page from markdown but
that should not prevent the application from building.
Signed-off-by: Derrick Lyndon Pallas <derrick@meter.com>
---
meson.build | 23 ++++++++++++-----------
1 file changed, 12 insertions(+), 11 deletions(-)
diff --git a/meson.build b/meson.build
index a2169fc17d..981d4a424f 100644
--- a/meson.build
+++ b/meson.build
@@ -72,16 +72,17 @@ ipcalc = executable('ipcalc',
install : true
)
-ronn = find_program('ronn', required: true)
-
-ipcalc_1 = custom_target(
- 'ipcalc.1',
- output : 'ipcalc.1',
- input : 'ipcalc.1.md',
- command : [ronn, '--pipe', '-r', '@INPUT@'],
- capture: true,
- install_dir: join_paths(get_option('mandir'), 'man1'),
- install: true
-)
+ronn = find_program('ronn', required: false)
+if ronn.found()
+ ipcalc_1 = custom_target(
+ 'ipcalc.1',
+ output : 'ipcalc.1',
+ input : 'ipcalc.1.md',
+ command : [ronn, '--pipe', '-r', '@INPUT@'],
+ capture: true,
+ install_dir: join_paths(get_option('mandir'), 'man1'),
+ install: true
+ )
+endif
subdir('tests')