squashfs-tools: updated to version 4.5.1

This commit is contained in:
Matt Housh 2022-03-28 16:38:13 -05:00
parent ee76f3538e
commit 5e2b23d94a
4 changed files with 15 additions and 27 deletions

View File

@ -3,3 +3,11 @@ drwxr-xr-x root/root sbin/
lrwxrwxrwx root/root sbin/sqfscat -> unsquashfs
lrwxrwxrwx root/root sbin/sqfstar -> mksquashfs
-rwxr-xr-x root/root sbin/unsquashfs
drwxr-xr-x root/root usr/
drwxr-xr-x root/root usr/share/
drwxr-xr-x root/root usr/share/man/
drwxr-xr-x root/root usr/share/man/man1/
-rw-r--r-- root/root usr/share/man/man1/mksquashfs.1.gz
-rw-r--r-- root/root usr/share/man/man1/sqfscat.1.gz
-rw-r--r-- root/root usr/share/man/man1/sqfstar.1.gz
-rw-r--r-- root/root usr/share/man/man1/unsquashfs.1.gz

View File

@ -1,6 +1,5 @@
untrusted comment: verify with /etc/ports/contrib.pub
RWSagIOpLGJF37tOdh4p5tgwBxJ5Q4n9ahE11s3XFolivu3Uzc6IOTQF7DqxxJqIxB61Q4wCmjaoow66m69YdXqyVYSWNZLmlgk=
SHA256 (Pkgfile) = c59485f5e2d2dd370190375d92226fb2b05193300288615007d321c9c98f0b30
SHA256 (.footprint) = 46ee2e8e8d666941206c63f7a8791370ed61e08ca5068a89b81d95d3e0e1da68
SHA256 (squashfs-tools-4.5.tar.gz) = b9e16188e6dc1857fe312633920f7d71cc36b0162eb50f3ecb1f0040f02edddd
SHA256 (destdir.patch) = 8fb613af82bf1c032a6f23b457ff0efa32c8a891f97580e90d93a911fe3a9be4
RWSagIOpLGJF32BKwpRD5MDgPuP2DPHzqI07eoktgsVngmCTmoTjLPZ4/M0il0+2ULWj8mrE1cKOAZjE989zKH6ZbsL2YV9vkwg=
SHA256 (Pkgfile) = f50bf848b6ba65926ed18ad92b4674f5d5269903bdf437ea88d7687fac957ef6
SHA256 (.footprint) = 49a61b0c5de34abb6c232c1cf923f562998b97d0d503c124cabf948b62a03b28
SHA256 (squashfs-tools-4.5.1.tar.gz) = 277b6e7f75a4a57f72191295ae62766a10d627a4f5e5f19eadfbc861378deea7

View File

@ -4,14 +4,12 @@
# Depends on: gzip lzo xz
name=squashfs-tools
version=4.5
version=4.5.1
release=1
source=(https://github.com/plougher/$name/archive/$version/$name-$version.tar.gz\
destdir.patch)
source=(https://github.com/plougher/$name/archive/$version/$name-$version.tar.gz)
build() {
cd $name-$version/$name
patch -p2 -i $SRC/destdir.patch
make GZIP_SUPPORT=1 LZO_SUPPORT=1 XZ_SUPPORT=1 EXTRA_CFLAGS="-fcommon"
make install INSTALL_DIR=/sbin DESTDIR=$PKG
make install INSTALL_PREFIX= INSTALL_DIR=${PKG}/sbin INSTALL_MANPAGES_DIR=${PKG}/usr/share/man/man1
}

View File

@ -1,17 +0,0 @@
diff -urN squashfs-tools-4.5.orig/squashfs-tools/Makefile squashfs-tools-4.5/squashfs-tools/Makefile
--- squashfs-tools-4.5.orig/squashfs-tools/Makefile 2021-07-22 20:11:24.000000000 +0000
+++ squashfs-tools-4.5/squashfs-tools/Makefile 2021-08-21 20:04:10.212179427 +0000
@@ -403,8 +403,8 @@
.PHONY: install
install: mksquashfs unsquashfs
- mkdir -p $(INSTALL_DIR)
- cp mksquashfs $(INSTALL_DIR)
- cp unsquashfs $(INSTALL_DIR)
- ln -fs $(INSTALL_DIR)/unsquashfs $(INSTALL_DIR)/sqfscat
- ln -fs $(INSTALL_DIR)/mksquashfs $(INSTALL_DIR)/sqfstar
+ mkdir -p $(DESTDIR)/$(INSTALL_DIR)
+ cp mksquashfs $(DESTDIR)/$(INSTALL_DIR)
+ cp unsquashfs $(DESTDIR)/$(INSTALL_DIR)
+ ln -fs unsquashfs $(DESTDIR)/$(INSTALL_DIR)/sqfscat
+ ln -fs mksquashfs $(DESTDIR)/$(INSTALL_DIR)/sqfstar