em8300: initial commit
This commit is contained in:
parent
ce7c1e01b6
commit
5e9c6f2d2d
19
em8300/.footprint
Normal file
19
em8300/.footprint
Normal file
@ -0,0 +1,19 @@
|
||||
drwxr-xr-x root/root lib/
|
||||
drwxr-xr-x root/root lib/firmware/
|
||||
-rw-r--r-- root/root lib/firmware/em8300.bin
|
||||
drwxr-xr-x root/root lib/modules/
|
||||
drwxr-xr-x root/root lib/modules/<kernel-version>/
|
||||
drwxr-xr-x root/root lib/modules/<kernel-version>/em8300/
|
||||
-rwxr-xr-x root/root lib/modules/<kernel-version>/em8300/adv717x.ko
|
||||
-rwxr-xr-x root/root lib/modules/<kernel-version>/em8300/bt865.ko
|
||||
-rwxr-xr-x root/root lib/modules/<kernel-version>/em8300/em8300.ko
|
||||
drwxr-xr-x root/root usr/
|
||||
drwxr-xr-x root/root usr/bin/
|
||||
-rwxr-xr-x root/root usr/bin/em8300setup
|
||||
drwxr-xr-x root/root usr/include/
|
||||
drwxr-xr-x root/root usr/include/linux/
|
||||
-rw-r--r-- root/root usr/include/linux/em8300.h
|
||||
drwxr-xr-x root/root usr/man/
|
||||
drwxr-xr-x root/root usr/man/man1/
|
||||
-rw-r--r-- root/root usr/man/man1/em8300setup.1.gz
|
||||
drwxr-xr-x root/root usr/share/
|
3
em8300/.md5sum
Normal file
3
em8300/.md5sum
Normal file
@ -0,0 +1,3 @@
|
||||
58a6765d469cc507c1e0dff152ce3d30 em8300-0.15.3.tar.gz
|
||||
736531b1c02b4a7244bd2dd127023b63 em8300-ntsc.diff
|
||||
83c6f2bbf1d55e3fcb3db57c07d9c310 em8300_2.6.17_2.patch.gz
|
25
em8300/Pkgfile
Normal file
25
em8300/Pkgfile
Normal file
@ -0,0 +1,25 @@
|
||||
# $Id: $
|
||||
# Description: Linux DXR3 and Hollywood+ Driver
|
||||
# URL: http://dxr3.sf.net
|
||||
# Maintainer: Alan Mizrahi, alan at mizrahi dot com dot ve
|
||||
# Depends on:
|
||||
|
||||
name=em8300
|
||||
version=0.15.4cvs1
|
||||
release=2
|
||||
source=(http://dl.sourceforge.net/sourceforge/dxr3/$name-0.15.3.tar.gz em8300-ntsc.diff em8300_2.6.17_2.patch.gz)
|
||||
|
||||
build () {
|
||||
cd $name-0.15.3
|
||||
patch -p1 < ../em8300-ntsc.diff
|
||||
zcat ../em8300_2.6.17_2.patch.gz | patch -p0
|
||||
./configure --prefix=/usr
|
||||
make
|
||||
make DESTDIR=$PKG install
|
||||
cd modules
|
||||
make
|
||||
make DESTDIR=$PKG install
|
||||
rm -rf $PKG/usr/share/em8300 $PKG/usr/bin/{autocal,dhc,dxr3view}
|
||||
# mkdir -p $PKG/etc/udev/rules.d
|
||||
# install -m 644 em8300-udev.rules $PKG/etc/udev/rules.d/90-em8300.rules
|
||||
}
|
29
em8300/README
Normal file
29
em8300/README
Normal file
@ -0,0 +1,29 @@
|
||||
REQUIREMENTS
|
||||
|
||||
PRE-INSTALL
|
||||
|
||||
POST-INSTALL
|
||||
|
||||
* Run depmod -a
|
||||
|
||||
* You may edit your /etc/modprobe.conf, I use this settings:
|
||||
|
||||
alias em8300-1 off
|
||||
alias char-major-121 em8300
|
||||
install em8300 /sbin/modprobe bt865 && /sbin/modprobe --ignore-install em8300
|
||||
options em8300 dicom_fix=0 dicom_control=0 dicom_other_pal=0
|
||||
|
||||
* Edit /etc/rc.modules to load the modules at boot time.
|
||||
|
||||
* You may also run em8300setup to change the default parameters.
|
||||
|
||||
* If you are using udev, you may want to create
|
||||
/etc/udev/rules.d/xx-em8300.rules with something like:
|
||||
|
||||
KERNEL=="em8300*", NAME="%k", OWNER="root", GROUP="em8300", MODE="660"
|
||||
|
||||
|
||||
PRECAUTION
|
||||
This port builds em8300 with NTSC by default.
|
||||
After installing this port you need to rebuild mplayer to
|
||||
add dxr3 support.
|
11
em8300/em8300-ntsc.diff
Normal file
11
em8300/em8300-ntsc.diff
Normal file
@ -0,0 +1,11 @@
|
||||
--- em8300-0.15.3/modules/Makefile.orig 2006-04-09 23:29:04.000000000 -0400
|
||||
+++ em8300-0.15.3/modules/Makefile 2006-04-09 23:29:59.000000000 -0400
|
||||
@@ -69,7 +69,7 @@
|
||||
endif
|
||||
|
||||
EXTRA_CFLAGS := -I$(EM8300_DIR)/include \
|
||||
- -DEM8300_VIDEOMODE_DEFAULT=EM8300_VIDEOMODE_PAL \
|
||||
+ -DEM8300_VIDEOMODE_DEFAULT=EM8300_VIDEOMODE_NTSC \
|
||||
-DEM8300_AUDIOMODE_DEFAULT=EM8300_AUDIOMODE_ANALOG \
|
||||
-DEM8300_VERSION=\"$(EM8300_VERSION)\" \
|
||||
-DCONFIG_ADV717X_PIXELPORT16BIT -DCONFIG_ADV717X_PIXELPORTPAL \
|
BIN
em8300/em8300_2.6.17_2.patch.gz
Normal file
BIN
em8300/em8300_2.6.17_2.patch.gz
Normal file
Binary file not shown.
Loading…
x
Reference in New Issue
Block a user