atanks: 2.9 -> 3.0
This commit is contained in:
parent
826c0ac94f
commit
63b774e860
@ -1 +1,3 @@
|
||||
c3d930dd63f3b4157827b305bf2a6b6e atanks-2.9.tar.gz
|
||||
88254f1c7efdcdb467d71e0589adaa75 atanks-3.0-install.patch
|
||||
2aedfb58060d8958e1459cce9687acdd atanks-3.0-version-fix.patch
|
||||
515ddfd70fb005d56aa0b509c4812ab8 atanks-3.0.tar.gz
|
||||
|
@ -5,21 +5,17 @@
|
||||
# Depends on: allegro
|
||||
|
||||
name=atanks
|
||||
version=2.9
|
||||
version=3.0
|
||||
release=1
|
||||
source=(http://dl.sourceforge.net/sourceforge/atanks/atanks-$version.tar.gz)
|
||||
source=(http://dl.sourceforge.net/sourceforge/atanks/atanks-$version.tar.gz
|
||||
atanks-$version-install.patch
|
||||
atanks-$version-version-fix.patch)
|
||||
|
||||
build() {
|
||||
cd atanks
|
||||
sed -i src/Makefile \
|
||||
-e '/^FLAGS = /s|-DLINUX -DDATA_DIR=\\".\\"|-DLINUX -DDATA_DIR=\\"/usr/share/atanks\\"|' \
|
||||
-e '/^CFLAGS += -g.*$/d'
|
||||
|
||||
make -C src
|
||||
install -D -m 0755 atanks $PKG/usr/bin/atanks
|
||||
install -d $PKG/usr/share/atanks
|
||||
install -m 0644 *.dat *.txt -t $PKG/usr/share/atanks/
|
||||
install -D -m 0644 atanks.desktop $PKG/usr/share/applications/atanks.desktop
|
||||
install -D -m 0644 atanks.png $PKG/usr/share/pixmaps/atanks.png
|
||||
patch -p 1 -i $SRC/atanks-$version-install.patch
|
||||
patch -p 1 -i $SRC/atanks-$version-version-fix.patch
|
||||
make
|
||||
make DESTDIR=$PKG install
|
||||
}
|
||||
|
||||
|
48
atanks/atanks-3.0-install.patch
Normal file
48
atanks/atanks-3.0-install.patch
Normal file
@ -0,0 +1,48 @@
|
||||
diff -pruN atanks.orig/Makefile atanks/Makefile
|
||||
--- atanks.orig/Makefile 2008-06-01 03:37:44.758709593 +1000
|
||||
+++ atanks/Makefile 2008-06-01 04:43:35.237710360 +1000
|
||||
@@ -1,17 +1,19 @@
|
||||
VERSION=2.8
|
||||
export VERSION
|
||||
FILENAME=atanks-${VERSION}
|
||||
-INSTALL=/usr/bin/install -c
|
||||
+INSTALL=/usr/bin/install
|
||||
DISTCOMMON=atanks/*.dat atanks/COPYING atanks/README atanks/TODO atanks/Changelog atanks/BUGS atanks/Help.txt atanks/credits.txt atanks/gloat.txt atanks/instr.txt atanks/revenge.txt atanks/suicide.txt atanks/gloat.pt_BR.txt atanks/Help.pt_BR.txt atanks/revenge.pt_BR.txt atanks/suicide.pt_BR.txt atanks/revenge_fr.txt atanks/gloat_fr.txt atanks/suicide_fr.txt atanks/weapons.txt
|
||||
-INCOMMON=*.dat COPYING README TODO Changelog *.txt
|
||||
+INCOMMON=*.dat *.txt
|
||||
|
||||
all:
|
||||
$(MAKE) -C src
|
||||
|
||||
install: all
|
||||
- $(INSTALL) -g 0 -m 755 -o 0 atanks /usr/bin
|
||||
- mkdir -p /usr/share/games/atanks
|
||||
- $(INSTALL) -g 0 -m 644 -o 0 $(INCOMMON) /usr/share/games/atanks
|
||||
+ $(INSTALL) -d $(DESTDIR)/usr/share/atanks
|
||||
+ $(INSTALL) -m 0644 -t $(DESTDIR)/usr/share/atanks $(INCOMMON)
|
||||
+ $(INSTALL) -m 0755 -D atanks $(DESTDIR)/usr/bin/atanks
|
||||
+ $(INSTALL) -m 0644 -D atanks.desktop $(DESTDIR)/usr/share/applications/atanks.desktop
|
||||
+ $(INSTALL) -m 0644 -D atanks.png $(DESTDIR)/usr/share/pixmaps/atanks.png
|
||||
clean:
|
||||
rm -f atanks
|
||||
$(MAKE) -C src clean
|
||||
diff -pruN atanks.orig/src/Makefile atanks/src/Makefile
|
||||
--- atanks.orig/src/Makefile 2008-06-01 03:37:44.780707681 +1000
|
||||
+++ atanks/src/Makefile 2008-06-01 03:45:44.758709878 +1000
|
||||
@@ -4,7 +4,7 @@ MODULES = \
|
||||
globaldata.o environment.o player.o virtobj.o floattext.o teleport.o physobj.o decor.o explosion.o missile.o beam.o tank.o atanks.o fade.o perlin.o sky.o button.o files.o team.o satellite.o
|
||||
|
||||
CC = g++
|
||||
-FLAGS = -DLINUX -DDATA_DIR=\".\"
|
||||
+FLAGS = -DLINUX -DDATA_DIR=\"/usr/share/atanks\"
|
||||
OUTPUT = ../atanks
|
||||
WFLAGS =
|
||||
OFLAGS =
|
||||
@@ -12,7 +12,6 @@ LFLAGS +=
|
||||
LDFLAGS = `allegro-config --libs`
|
||||
|
||||
CFLAGS += -Wall -Iinclude # -fprofile-arcs -ftest-coverage
|
||||
-CFLAGS += -g # debug vs optimize flags
|
||||
|
||||
SRCS = $(MODULES:.o=.cc)
|
||||
GLOBALS = main.h globals.h externs.h globaldata.h imagedefs.h lineseq.h button.h files.h
|
9
atanks/atanks-3.0-version-fix.patch
Normal file
9
atanks/atanks-3.0-version-fix.patch
Normal file
@ -0,0 +1,9 @@
|
||||
diff -pruN atanks.orig/Makefile atanks/Makefile
|
||||
--- atanks.orig/Makefile 2008-06-01 03:37:44.758709593 +1000
|
||||
+++ atanks/Makefile 2008-06-01 04:48:47.041706580 +1000
|
||||
@@ -1,4 +1,4 @@
|
||||
-VERSION=2.8
|
||||
+VERSION=3.0
|
||||
export VERSION
|
||||
FILENAME=atanks-${VERSION}
|
||||
INSTALL=/usr/bin/install -c
|
Loading…
x
Reference in New Issue
Block a user