nvidia-legacy-71xx: dropped

This commit is contained in:
Danny Rawlins 2009-12-16 21:38:29 +11:00
parent b8a51160c7
commit 63d7cc677d
6 changed files with 0 additions and 288 deletions

View File

@ -1,37 +0,0 @@
drwxr-xr-x root/root lib/
drwxr-xr-x root/root lib/modules/
drwxr-xr-x root/root lib/modules/<kernel-version>/
drwxr-xr-x root/root lib/modules/<kernel-version>/kernel/
drwxr-xr-x root/root lib/modules/<kernel-version>/kernel/drivers/
drwxr-xr-x root/root lib/modules/<kernel-version>/kernel/drivers/video/
-rw-r--r-- root/root lib/modules/<kernel-version>/kernel/drivers/video/nvidia.ko
drwxr-xr-x root/root usr/
drwxr-xr-x root/root usr/bin/
-rwxr-xr-x root/root usr/bin/nvidia-settings
drwxr-xr-x root/root usr/include/
drwxr-xr-x root/root usr/include/nvidia/
drwxr-xr-x root/root usr/include/nvidia/GL/
-r--r--r-- root/root usr/include/nvidia/GL/gl.h
-r--r--r-- root/root usr/include/nvidia/GL/glext.h
-r--r--r-- root/root usr/include/nvidia/GL/glx.h
-r--r--r-- root/root usr/include/nvidia/GL/glxtokens.h
drwxr-xr-x root/root usr/lib/
-rwxr-xr-x root/root usr/lib/libGL.la
-rwxr-xr-x root/root usr/lib/libGL.so.71.86.06
lrwxrwxrwx root/root usr/lib/libGLcore.so -> libGLcore.so.71.86.06
-rwxr-xr-x root/root usr/lib/libGLcore.so.71.86.06
-rwxr-xr-x root/root usr/lib/libnvidia-tls.so.71.86.06
drwxr-xr-x root/root usr/lib/tls/
-rwxr-xr-x root/root usr/lib/tls/libnvidia-tls.so.71.86.06
drwxr-xr-x root/root usr/lib/xorg/
-r--r--r-- root/root usr/lib/xorg/libXvMCNVIDIA.a
-rwxr-xr-x root/root usr/lib/xorg/libXvMCNVIDIA.so.71.86.06
drwxr-xr-x root/root usr/lib/xorg/modules/
drwxr-xr-x root/root usr/lib/xorg/modules/drivers/
-rwxr-xr-x root/root usr/lib/xorg/modules/drivers/nvidia_drv.so
drwxr-xr-x root/root usr/lib/xorg/modules/extensions/
lrwxrwxrwx root/root usr/lib/xorg/modules/extensions/libGLcore.so -> /usr/lib/libGLcore.so
-rwxr-xr-x root/root usr/lib/xorg/modules/extensions/libglx.so.71.86.06
drwxr-xr-x root/root usr/man/
drwxr-xr-x root/root usr/man/man1/
-rw-r--r-- root/root usr/man/man1/nvidia-installer.1.gz

View File

@ -1,3 +0,0 @@
61e4511d1bbb2962ca139091210b61ea NVIDIA-Linux-x86-71.86.06-pkg0.run
cd4a68b5a88be6976b90cd0df6bfe89e kernel-2.6.27.patch
544ac021f572c0aca5025dcca9d01510 nvidia-makefile.patch

View File

@ -1,55 +0,0 @@
# Description: nVIDIA Linux Display Driver.
# URL: http://www.nvidia.com/
# Maintainer: Danny Rawlins, monster dot romster at gmail dot com
# Packager: Matt Housh, jaeger at morpheus dot net
# Depends on: xorg gl-select
name=nvidia-legacy-71xx
version=71.86.06
release=3
source=(http://us.download.nvidia.com/XFree86/Linux-x86/$version/NVIDIA-Linux-x86-$version-pkg0.run
nvidia-makefile.patch
kernel-2.6.27.patch)
build() {
sh NVIDIA-Linux-x86-$version-pkg0.run --extract-only
cd NVIDIA-Linux-x86-$version-pkg0
# patch Makefile.kbuild for normal users and no load during build
patch -p 0 -i $SRC/nvidia-makefile.patch usr/src/nv/Makefile.kbuild
# kernel patch
patch -p 1 -i $SRC/kernel-2.6.27.patch
# create directories the Makefile expects
mkdir -p $PKG/usr/lib \
$PKG/usr/lib/xorg/modules/drivers \
$PKG/usr/lib/xorg/modules/extensions \
$PKG/usr/bin $PKG/usr/man/man1
# install libraries
cp -a usr/X11R6/lib/* $PKG/usr/lib/xorg/
cp -a usr/lib/* $PKG/usr/lib/
sed -i -e 's|__LIBGL_PATH__|/usr/lib|' $PKG/usr/lib/libGL.la
ln -s libGLcore.so.$version $PKG/usr/lib/libGLcore.so
ln -sf /usr/lib/libGLcore.so $PKG/usr/lib/xorg/modules/extensions/libGLcore.so
# copy includes
mkdir -p $PKG/usr/include/nvidia
cp -r usr/include/GL $PKG/usr/include/nvidia/
# install xconfig/settings programs and manpages
install -m 0755 usr/bin/nvidia-settings $PKG/usr/bin/
install -m 0644 usr/share/man/man1/nvidia-installer.1.gz \
$PKG/usr/man/man1/
# build the module
cd usr/src/nv
sed -i -e 's/config.h/utsrelease.h/' nv-linux.h # fix for later kernels
ln -s Makefile{.kbuild,}
SYSSRC="/usr/src/linux-$(uname -r)" IGNORE_CC_MISMATCH=1 make module
# install it
install -m 0644 -D nvidia.ko \
$PKG/lib/modules/`uname -r`/kernel/drivers/video/nvidia.ko
}

View File

@ -1,67 +0,0 @@
REQUIREMENTS:
Add your users to the "video" group to be able to use the nvidia
devices required for 3d to function properly.
PRECAUTION:
PRE-INSTALL:
POST-INSTALL
Use opt/gl-select from ports to select the correct gl/glx libraries
and extensions like so:
# gl-select nvidia
PRE-REMOVE:
POST-REMOVE
Use opt/gl-select from ports to revert to the xorg gl/glx
libraries and extensions like so:
# gl-select xorg
When UPGRADING/DOWNGRADING the nvidia port (where the version changes),
use gl-select to revert to xorg and then re-select nvidia in order to
refresh the libGLcore and libGL symlinks, like so:
# prt-get update nvidia-legacy-71xx
# gl-select xorg
# gl-select nvidia
NOTES:
The following GPUs are no longer supported in the regular NVIDIA
Unified UNIX Graphics Driver. Instead, these GPUs will continue to be
supported through special "Legacy GPU" drivers that will be updated
periodically to add support for new versions of Linux system
components (e.g., new Linux kernels, new versions of the X server,
etc).
There are presently two Legacy GPU driver series. The 1.0-71xx series
supports TNT, TNT2, GeForce 256, and GeForce2 GPUs. The 1.0-96xx
series supports GeForce2 MX, GeForce3, GeForce4, and Quadro4 GPUs.
For a complete list of the GPUs supported in each of the Legacy GPU
driver series, see the lists below.
The 1.0-71xx driver supports the following set of GPUs:
NVIDIA chip name Device PCI ID
RIVA TNT 0x0020
RIVA TNT2/TNT2 Pro 0x0028
RIVA TNT2 Ultra 0x0029
Vanta/Vanta LT 0x002C
RIVA TNT2 Model 64/Model 64 Pros 0x002D
Aladdin TNT2 0x00A0
GeForce 256 0x0100
GeForce DDR 0x0101
Quadro 0x0103
GeForce2 GTS/GeForce2 Pro 0x0150
GeForce2 Ti 0x0151
GeForce2 Ultra 0x0152
Quadro2 Pro 0x0153
Referenced from: http://www.nvidia.com/object/IO_32667.html

View File

@ -1,87 +0,0 @@
diff -Nru NVIDIA-Linux-x86-173.14.12-pkg0.orig/usr/src/nv/nv.c NVIDIA-Linux-x86-173.14.12-pkg0/usr/src/nv/nv.c
--- usr/src/nv/nv.c 2008-07-18 03:42:50.000000000 +0200
+++ NVIDIA-Linux-x86-173.14.12-pkg0/usr/src/nv/nv.c 2008-08-12 00:35:45.000000000 +0200
@@ -1296,14 +1296,22 @@
if (get_cpu() == cpu)
__nv_setup_pat_entries(NULL);
else
+ #if LINUX_VERSION_CODE >= KERNEL_VERSION(2, 6, 27)
+ smp_call_function(__nv_setup_pat_entries, hcpu, 1);
+ #else
smp_call_function(__nv_setup_pat_entries, hcpu, 1, 1);
+ #endif
put_cpu();
break;
case CPU_DOWN_PREPARE:
if (get_cpu() == cpu)
__nv_restore_pat_entries(NULL);
else
+ #if LINUX_VERSION_CODE >= KERNEL_VERSION(2, 6, 27)
+ smp_call_function(__nv_restore_pat_entries, hcpu, 1);
+ #else
smp_call_function(__nv_restore_pat_entries, hcpu, 1, 1);
+ #endif
put_cpu();
break;
}
diff -Nru NVIDIA-Linux-x86-173.14.12-pkg0.orig/usr/src/nv/nv-linux.h NVIDIA-Linux-x86-173.14.12-pkg0/usr/src/nv/nv-linux.h
--- usr/src/nv/nv-linux.h 2008-07-18 03:42:51.000000000 +0200
+++ NVIDIA-Linux-x86-173.14.12-pkg0/usr/src/nv/nv-linux.h 2008-08-12 00:44:27.000000000 +0200
@@ -104,7 +104,10 @@
#endif
#include <linux/spinlock.h>
+#if LINUX_VERSION_CODE >= KERNEL_VERSION(2, 6, 27)
+#else
#include <asm/semaphore.h>
+#endif
#include <linux/completion.h>
#include <linux/highmem.h>
@@ -665,13 +668,21 @@
#if defined(preempt_disable)
preempt_disable();
#endif
+ #if LINUX_VERSION_CODE >= KERNEL_VERSION(2, 6, 27)
+ ret = smp_call_function(func, info, 1);
+ #else
ret = smp_call_function(func, info, 1, 1);
+ #endif
func(info);
#if defined(preempt_enable)
preempt_enable();
#endif
#else
+ #if LINUX_VERSION_CODE >= KERNEL_VERSION(2, 6, 27)
+ ret = on_each_cpu(func, info, 1);
+ #else
ret = on_each_cpu(func, info, 1, 1);
+ #endif
#endif
return ret;
}
diff -Nru NVIDIA-Linux-x86-173.14.12-pkg0.orig/usr/src/nv/os-interface.c NVIDIA-Linux-x86-173.14.12-pkg0/usr/src/nv/os-interface.c
--- usr/src/nv/os-interface.c 2008-07-18 03:42:50.000000000 +0200
+++ NVIDIA-Linux-x86-173.14.12-pkg0/usr/src/nv/os-interface.c 2008-08-12 00:48:07.000000000 +0200
@@ -48,7 +48,11 @@
#endif
local_bh_disable();
atomic_set(&os_smp_barrier, 1);
+ #if LINUX_VERSION_CODE >= KERNEL_VERSION(2, 6, 27)
+ ret = smp_call_function(ipi_handler, NULL, 0);
+ #else
ret = smp_call_function(ipi_handler, NULL, 1, 0);
+ #endif
#endif
return (ret == 0) ? RM_OK : RM_ERROR;
}
@@ -704,7 +708,9 @@
U032 sig
)
{
+ #if LINUX_VERSION_CODE <= KERNEL_VERSION(2, 6, 26)
return kill_proc(pid, sig, 1) ? RM_ERR_OPERATING_SYSTEM : RM_OK;
+ #endif
}
/*******************************************************************************/

View File

@ -1,39 +0,0 @@
--- Makefile.kbuild.orig 2006-04-13 11:14:18.437632472 -0500
+++ Makefile.kbuild 2006-04-13 11:15:28.789937296 -0500
@@ -269,10 +269,10 @@
#
suser-sanity-check:
- @if ! $(CONFTEST) suser_sanity_check; then exit 1; fi
+ #@if ! $(CONFTEST) suser_sanity_check; then exit 1; fi
rmmod-sanity-check:
- @if ! $(CONFTEST) rmmod_sanity_check; then exit 1; fi
+ #@if ! $(CONFTEST) rmmod_sanity_check; then exit 1; fi
gcc-sanity-check:
@if ! $(CONFTEST) cc_sanity_check full_output; then exit 1; fi
@@ -311,9 +311,9 @@
#
module-install: suser-sanity-check module
- @mkdir -p $(MODULE_ROOT)/video; \
- install -m 0664 -o root -g root $(MODULE_OBJECT) $(MODULE_ROOT)/video; \
- PATH="$(PATH):/bin:/sbin" depmod -ae;
+ #@mkdir -p $(MODULE_ROOT)/video; \
+ #install -m 0664 -o root -g root $(MODULE_OBJECT) $(MODULE_ROOT)/video; \
+ #PATH="$(PATH):/bin:/sbin" depmod -ae;
#
# This target builds, then installs, then creates device nodes and inserts
@@ -321,8 +321,8 @@
#
package-install: module-install rmmod-sanity-check
- PATH="$(PATH):/bin:/sbin" modprobe $(MODULE_NAME) && \
- echo "$(MODULE_OBJECT) installed successfully.";
+ #PATH="$(PATH):/bin:/sbin" modprobe $(MODULE_NAME) && \
+ #echo "$(MODULE_OBJECT) installed successfully.";
#
# Build an object file suitable for further processing by the installer and