atanks: 3.0 -> 3.1

This commit is contained in:
Danny Rawlins 2008-08-16 21:03:05 +10:00
parent d4691fba2d
commit 6a7333b9e4
4 changed files with 18 additions and 18 deletions

View File

@ -1,3 +1,3 @@
88254f1c7efdcdb467d71e0589adaa75 atanks-3.0-install.patch
2aedfb58060d8958e1459cce9687acdd atanks-3.0-version-fix.patch
515ddfd70fb005d56aa0b509c4812ab8 atanks-3.0.tar.gz
8bc373f835bc325e86b978d635d5adc9 atanks-3.1-install.patch
3c3b3d1db196f0423c3530b07be2be8a atanks-3.1-version-fix.patch
16c46685a089e40f1dc69010b4d839a8 atanks-3.1.tar.gz

View File

@ -5,16 +5,16 @@
# Depends on: allegro
name=atanks
version=3.0
version=3.1
release=1
source=(http://dl.sourceforge.net/sourceforge/atanks/atanks-$version.tar.gz
atanks-$version-install.patch
atanks-$version-version-fix.patch)
source=(http://dl.sourceforge.net/sourceforge/$name/$name-$version.tar.gz
$name-3.1-install.patch
$name-3.1-version-fix.patch)
build() {
cd atanks
patch -p 1 -i $SRC/atanks-$version-install.patch
patch -p 1 -i $SRC/atanks-$version-version-fix.patch
cd $name
patch -p 1 -i $SRC/$name-3.1-install.patch
patch -p 1 -i $SRC/$name-3.1-version-fix.patch
make
make DESTDIR=$PKG install
}

View File

@ -1,6 +1,6 @@
diff -pruN atanks.orig/Makefile atanks/Makefile
--- atanks.orig/Makefile 2008-06-01 03:37:44.758709593 +1000
+++ atanks/Makefile 2008-06-01 04:43:35.237710360 +1000
--- atanks.orig/Makefile 2008-08-16 20:47:21.349143726 +1000
+++ atanks/Makefile 2008-08-16 20:52:17.435142915 +1000
@@ -1,17 +1,19 @@
VERSION=2.8
export VERSION
@ -27,8 +27,8 @@ diff -pruN atanks.orig/Makefile atanks/Makefile
rm -f atanks
$(MAKE) -C src clean
diff -pruN atanks.orig/src/Makefile atanks/src/Makefile
--- atanks.orig/src/Makefile 2008-06-01 03:37:44.780707681 +1000
+++ atanks/src/Makefile 2008-06-01 03:45:44.758709878 +1000
--- atanks.orig/src/Makefile 2008-08-16 20:47:21.346144525 +1000
+++ atanks/src/Makefile 2008-08-16 20:53:10.845145926 +1000
@@ -4,7 +4,7 @@ MODULES = \
globaldata.o environment.o player.o virtobj.o floattext.o teleport.o physobj.o decor.o explosion.o missile.o beam.o tank.o atanks.o fade.o perlin.o sky.o button.o files.o team.o satellite.o
@ -41,7 +41,7 @@ diff -pruN atanks.orig/src/Makefile atanks/src/Makefile
@@ -12,7 +12,6 @@ LFLAGS +=
LDFLAGS = `allegro-config --libs`
CFLAGS += -Wall -Iinclude # -fprofile-arcs -ftest-coverage
CFLAGS += -Wall -Wno-write-strings -Iinclude # -fprofile-arcs -ftest-coverage
-CFLAGS += -g # debug vs optimize flags
SRCS = $(MODULES:.o=.cc)

View File

@ -1,9 +1,9 @@
diff -pruN atanks.orig/Makefile atanks/Makefile
--- atanks.orig/Makefile 2008-06-01 03:37:44.758709593 +1000
+++ atanks/Makefile 2008-06-01 04:48:47.041706580 +1000
--- atanks.orig/Makefile 2008-08-16 20:47:21.349143726 +1000
+++ atanks/Makefile 2008-08-16 20:57:49.480142909 +1000
@@ -1,4 +1,4 @@
-VERSION=2.8
+VERSION=3.0
+VERSION=3.1
export VERSION
FILENAME=atanks-${VERSION}
INSTALL=/usr/bin/install -c