pugixml: 1.12 -> 1.12.1

This commit is contained in:
Tim Biermann 2022-02-16 13:02:10 +01:00
parent 52a84ffdc8
commit 6fd75b0aa0
Signed by: tb
GPG Key ID: 42F8B4E30B673606
3 changed files with 7 additions and 77 deletions

View File

@ -1,5 +1,5 @@
untrusted comment: verify with /etc/ports/contrib.pub
RWSagIOpLGJF39bcDMNch6zMgwoE5x6wZX76bPuz7lGfeI5HF9xMHqEq1GtyGD2WnIpRCk4SEgDeyvFUL37iV8lD/vE1am09Yw8=
SHA256 (Pkgfile) = 6be8aecc54c540510e1d23096a640a2483307dffc6bae1fa8ac210c0c3715eeb
RWSagIOpLGJF31sx/O4yRJi/vUpDpdHCHuqEAOIa3zKRq2NapQDn+Y1pptE+RjvFb/3/IeG6fVKF3ZTd+ggVJ7H3av53ds3bmQg=
SHA256 (Pkgfile) = 2d95e56788be77acf9128a4afc7e987a27eda0d26bedecd3c02edd160eaa2a92
SHA256 (.footprint) = f7a8a0edd472dbec9518e480a3a7f6d88828ccbeee67da1b80de9f8f5380ad23
SHA256 (pugixml-1.12.tar.gz) = fd6922a4448ec2f3eb9db415d10a49660e5d84ce20ce66b8a07e72ffc84270a7
SHA256 (pugixml-1.12.1.tar.gz) = dcf671a919cc4051210f08ffd3edf9e4247f79ad583c61577a13ee93af33afc7

View File

@ -4,13 +4,14 @@
# Depends on: cmake
name=pugixml
version=1.12
version=1.12.1
release=1
source=(http://github.com/zeux/pugixml/releases/download/v$version/$name-$version.tar.gz)
build() {
[[ -e /usr/bin/ninja ]] && PKGMK_PUGIXML+=' -G Ninja'
cmake -S $name-$version -B build $PKGMK_PUGIXML \
prt-get isinst ninja && PKGMK_PUGIXML+=' -G Ninja'
#cmake -S $name-$version -B build $PKGMK_PUGIXML \
cmake -S $name-${version:0:4} -B build $PKGMK_PUGIXML \
-D CMAKE_INSTALL_PREFIX=/usr \
-D CMAKE_INSTALL_LIBDIR=lib \
-D CMAKE_BUILD_TYPE=Release \

View File

@ -1,71 +0,0 @@
From 314dc6a95baaca90294a8ea957d9810e3bee0f62 Mon Sep 17 00:00:00 2001
From: Eli Schwartz <eschwartz93@gmail.com>
Date: Mon, 9 Apr 2018 01:46:30 -0400
Subject: [PATCH] cmake: always install the pkg-config file
There's really never a reason to *not* want this installed. If an option
is needed to specify installing in a versioned subdirectory, this option
should be explicitly described rather than hidden in something else.
As an added bonus, this makes the CMake install code slightly *less*
complicated.
---
CMakeLists.txt | 10 ++++------
scripts/pugixml.pc.in | 6 +++---
2 files changed, 7 insertions(+), 9 deletions(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 90fa6793..d7bc1b20 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -4,7 +4,7 @@ project(pugixml)
option(BUILD_SHARED_LIBS "Build shared instead of static library" OFF)
option(BUILD_TESTS "Build tests" OFF)
-option(BUILD_PKGCONFIG "Build in PKGCONFIG mode" OFF)
+option(USE_VERSIONED_LIBDIR "Use a private subdirectory to install the headers and libs" OFF)
set(BUILD_DEFINES "" CACHE STRING "Build defines")
@@ -55,7 +55,7 @@ endif()
set_target_properties(pugixml PROPERTIES VERSION 1.9 SOVERSION 1)
get_target_property(PUGIXML_VERSION_STRING pugixml VERSION)
-if(BUILD_PKGCONFIG)
+if(USE_VERSIONED_LIBDIR)
# Install library into its own directory under LIBDIR
set(INSTALL_SUFFIX /pugixml-${PUGIXML_VERSION_STRING})
endif()
@@ -71,10 +71,8 @@ install(TARGETS pugixml EXPORT pugixml-config
install(FILES ${HEADERS} DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}${INSTALL_SUFFIX})
install(EXPORT pugixml-config DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/pugixml)
-if(BUILD_PKGCONFIG)
- configure_file(scripts/pugixml.pc.in ${PROJECT_BINARY_DIR}/pugixml.pc @ONLY)
- install(FILES ${PROJECT_BINARY_DIR}/pugixml.pc DESTINATION ${CMAKE_INSTALL_PREFIX}/lib/pkgconfig)
-endif()
+configure_file(scripts/pugixml.pc.in ${PROJECT_BINARY_DIR}/pugixml.pc @ONLY)
+install(FILES ${PROJECT_BINARY_DIR}/pugixml.pc DESTINATION ${CMAKE_INSTALL_PREFIX}/lib/pkgconfig)
if(BUILD_TESTS)
file(GLOB TEST_SOURCES tests/*.cpp)
diff --git a/scripts/pugixml.pc.in b/scripts/pugixml.pc.in
index 3c97c28d..804c4d38 100644
--- a/scripts/pugixml.pc.in
+++ b/scripts/pugixml.pc.in
@@ -1,11 +1,11 @@
prefix=@CMAKE_INSTALL_PREFIX@
exec_prefix=${prefix}
-includedir=${prefix}/include/pugixml-@PUGIXML_VERSION_STRING@
-libdir=${exec_prefix}/lib/pugixml-@PUGIXML_VERSION_STRING@
+includedir=${prefix}/include@INSTALL_SUFFIX@
+libdir=${exec_prefix}/lib@INSTALL_SUFFIX@
Name: pugixml
Description: Light-weight, simple and fast XML parser for C++ with XPath support.
URL: http://pugixml.org/
Version: @PUGIXML_VERSION_STRING@
Cflags: -I${includedir}
-Libs: -L${libdir} -lpugixml
\ No newline at end of file
+Libs: -L${libdir} -lpugixml