ipcalc: go to 1.0.0 (this a different program, actually)

This commit is contained in:
Steffen Nurpmeso 2021-04-09 23:31:22 +02:00
parent 01908ade87
commit 7141604425
4 changed files with 74 additions and 20 deletions

View File

@ -1,7 +1,7 @@
drwxr-xr-x root/root usr/
drwxr-xr-x root/root usr/bin/
-rwxr-xr-x root/root usr/bin/ipcalc
drwxr-xr-x root/root usr/share/
drwxr-xr-x root/root usr/share/man/
drwxr-xr-x root/root usr/share/man/man1/
-rw-r--r-- root/root usr/share/man/man1/ipcalc.1.gz
drwxr-sr-x ports/ports usr/
drwxr-sr-x ports/ports usr/bin/
-rwxr-xr-x ports/ports usr/bin/ipcalc
drwxr-sr-x ports/ports usr/share/
drwxr-sr-x ports/ports usr/share/man/
drwxr-sr-x ports/ports usr/share/man/man1/
-rw-r--r-- ports/ports usr/share/man/man1/ipcalc.1.gz

View File

@ -1,5 +1,6 @@
untrusted comment: verify with /etc/ports/contrib.pub
RWSagIOpLGJF3yrjlYU1FjEoGgQmOgNWLo1K341ig5VDphTgm2CCmTg9cle+/6m/Sdc98x+Fsv2zO3Qh51mDQsqidFwdEdyuJw4=
SHA256 (Pkgfile) = 0e3ebae78e009f8eec275eea56a43039cb5bdea3e722b88b16890157ad8e73a5
SHA256 (.footprint) = 7afe696a7c62c307d705f3089bfdf168f6098e7ae4a97f173210ba2831f2eb53
SHA256 (ipcalc-0.41.tar.gz) = dda9c571ce3369e5b6b06e92790434b54bec1f2b03f1c9df054c0988aa4e2e8a
RWSagIOpLGJF30q8I0xEoj/WSmNlC+tC6GkTNo4xkEe16MoD2dFeKvfFuDktYcKD2b9foUN6OjMAi6TZTrEW81noXSGh9GoP3Qk=
SHA256 (Pkgfile) = 561626d802e53df8d50fa7c45ba0ce7ae6711556794e97bebdbebcc2263593fe
SHA256 (.footprint) = 86e0d7d2309cf7c62b8950a5f68b3001c1cf618127b306bde54f37049bf162b1
SHA256 (ipcalc-1.0.0.tar.bz2) = d7aca371335ab3e35364bcfe34cd0229db005be8bebb9236608ec318cb3f7748
SHA256 (build.patch) = 15cb7289cdc104b34e43f447df1ce70ca97b510a9b7058aee4ab3472a3827b6c

View File

@ -1,18 +1,23 @@
# Description: ipcalc: calculate IPv4 broadcast, network and host range.
# URL: http://jodies.de/ipcalc
# Description: ipcalc: calculate IPv4/6 broadcast, network and host range.
# URL: https://gitlab.com/ipcalc/ipcalc
# Maintainer: Steffen Nurpmeso, steffen at sdaoden dot eu
name=ipcalc
version=0.41
version=1.0.0
release=1
source=(http://jodies.de/${name}-archive/${name}-${version}.tar.gz)
source=(https://gitlab.com/${name}/${name}/-/archive/${version}/\
${name}-${version}.tar.bz2 build.patch)
build() {
cd ${name}-${version}
#
patch -Np1 -i "${SRC}"/build.patch
meson setup build
ninja -C build
cat > ./ipcalc.1 <<- \!
.Dd January 4, 2021
.Dd April 9, 2021
.Dt IPCALC 1
.Os
.
@ -22,11 +27,10 @@ build() {
.
.Bd -literal
!
perl ipcalc >> ./ipcalc.1
cat ipcalc.1.md >> ./ipcalc.1
echo '.Ed' >> ./ipcalc.1
install -D -m 0755 ipcalc "${PKG}"/usr/bin/${name}
install -D -m 0755 build/ipcalc "${PKG}"/usr/bin/${name}
install -D -m 0644 ipcalc.1 "${PKG}"/usr/share/man/man1/${name}.1
}

49
ipcalc/build.patch Normal file
View File

@ -0,0 +1,49 @@
commit 322294d7bf61f9fdf0e45e9b6c6013a7c6a35bfd
Author: Derrick Lyndon Pallas <derrick@meter.com>
AuthorDate: 2020-10-14 18:25:54 +0000
Commit: Derrick Lyndon Pallas <derrick@meter.com>
CommitDate: 2020-10-14 18:33:24 +0000
Do not fail to build if ronn is missing
If ruby-ronn is missing, we can not compile the man page from markdown but
that should not prevent the application from building.
Signed-off-by: Derrick Lyndon Pallas <derrick@meter.com>
---
meson.build | 23 ++++++++++++-----------
1 file changed, 12 insertions(+), 11 deletions(-)
diff --git a/meson.build b/meson.build
index a2169fc17d..981d4a424f 100644
--- a/meson.build
+++ b/meson.build
@@ -72,16 +72,17 @@ ipcalc = executable('ipcalc',
install : true
)
-ronn = find_program('ronn', required: true)
-
-ipcalc_1 = custom_target(
- 'ipcalc.1',
- output : 'ipcalc.1',
- input : 'ipcalc.1.md',
- command : [ronn, '--pipe', '-r', '@INPUT@'],
- capture: true,
- install_dir: join_paths(get_option('mandir'), 'man1'),
- install: true
-)
+ronn = find_program('ronn', required: false)
+if ronn.found()
+ ipcalc_1 = custom_target(
+ 'ipcalc.1',
+ output : 'ipcalc.1',
+ input : 'ipcalc.1.md',
+ command : [ronn, '--pipe', '-r', '@INPUT@'],
+ capture: true,
+ install_dir: join_paths(get_option('mandir'), 'man1'),
+ install: true
+ )
+endif
subdir('tests')