nss_ldap: deleted unmaintained port

This commit is contained in:
Tim Biermann 2021-03-04 09:07:36 +00:00
parent ae3b3c30ad
commit 719e9bb68d
Signed by: tb
GPG Key ID: 42F8B4E30B673606
4 changed files with 0 additions and 61 deletions

View File

@ -1,13 +0,0 @@
drwxr-xr-x root/root etc/
-rw-r--r-- root/root etc/nss_ldap.conf
-rw-r--r-- root/root etc/nsswitch.ldap
drwxr-xr-x root/root lib/
-rwxr-xr-x root/root lib/libnss_ldap-2.28.so
lrwxrwxrwx root/root lib/libnss_ldap.so.2 -> libnss_ldap-2.28.so
drwxr-xr-x root/root usr/
drwxr-xr-x root/root usr/lib/
lrwxrwxrwx root/root usr/lib/libnss_ldap.so.2 -> ../../lib/libnss_ldap.so.2
drwxr-xr-x root/root usr/share/
drwxr-xr-x root/root usr/share/man/
drwxr-xr-x root/root usr/share/man/man5/
-rw-r--r-- root/root usr/share/man/man5/nss_ldap.5.gz

View File

@ -1,6 +0,0 @@
untrusted comment: verify with /etc/ports/contrib.pub
RWSagIOpLGJF32nM2vTI0kRmiSzv2f/uKv7w1LgW1e50QDHJxo8hEkeVVlh0rR4NPXezfm30X6eHacxj8qzSDXxUJArkMLYeZQ8=
SHA256 (Pkgfile) = 27d5f2c4b464a051f2cb94a62a594d67aeeedaee2f38a0f0d4a7a0b15db52e99
SHA256 (.footprint) = 65948f6df1182bb97a0b1b1a484c973902260900ebdb147fb0518399ab4a1b30
SHA256 (154730b5a2b58a4212e419b498476fcb5a60de7b.tar.gz) = 78127d836d75d635037d09cead6709f3d0686d75e7fc89bf780527d9dba8b806
SHA256 (nss_ldap-249-sasl-compile.patch) = 3da93087461fb970d5da9fe6b169f5493ca83ae2149cb03be9e8486bfcf437d6

View File

@ -1,31 +0,0 @@
# Description: LDAP NSS module
# URL: https://arthurdejong.org/nss-pam-ldapd/
# Maintainer: Alan Mizrahi, alan at mizrahi dot com dot ve
# Depends on: openldap krb5
name=nss_ldap
version=266
release=1
_commit=154730b5a2b58a4212e419b498476fcb5a60de7b
source=(https://github.com/PADL/nss_ldap/archive/$_commit.tar.gz
nss_ldap-249-sasl-compile.patch)
build() {
cd $name-$_commit
patch -p0 -i $SRC/nss_ldap-249-sasl-compile.patch
sed -i -e 's|CVSVERSIONDIR=\$(top_srcdir) vers_string|CVSVERSIONDIR=\$(top_srcdir) ./vers_string|g' Makefile.am Makefile.in
export PERL5LIB="$PWD"
./configure \
--prefix=/usr \
--libdir=/lib \
--sysconfdir=/etc \
--mandir=/usr/share/man \
--with-ldap-lib=openldap \
--with-ldap-conf-file=/etc/nss_ldap.conf
make
mkdir -p $PKG/lib
make DESTDIR=$PKG install
}

View File

@ -1,11 +0,0 @@
--- ldap-nss.c~ 2006-02-25 02:43:33.503639826 -0800
+++ ldap-nss.c 2006-02-25 02:50:51.943806612 -0800
@@ -72,6 +72,8 @@
#include <sasl/sasl.h>
#elif defined(HAVE_SASL_H)
#include <sasl.h>
+#elif defined(HAVE_SASL_SASL_H)
+#include <sasl/sasl.h>
#endif
#ifndef HAVE_SNPRINTF