zathura-pdf-mupdf: 0.4.2 -> 0.4.3
This commit is contained in:
parent
b6c522f77c
commit
73ddc83c5c
zathura-pdf-mupdf
@ -1,6 +1,5 @@
|
||||
untrusted comment: verify with /etc/ports/contrib.pub
|
||||
RWSagIOpLGJF334X2krEs9D1+dNPUEZca+ujSy4IRmufHCTFJ31ThvENklh7VPwY/oZsSSMBQTKtrhsbtlVkaToZk5mvQfqYjgg=
|
||||
SHA256 (Pkgfile) = 31f4838ff488208862c2930739802b536dc78cc365493237f090862bf3f3e9e3
|
||||
RWSagIOpLGJF37IeTQM17yHu0EnQHioFwrahSoUvCgnWYJHiZno54K16F+BPFz/YwRS/U/jhLh9Wg6adwZL3O2DTBhnxc+Lmvwc=
|
||||
SHA256 (Pkgfile) = 917e8cda4e893dcfc72b4a2e27fd82f7abff2f934a54d4d70c7ea30848c8de91
|
||||
SHA256 (.footprint) = 6afe2b8de941c5d7fb3d0692f5260d9b8c733331a338279d2844dbd692db7add
|
||||
SHA256 (zathura-pdf-mupdf-0.4.2.tar.gz) = 71e06a3e2dfbae48c01fd6bb2261dedbda2e2774748f20f56f89d8a440489718
|
||||
SHA256 (0001-Remove-mupdf-linking-detection.patch) = 8b51563a782a7dea38711335354bf65e2303b06bfecacf9cc060ecfc7b0851b8
|
||||
SHA256 (zathura-pdf-mupdf-0.4.3.tar.gz) = 2bebf6c482f3b346badfb16fb703309fd97f7fa12f17b87293e9beb05d815508
|
||||
|
@ -1,76 +0,0 @@
|
||||
From e91e5ad64d20eb4a7df377effc12ec21ba6f5f7c Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Johannes=20L=C3=B6thberg?= <johannes@kyriasis.com>
|
||||
Date: Fri, 18 Mar 2022 00:02:43 +0100
|
||||
Subject: [PATCH] Remove mupdf linking detection
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
Signed-off-by: Johannes Löthberg <johannes@kyriasis.com>
|
||||
---
|
||||
meson.build | 40 ++++++++++++++--------------------------
|
||||
1 file changed, 14 insertions(+), 26 deletions(-)
|
||||
|
||||
diff --git a/meson.build b/meson.build
|
||||
index c8c19dc..8174431 100644
|
||||
--- a/meson.build
|
||||
+++ b/meson.build
|
||||
@@ -19,8 +19,6 @@ zathura = dependency('zathura', version: '>=0.3.9')
|
||||
girara = dependency('girara-gtk3')
|
||||
glib = dependency('glib-2.0')
|
||||
cairo = dependency('cairo')
|
||||
-mupdf = dependency('mupdf', required: false)
|
||||
-mupdfthird = cc.find_library('mupdf-third')
|
||||
|
||||
build_dependencies = [
|
||||
zathura,
|
||||
@@ -29,32 +27,22 @@ build_dependencies = [
|
||||
cairo,
|
||||
]
|
||||
|
||||
-if not mupdf.found()
|
||||
- # normal build of mupdf
|
||||
- mupdf = cc.find_library('mupdf')
|
||||
- build_dependencies += [mupdf, mupdfthird]
|
||||
-else
|
||||
- # build from Debian's libmupdf-dev
|
||||
- build_dependencies += [mupdf, mupdfthird]
|
||||
+mupdf = cc.find_library('mupdf')
|
||||
+mupdfthird = cc.find_library('mupdf-third')
|
||||
|
||||
- libjpeg = dependency('libjpeg')
|
||||
- libjbig2dec = cc.find_library('jbig2dec')
|
||||
- libopenjp2 = dependency('libopenjp2')
|
||||
- gumbo = dependency('gumbo')
|
||||
- tesseract = dependency('tesseract')
|
||||
- leptonica = dependency('lept')
|
||||
- mujs = dependency('mujs')
|
||||
+libjpeg = dependency('libjpeg')
|
||||
+libjbig2dec = cc.find_library('jbig2dec')
|
||||
+libopenjp2 = dependency('libopenjp2')
|
||||
+gumbo = dependency('gumbo')
|
||||
|
||||
- build_dependencies += [
|
||||
- libjpeg,
|
||||
- libjbig2dec,
|
||||
- libopenjp2,
|
||||
- gumbo,
|
||||
- tesseract,
|
||||
- leptonica,
|
||||
- mujs
|
||||
- ]
|
||||
-endif
|
||||
+build_dependencies += [
|
||||
+ mupdf,
|
||||
+ mupdfthird,
|
||||
+ libjpeg,
|
||||
+ libjbig2dec,
|
||||
+ libopenjp2,
|
||||
+ gumbo,
|
||||
+]
|
||||
|
||||
if get_option('plugindir') == ''
|
||||
plugindir = zathura.get_pkgconfig_variable('plugindir')
|
||||
--
|
||||
2.35.1
|
||||
|
@ -4,14 +4,11 @@
|
||||
# Depends on: mujs mupdf zathura
|
||||
|
||||
name=zathura-pdf-mupdf
|
||||
version=0.4.2
|
||||
version=0.4.3
|
||||
release=1
|
||||
source=(https://github.com/pwmt/zathura-pdf-mupdf/archive/$version/$name-$version.tar.gz
|
||||
0001-Remove-mupdf-linking-detection.patch)
|
||||
source=(https://github.com/pwmt/zathura-pdf-mupdf/archive/$version/$name-$version.tar.gz)
|
||||
|
||||
build() {
|
||||
patch -Np1 -d $name-$version -i $SRC/0001-Remove-mupdf-linking-detection.patch
|
||||
|
||||
meson setup $name-$version build \
|
||||
--prefix=/usr \
|
||||
--sysconfdir=/etc \
|
||||
|
Loading…
x
Reference in New Issue
Block a user