asterisk: Updated version 1.4.29.1 -> 1.4.35

This commit is contained in:
Alan Mizrahi 2010-09-13 18:05:43 +09:00
parent 83005482da
commit 7579eeabe2
6 changed files with 9 additions and 102 deletions

View File

@ -147,6 +147,7 @@ drwxr-xr-x root/root usr/include/asterisk/
-rw-r--r-- root/root usr/include/asterisk/strings.h
-rw-r--r-- root/root usr/include/asterisk/tdd.h
-rw-r--r-- root/root usr/include/asterisk/term.h
-rw-r--r-- root/root usr/include/asterisk/test.h
-rw-r--r-- root/root usr/include/asterisk/threadstorage.h
-rw-r--r-- root/root usr/include/asterisk/time.h
-rw-r--r-- root/root usr/include/asterisk/tonezone_compat.h

View File

@ -1,6 +1,3 @@
262781104d7ef2d43adb6d04765d7923 1.4-gsm-gcc4.2.patch
7385cdc587b0795f112ba9a3c213d662 asterisk-1.4.29.1.tar.gz
0a0f9d6a5bfd76c0b14e985552765122 asterisk-1.4.35.tar.gz
79576bd629adb76950b756f29c56d4cf asterisk-config.patch
19b6ab4e74bfbe5cfd920338569caebb asterisk-mmx.patch
291cdd8cdfa6cf72cb48404ab4e6556b asterisk.rc
7989268cec9053dff54488035fa8927c voicemail.patch

View File

@ -1,18 +0,0 @@
diff -Naur asterisk-1.4.17.orig/codecs/gsm/Makefile asterisk-1.4.17/codecs/gsm/Makefile
--- asterisk-1.4.17.orig/codecs/gsm/Makefile 2007-02-16 19:31:42.000000000 -0500
+++ asterisk-1.4.17/codecs/gsm/Makefile 2008-01-15 13:23:37.000000000 -0500
@@ -37,6 +37,14 @@
######### ppro's, etc, as well as the AMD K6 and K7. The compile will
######### probably require gcc.
+# Due to the gsm codec beeing broken when compiled with gcc version 4.2
+# and optimization higher than -O2 we are checking for that version and
+# set the optimization to -O2 in this case.
+
+ifeq ($(shell gcc -v 2>&1 | grep "gcc version" | cut -c 13-16 ),4.2.)
+OPTIMIZE=-O2
+endif
+
ifeq (, $(findstring $(OSARCH) , Darwin SunOS ))
ifeq (, $(findstring $(PROC) , x86_64 amd64 ultrasparc sparc64 arm armv5b armeb ppc powerpc ppc64 ia64 s390 bfin mipsel ))
ifeq (, $(findstring $(shell uname -m) , ppc ppc64 alpha armv4l s390 ))

View File

@ -4,9 +4,13 @@
# Depends on: openssl, ncurses
name=asterisk
version=1.4.29.1
release=5
source=(http://downloads.digium.com/pub/$name/releases/$name-$version.tar.gz asterisk.rc asterisk-mmx.patch 1.4-gsm-gcc4.2.patch voicemail.patch asterisk-config.patch)
version=1.4.35
release=1
source=(
http://downloads.digium.com/pub/$name/releases/$name-$version.tar.gz
asterisk.rc
asterisk-config.patch
)
build () {
cd $name-$version
@ -14,16 +18,6 @@ build () {
# Menuselect configuration patch to remove default sounds and moh
patch -p1 -i $SRC/asterisk-config.patch
# Fixes choppy gsm transcoding when using gcc 4.2
patch -p1 -i $SRC/1.4-gsm-gcc4.2.patch
# patch -p0 -i $SRC/voicemail.patch
# Check if this processor supports MMX instruction set
# if [ -n "`grep '^flags.*mmx' /proc/cpuinfo`" ]; then
# patch -p1 -i $SRC/asterisk-mmx.patch
# fi
./configure --prefix=/usr --with-ncurses --with-ssl
make
make DESTDIR=$PKG install

View File

@ -1,11 +0,0 @@
--- asterisk-1.4.26.2/Makefile.rules.orig 2009-09-09 15:52:34.063291569 -0430
+++ asterisk-1.4.26.2/Makefile.rules 2009-09-09 15:52:46.814961322 -0430
@@ -42,7 +42,7 @@
# Uncomment to enable MMXTM optimizations for x86 architecture CPU's
# which support MMX instructions. This should be newer pentiums,
# ppro's, etc, as well as the AMD K6 and K7.
- #K6OPT=-DK6OPT
+ K6OPT=-DK6OPT
ASTCFLAGS+=$(OPTIMIZE)
endif

View File

@ -1,56 +0,0 @@
Index: apps/app_voicemail.c
===================================================================
--- apps/app_voicemail.c (revision 188040)
+++ apps/app_voicemail.c (working copy)
@@ -8846,7 +8846,10 @@
{
int res;
char *adsi_loaded = ast_module_helper("", "res_adsi.so", 0, 0, 0, 0);
+ char *smdi_loaded = ast_module_helper("", "res_smdi.so", 0, 0, 0, 0);
free(adsi_loaded);
+ free(smdi_loaded);
+
if (!adsi_loaded) {
/* If embedded, res_adsi may be known as "res_adsi" not "res_adsi.so" */
adsi_loaded = ast_module_helper("", "res_adsi", 0, 0, 0, 0);
@@ -8857,6 +8860,16 @@
}
}
+ if (!smdi_loaded) {
+ /* If embedded, res_smdi may be known as "res_smdi" not "res_smdi.so" */
+ smdi_loaded = ast_module_helper("", "res_smdi", 0, 0, 0, 0);
+ ast_free(smdi_loaded);
+ if (!smdi_loaded) {
+ ast_log(LOG_ERROR, "app_voicemail.so depends upon res_smdi.so\n");
+ return AST_MODULE_LOAD_DECLINE;
+ }
+ }
+
my_umask = umask(0);
umask(my_umask);
res = ast_register_application(app, vm_exec, synopsis_vm, descrip_vm);
Index: res/res_smdi.c
===================================================================
--- res/res_smdi.c (revision 188040)
+++ res/res_smdi.c (working copy)
@@ -1313,6 +1313,8 @@
.read = smdi_msg_read,
};
+static int unload_module(void);
+
static int load_module(void)
{
int res;
@@ -1330,8 +1332,10 @@
/* load the config and start the listener threads*/
res = smdi_load(0);
if (res < 0) {
+ unload_module();
return res;
} else if (res == 1) {
+ unload_module();
ast_log(LOG_WARNING, "No SMDI interfaces are available to listen on, not starting SMDI listener.\n");
return AST_MODULE_LOAD_DECLINE;
}